CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] Splitting Edge (airfoil meshing) (http://www.cfd-online.com/Forums/ansys-meshing/101852-splitting-edge-airfoil-meshing.html)

James Hetfield May 15, 2012 13:31

Splitting Edge (airfoil meshing)
 
1 Attachment(s)
Hello everybody

I've got a problem with "Split Edge" in ICEM 14
based on the tutorial provided by Simon (3 parts) I can do the Edit Edge-->Split Edge for those two edges inside the airfoil so they will be projected on the airfoil curves. (I've attached the picture after doing this)
but I wanna do a smoother Split. I mean as you can see in the figure, there are sharp facets that I want do a better job with splitting edges to get rid of them and have a smoother edges. (because theses facets are killers for drag coefficient calculation)

does anyone know how to do Splitting Edge smoother?

Far May 15, 2012 14:17

Well CFD by nature is not smooth. That's why we call it dicretized solution as compared to exact solution.

split edge has nothing to do with smoothness. It all related to basic CFD

James Hetfield May 15, 2012 14:26

I know that, but these facets that are approximating the airfoil surface should be smoother than this (they should be shorter lines so they can be put on the airfoil surface more precisely)

if you dont do that, the nature of flow will be changed too much and will change the drag and lift coefficients

PSYMN May 16, 2012 09:11

Solutions...
 
Yes, there are at least a couple of ways you can solve the problem...

1) Yes, ICEM CFD does usually facetize the geometry to make display and projection quicker. You can control this with "Settings => Model => Triangulation" Change it from 0.001 to 0.0000001 and see how that looks.

2) But you don't need to have the mesh project to the facets, you can project to the actual bspline geometry. This setting is used in high end turbo applications for exactly this reason that James is concerned about. To do that, go to "Settings => Meshing options => Hexa/Mixed => Project to Bsplines...

Best regards,

Simon

Far May 16, 2012 09:14

I didn't know that. But in this way we are looking for accuracy at micron level, which may not be possible in actual geometry. isn't it?

PSYMN May 16, 2012 09:17

The Bspline geometry is mathematically precise... (well beyond the micron level), but you actually don't get any better than your final mesh resolution (since you are using linear elements).

James Hetfield May 16, 2012 12:56

Simon, I really dont know how to thank you

THANKS A LOT

James Hetfield May 16, 2012 12:57

Far, thank you too for responding to my posts all the time and helping me

really appreciate it

James Hetfield May 16, 2012 14:08

Quote:

Originally Posted by PSYMN (Post 361430)
The Bspline geometry is mathematically precise... (well beyond the micron level), but you actually don't get any better than your final mesh resolution (since you are using linear elements).

I have another question Simon
when I follow your tutorial, when I wanna do the Automatic Linear Split Edge, sometimes it does not work and sometimes works :eek:

what is the problem?

James Hetfield May 16, 2012 14:31

Quote:

Originally Posted by PSYMN (Post 361424)
Yes, there are at least a couple of ways you can solve the problem...

1) Yes, ICEM CFD does usually facetize the geometry to make display and projection quicker. You can control this with "Settings => Model => Triangulation" Change it from 0.001 to 0.0000001 and see how that looks.

2) But you don't need to have the mesh project to the facets, you can project to the actual bspline geometry. This setting is used in high end turbo applications for exactly this reason that James is concerned about. To do that, go to "Settings => Meshing options => Hexa/Mixed => Project to Bsplines...

Best regards,

Simon

OK, I set these options
now, what should I do? the same procedure as explained in the tutorial (Edit Edge--> Automatic Linear?) ?

besides, sometimes Automatic Linear doesnt work for me and I dont know why :(

Ananthakrishnan May 16, 2012 18:00

A common mistake would be to use automatic linear without applying any nodes on the edges..In that case ICEm will be projecting the two points of the edge(default number of nodes) on to the curves..Try updating the edge parameters and then using the auto linear option..
This is what happened to me..

James Hetfield May 16, 2012 19:30

2 Attachment(s)
Another question:

when I generate the grid, the lines that go off the wall (airfoil surface) are not normal to it (even after smoothing) :confused:
I have attached the picture near to the surface

Am I doing something wrong???
what options should I use while smoothing? (Grid Expansion or others....???)

PSYMN May 17, 2012 12:24

Ananthakrishnan was right about the automatic linear...

Orthogonality is what you are looking for in your latest querry.

The hexahedral smoother can improve orthogonality, but you can also improve it with better edge/vertex locations or shapes or improving the match between distributions on opposite sides of the body.

Some times, there isn't much you can do about it except relax and be glad that most solvers can handle it.


All times are GMT -4. The time now is 13:43.