CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ANSYS Meshing] Mesh sizing (

Kirjain June 19, 2012 03:56

Mesh sizing
1 Attachment(s)
Hello all,

I am having problems with meshing a simple pipe structure. I split the cylindrical volume in five parts in Design Modeller in order to generate a classical mesh but when I give sizing commands to the mesh ANSYS Meshing refuses to obey them. What might be the reason for the programme's behaviour? I attached a figure to this post so you can see what I am writing about.

So basically I am trying to generate a mesh with elements of the same size (i.e. evenly spaced) all around the pipe wall but I have only succeeded in obtaining a mesh that grows denser at the edges of each part (they should be conformal, though, as I have used the form-new-part command after splitting the original body).

Can anyone help me with this? Is there an obvious mistake that I am making?


chris85 June 19, 2012 04:24

Looks from the image you have a bias set for the edges which go from the central area to the pipe wall. Certainly looks like a bias judging by the spacing of the edges.

Need to change the edge sizing you have there to no bias. See how that works.

Kirjain June 19, 2012 08:40

But surely that should not affect the density of the mesh near the internal edges between the parts of the fluid body? The bias is set in order to accurately analyse boundary layer phenomena and the element size should decrease toward the outer rim or the fluid body.

chris85 June 19, 2012 09:36

Ok but you say you want elements of same size all around the pipe wall which they look ok. is it more the domain in the centre of the pipe you are concerned about.

Kirjain June 20, 2012 06:27

Sorry, I realise I haven't stated my question clearly enough. When you look at the mesh around the central part of the fluid body you will see that it becomes denser in the vicinity of the four edges connecting the curved parts of the fluid body (shown on the right of the image attached to my first message). This is what I would like to get rid of as it seems silly to cram in more elements where there is no real border between different fluid parts (i.e. no need for more detailed calculation). To do this I have inserted the sizing command shown on the left of the image and you can see there is no bias set at all. Still, for some reason, the elements of the mesh created are not evenly spaced. At this stage I am not concerned about the central part of the fluid body at all as I will deal with it later on.

I appreciate all the help you can give me with this problem!

chris85 June 20, 2012 06:32

have a look at inflation options in the general mesh options and see if this helps.

PSYMN June 23, 2012 14:50

Try setting the sizing to "Hard" instead of "Soft". It thinks it is doing you a favor by adjusting the distribution to match the smaller size mesh you have in the radial direction... Setting the sizing to "hard" should force it to follow your controls more precisely.

All times are GMT -4. The time now is 19:21.