CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[ANSYS Meshing] Mesh sizing

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 19, 2012, 03:56
Default Mesh sizing
  #1
New Member
 
Anna
Join Date: Jun 2012
Location: Finland
Posts: 19
Rep Power: 5
Kirjain is on a distinguished road
Hello all,

I am having problems with meshing a simple pipe structure. I split the cylindrical volume in five parts in Design Modeller in order to generate a classical mesh but when I give sizing commands to the mesh ANSYS Meshing refuses to obey them. What might be the reason for the programme's behaviour? I attached a figure to this post so you can see what I am writing about.

So basically I am trying to generate a mesh with elements of the same size (i.e. evenly spaced) all around the pipe wall but I have only succeeded in obtaining a mesh that grows denser at the edges of each part (they should be conformal, though, as I have used the form-new-part command after splitting the original body).

Can anyone help me with this? Is there an obvious mistake that I am making?

Cheers.
Attached Images
File Type: jpg pipe.jpg (24.1 KB, 45 views)
Kirjain is offline   Reply With Quote

Old   June 19, 2012, 04:24
Default
  #2
New Member
 
Chris
Join Date: Nov 2011
Posts: 19
Rep Power: 5
chris85 is on a distinguished road
Looks from the image you have a bias set for the edges which go from the central area to the pipe wall. Certainly looks like a bias judging by the spacing of the edges.


Need to change the edge sizing you have there to no bias. See how that works.
chris85 is offline   Reply With Quote

Old   June 19, 2012, 08:40
Default
  #3
New Member
 
Anna
Join Date: Jun 2012
Location: Finland
Posts: 19
Rep Power: 5
Kirjain is on a distinguished road
But surely that should not affect the density of the mesh near the internal edges between the parts of the fluid body? The bias is set in order to accurately analyse boundary layer phenomena and the element size should decrease toward the outer rim or the fluid body.
Kirjain is offline   Reply With Quote

Old   June 19, 2012, 09:36
Default
  #4
New Member
 
Chris
Join Date: Nov 2011
Posts: 19
Rep Power: 5
chris85 is on a distinguished road
Ok but you say you want elements of same size all around the pipe wall which they look ok. is it more the domain in the centre of the pipe you are concerned about.
chris85 is offline   Reply With Quote

Old   June 20, 2012, 06:27
Default
  #5
New Member
 
Anna
Join Date: Jun 2012
Location: Finland
Posts: 19
Rep Power: 5
Kirjain is on a distinguished road
Sorry, I realise I haven't stated my question clearly enough. When you look at the mesh around the central part of the fluid body you will see that it becomes denser in the vicinity of the four edges connecting the curved parts of the fluid body (shown on the right of the image attached to my first message). This is what I would like to get rid of as it seems silly to cram in more elements where there is no real border between different fluid parts (i.e. no need for more detailed calculation). To do this I have inserted the sizing command shown on the left of the image and you can see there is no bias set at all. Still, for some reason, the elements of the mesh created are not evenly spaced. At this stage I am not concerned about the central part of the fluid body at all as I will deal with it later on.

I appreciate all the help you can give me with this problem!
Kirjain is offline   Reply With Quote

Old   June 20, 2012, 06:32
Default
  #6
New Member
 
Chris
Join Date: Nov 2011
Posts: 19
Rep Power: 5
chris85 is on a distinguished road
have a look at inflation options in the general mesh options and see if this helps.
chris85 is offline   Reply With Quote

Old   June 23, 2012, 14:50
Default
  #7
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 35
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
Try setting the sizing to "Hard" instead of "Soft". It thinks it is doing you a favor by adjusting the distribution to match the smaller size mesh you have in the radial direction... Setting the sizing to "hard" should force it to follow your controls more precisely.
__________________
-----------------------------------------
Please help guide development at ANSYS by filling in these surveys

Public ANSYS ICEM CFD Users Survey

This second one is more general (Gambit, TGrid and ANSYS Meshing users welcome)...

CFD Online Users Survey
PSYMN is offline   Reply With Quote

Reply

Tags
ansys meshing, evenly spaced, mesh sizing

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Number of cells in mesh don't match with size of cellLevel colinB OpenFOAM Native Meshers: snappyHexMesh and Others 11 January 13, 2015 12:47
engrid -> save as .stl with boundarie codes Zymon enGrid 31 August 29, 2011 13:40
2d irregular grid Remy Main CFD Forum 1 December 22, 2008 05:49
fluent add additional zones for the mesh file SSL FLUENT 2 January 26, 2008 12:55
basic of mesh refinement arya CFX 4 June 19, 2007 12:21


All times are GMT -4. The time now is 04:01.