CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ANSYS Meshing] Meshing a t-pipe in Ansys Meshing (

Kirjain August 6, 2012 02:03

Meshing a t-pipe in Ansys Meshing
1 Attachment(s)
I would need help with meshing a simple t-pipe with ANSYS Meshing. I have split both the arm and the mainline into o-grid configurations and applied symmetry along the zy-plane (see figure). My problem is that I can't use the sweep method on all the parts created (the uppermost part of the mainline cannot be sweeped as it's connected to the arm) and I don't know how to get around this problem. I'm quite new to meshing in general and don't yet know too much so please be patient wit my stupid questions!
What would be the best way out of this problem? Can I define the arm and the mainline as different bodies (forming two parts in DM) or will this mess up the connection between the meshes? Or would a non-conformal mesh do the trick and if so, how would I go about creating one?

Another thing I would like to ask is related to post processing and grid visualisations. Is there any way (either in Ansys Meshing or in FLUENT) I could get out clear good images of the computational mesh, without the Ansys logo hanging about or the horrible colour-gradient background looming behind the body? I'm looking for something simple: black and white images of the surface mesh and a few figures of the inner mesh maybe.

Cheers for helping me out!


flotus1 August 6, 2012 02:43

About the appearance isues:

In workbench, click on "tools -> "options" and go to the "appearance" tab.
Here you can set the backgraund to "solid" and change the colour.
The Ansys logo cannot be switched off if you use any noncommercial version.

PSYMN August 7, 2012 09:09

1 Attachment(s)
Right, you can turn off the logo with the commercial version, but not the academic...

If you have this model split up into 2 parts DM (one straight pipe and one pipe Tconnected to the surface of the first) you can hold down the control key and select the parts in the tree, then right click to "form new part". This will create a conformal multibody part.

If it is having trouble sweeping, you can add virtual edge/face splits or try sequential meshing to make sure it meshes the right part first... This image shows how to handle a small pipe with fine mesh connected to a coarser pipe... The mesh pattern of the little pipe is actually swept across the larger pipe.
Attachment 15054

Of-course, this sort of geometry is best done in ICEM CFD hexa where you have excellent meshing control and Ogrids to make it easy.

Kirjain August 8, 2012 03:57

So you're suggesting I should abandon the o-grid and just mesh with two bodies? Wouldn't that reduce the quality of the grid drastically? How would I go about creating a virtual edge or face split? Couldn't I try doing the same with o-grids as well?

At the moment I am just trying to split the problematic bodies (of the mainline just underneath the junction) in order to enable sweeping but it's not going the way I'd want it to. Basically I just end up with an error stating there's something wrong with my settings and that I should change them, without telling me where the problem is exactly.

Unfortunately I don't have access to ICEM CFD and have to make due with Ansys Meshing..!

Kirjain August 14, 2012 04:50

2 Attachment(s)

I managed to split the geometry down so that all the bodies can be meshed with hexa elements. I attached an image of it but of course there must be many more sophisticated ways of doing what I did.

Anyway, as I was meshing this geometry I encountered a new problem: multiple edges. If I try to select all the edges of a part (take a look at image 2), I end up with more edges selected than are visible. How could I prevent this from happening? The actual problem is that the extra edges completely mess about with the sizing functions and the elements become horribly skewed, ruining the mesh.

Is there any explanation to why there are "hidden" edges in a geometry? I couldn't work out where they had come from when I looked at my original geometry in DM.

Thank you for any assistance!

flotus1 August 14, 2012 05:15

I suppose if you split a body, the result are two bodies, each with one face at the interface. The same happens with the edges.
Did you "form a new part" in design modeler after splitting the geometry. I think this would prevent multiple edges and faces.

If your problem is only the selection of the edges, then hide all the other bodies while picking the edges.

BWT: Congratulations for your zen-like patience blocking this geometry by hand.

Kirjain August 15, 2012 02:03

Cheers, I had only forgotten to make a new part of the bodies created. All's working semi-all-right at the moment, though, thank you for helping me out Alex and Simon.

And yes indeed, it was quite tough trying to block the pipe geometry manually. Still I reckon there would be a way of doing it more easily, if only I knew how..!

All times are GMT -4. The time now is 04:04.