CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [GAMBIT] Mesh Not Generate (http://www.cfd-online.com/Forums/ansys-meshing/106394-mesh-not-generate.html)

alimisaghian August 28, 2012 01:00

Mesh Not Generate
 
Hi , i am modeling a granullar bed reactor. i have made the geometry that consist of the chamber and the granuls . the chamber Diameter is 25 cm and the granuls are 3mm Diameter. when i try to mesh it in gambit , it fails to mesh. please help me. What to do:o

-mAx- August 28, 2012 02:48

any pictures or more details on errors given from Gambit?

alimisaghian August 28, 2012 02:56

1 Attachment(s)
here a pic

-mAx- August 28, 2012 02:59

2d or 3d?
did you use a size function for refinining at holes?

alimisaghian August 28, 2012 03:06

it is 2d , no idont know how to use that

alimisaghian August 28, 2012 03:12

fluid will come from the top , and those circles are the solid granul. fluid will pass through them and will exit from bottom.

-mAx- August 28, 2012 03:15

ok I assume you have at top and bottom domains without holes, which means you can afford to get coarser mesh.
The area you displayed has to be mesh with small size elements, else you won't be able to capture anything.
So 2 options:
1-you have your domain (just one surface) and you mesh it with a constant element size (but small one: you need at least 8-10 element between holes)
2-you split your domain into 3 domains: top-center-bottom
you start with center domain, and apply size function on each hole edge, with small start size. Gambit will mesh the domain and refine at those edges. Then mesh the 2 other domains mith more coarse mesh (you can also use size function)
you will get smaller mesh size, but sufficient refined.
The problem you got should be linked to your element size (I assume)

alimisaghian August 28, 2012 03:16

1 Attachment(s)
when i use Tri pave mesh with 0.11588 interval size the mesh is generated like this and fluent dont accept it .

alimisaghian August 28, 2012 03:20

2 Attachment(s)
please check these pics,

-mAx- August 28, 2012 03:28

as you can see on your second picture, the mesh is to fine where there is no hole, BUT to coarse where there are holes.
Follow my advice 2-

alimisaghian August 28, 2012 03:33

ok, thanks, let me check your advise 2 and report the results,:)

-mAx- August 28, 2012 03:44

just a tip for the size function with edges (holes)
Befor selecting edges, select All edges in the display attributes and visibility on. Then select All surfaces and visibility off.
Now only edges are displayed.
Click reset, and again in Edges, but select the outer edges (not the holes edges), and visibility off.
Only holes edges should be displayed
Now in the size function panel, you can pick and select all edges which are displayed.
you will save lots of time intead of picking all your edges one by one...


All times are GMT -4. The time now is 04:25.