CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] How can I extrude a 2D Hexa Mesh along a center curve? (http://www.cfd-online.com/Forums/ansys-meshing/109058-how-can-i-extrude-2d-hexa-mesh-along-center-curve.html)

Daniel C November 8, 2012 07:55

How can I extrude a 2D Hexa Mesh along a center curve?
 
Hallo everybody!

My concern as follows:

I have created a simple 2D Hexa Mesh in ICEM. Now I want to extrude this mesh along a guiding curve, which is normal to the surface of the mesh. In that manner, I try to mesh a serpentine cooler with a lot of bending. Creating a blocking topology is much more time consuming, I think.

What I've tried:
I made a 3D Blocking from 2D (10mm in Y-Direction). Then I used Extrude Face(s) -> Extrude Along Curve along curve, but I can't select all the curves for extrusion. So, how can I extrude along the whole curve?

Does anybody has a hint for me?

Thank you very much!

Daniel

http://imageshack.us/photo/my-images/585/icem.png/

http://imageshack.us/photo/my-images/585/icem.png/

diamondx November 8, 2012 14:01

Somebody answered you but in a different thread...

Broly said:
you could try this :

geometry -> create/modify curve -> concatenate/reapproximate curves

You will end with one curve, and it should work.

Far November 9, 2012 00:45

Can we extrude the 2d mesh in pre-mesh? or it only works when pre-mesh is converted into unstructured mesh?

diamondx November 9, 2012 00:47

You can extrude 2d mesh n the premesh

BrolY November 9, 2012 04:17

In fact, you extrude the block, so at the end, it's like extruding the pre-mesh.

Far November 9, 2012 04:20

extrude block only work on the 3d blocks

http://imageshack.us/photo/my-images/585/icem.png/

Daniel C November 9, 2012 04:57

2 Attachment(s)
Okay, I have concatenated the curves, now I can select the whole curve as a tracking curve. But I don't get a satisfying result (See picture 1).

In a second attempt I changed the geometrie. Now I have one outer and one inner curve as a track for the extrusion. I still get no result (See picture 2).

I tried both, pre-mesh and unstructured mesh.

Far November 9, 2012 05:01

see this http://www.cfd-online.com/Forums/ans...ing-edges.html

BrolY November 9, 2012 05:03

You should extrude the block curve by curve., and be sure that you have a split at each geometry change. I've done it plenty of times, it works well.

Daniel C November 9, 2012 06:42

3 Attachment(s)
Thank you Far, that helped a lot.

ICEM seems to have some difficulties with narrow radius in curvature (Picture 1 and 2). So the centerline of the rectangle duct is truly the better tracking curve (Picture 3). Now I have to adjust the number of layer properly to have the best fit to my curvature.

Another problem is, that only the node distribution from the face is copied each time. That is clear to me, because each block has a different size compared to the original block. So ICEM does not know whether the number of nodes or the spacing is impotant. What is the best practice to handle this problem? Do I have to go to the Curve Mesh Setup?

Thanks again!

Daniel

Far November 9, 2012 06:59

I usually define the premesh parameters manually. Did you check the premesh? Is it OK?

I see you have made the few splits at the curvature, this should work!

Not the curve mesh set-up, use the edge mesh parameters. You can also define the default no of nodes so that you will have reasonable no of nodes on each segment of edge while you are extruding blocks.

Daniel C November 9, 2012 07:40

1 Attachment(s)
I did not make any splits at the curvature. The extrusion went automatically.

The pre-mesh was fine. My first block contains 28 nodes in x-, 11 nodes in y- and 21 in z-direction. I extrude in y-direction.

The number of nodes is alway set to 2 nodes in depth as I extrude. How can I set the default number of nodes. I hooked the Nodes Locked option in the Edge Params, but that did not work.

How can I define the default no of nodes? Sorry form my stupid questions, but I am a complete newbie in ICEM :-)

Far November 9, 2012 08:01

go to premesh parameters. update all in first tab (update sizes)

Check premesh, if mesh looks decent (like 4-8 nodes on edge) then ok, otherwise go to 2nd tab (scale sizes) and try with 2 and contiue clicking apply untill you are satisfied with meshing.

I request Simon to provide the defaults for the no of nodes on edge, so that user can set it in the starting of project like we do in gambit and gridgen/pointwise

Daniel C November 9, 2012 08:32

1 Attachment(s)
That is a suitable method for me. Thank you!


Could you still give me a hint, how to fit the blocks to the curvature? The blocks do not want to fit it! They dont't adopt the edge association I made in the Associate Edge to Curve tab. Do I have to set the association manual edge for edge? That would be horrible!:eek:

Far November 9, 2012 08:36

did u try the auto association? This is the last option in association panel

Daniel C November 9, 2012 08:43

1 Attachment(s)
It's a pity, auto association does not work. See picture.

Far November 9, 2012 08:50

manual method :D

Daniel C November 9, 2012 09:00

Haha :D! Okay, this is my first try and this is only a small sample duct.

If I have , let me say, 100 and more bendings in a more complex duct, I am quite busy for the next time :D.

Summary;
1. I associated the two top edges to the top outer and inner curves of the duct.
2. I extruded the blocking with 53 layers along the center curve of the duct.

Where I went wrong?

Far November 9, 2012 09:09

nothing wrong. try manual association and then check pre mesh

Check 89 slide https://docs.google.com/file/d/0ByIL...MjQ/edit?pli=1

Daniel C November 9, 2012 09:35

Good script! I will use it in the future. What did you mean with >>Check 89 slide<< ?


All times are GMT -4. The time now is 21:16.