CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] merging meshs from different types of blocks (http://www.cfd-online.com/Forums/ansys-meshing/109067-merging-meshs-different-types-blocks.html)

kpax November 8, 2012 10:12

merging meshs from different types of blocks
 
hi everybody,

i am currently trying to mesh a bifurcating vessel using ICEM 14.0.
I managed to create a pre-mesh which seemed reasonable, but pre-mesh quality check tells me that i have some problems with skewness (equiangle skewness has more than 0.3% elements with skewness < 0.05). so i converted one of the blocks to type 'free' (all other blocks are 'mapped'). This reduced the number of highly skewed elements, but when i created the real mesh and checked it, the interface areas between the different types of blocks contained uncovered faces.
When I tried to convert the .msh file to use in OF (using fluentMeshToFoam), i got a weird error that did not occur for all mapped blocks.

so i think the problem is that the different types of blocks need to be connected in some way? I read in another thread that you can simply merge the nodes with a certain tolerance, but that did not work for me.

any help is appreciated.

kpax

BrolY November 8, 2012 12:14

you could try this :

geometry -> create/modify curve -> concatenate/reapproximate curves

You will end with one curve, and it should work.

kpax November 8, 2012 12:35

2 Attachment(s)
hmm, not sure what you mean? there is only one curve at the interface of the two blocks (which delineates different surfaces), so nothing to concatenate?!


edit: ok, maybe i should add some pictures. here you can see the blocking i chose (middle one is the free block), and the elements with uncovered faces.

diamondx November 8, 2012 13:55

Quote:

Basically, Uncovered faces means that you have volume elements with an exposed side. It should be covered by a shell or another volume element. Missing internal edges means that you have a 2D elements with an exposed side. It should be covered by a line element or another 2D element.

When you get either error (Uncovered faces or missing internal edges), you should push the [Fix] button. This will prompt you to select or type in a new part name. It will create shell elements (or line elements) to cover the "uncovered" faces (or edges) and put the new elements in the part name you selected. You will then have a valid boundary to take to Fluent and use as a wall or internal wall or whatever.

Simon
did you try this, when pushing the fix, name the new part "interior_something" then when setting boundary condition, declare that part as "interior"
Give it a try, you can share your project with us,i'll take a look at it when i have time.

diamondx November 8, 2012 14:00

Quote:

you could try this :

geometry -> create/modify curve -> concatenate/reapproximate curves

You will end with one curve, and it should work.
Broly, it's either you're drunk or you're in the wrong thread :D:

http://www.cfd-online.com/Forums/ans...ter-curve.html

BrolY November 8, 2012 14:37

Lol you are right Diamondx !
let's say I'm working too much ;)

kpax November 9, 2012 07:23

1 Attachment(s)
Quote:

Originally Posted by diamondx (Post 391066)
did you try this, when pushing the fix, name the new part "interior_something" then when setting boundary condition, declare that part as "interior"
Give it a try, you can share your project with us,i'll take a look at it when i have time.


hey ali,

this seems to be working, the only problem is that after this "fix" i get a multiple edges error. these multiple edges are located around the interfaces as you can see in the attached picture.

i think this is going in the right direction, because OpenFoam seemed to accept the interface internal BC... however, when trying to convert the mesh, i got
"Unused points found in the mesh, number unused by faces: 10444 number unused by cells: 10444"
I guess this is due to the multiple edges?



ps. i also tried putting all the surfaces in the same part, as suggested by simon here: http://www.cfd-online.com/Forums/ans...tet-merge.html
-> did not affect the multiple edge problem described above



edit: i just realized that it's only the middle block that makes problems. e.g., when i choose only the lower block (in the pictures) to be 'free', and the rest as 'mapped', then i dont get any uncovered faces at all. weird.

kpax November 9, 2012 08:56

2 Attachment(s)
ok, i think i'm getting closer to the solution...

apparently, the critical step is when i convert the middle block from mapped to free. for some reason, this makes the block turn transparent on one side (see attached pictures). it's this step that leads to uncovered faces.

anyone seen this before?



edit: found a solution. separating the middle block into three parts and converting only the left and right one to type free works.. dont understand why exactly, though.
anyway, thx for your help.

BrolY November 9, 2012 12:00

What you are experienceing is something I've ever wondered to myself.
For me, it's normal that ICEM sees uncovered faces considering the fact there are more cells on one side of the mesh than the other (the free block can have different number of nodes than the "structured" block).

This trouble is even more obivous when you use the option "refinnement".

That should be something the solver should handle instead of ICEM.
Do you agree with that ?

diamondx November 9, 2012 12:00

You did great while I was sleeping I'm glad you fixed your problem

Far November 10, 2012 00:03

Quote:

i am currently trying to mesh a bifurcating vessel using ICEM 14.0.
I managed to create a pre-mesh which seemed reasonable, but pre-mesh quality check tells me that i have some problems with skewness (equiangle skewness has more than 0.3% elements with skewness < 0.05). so i converted one of the blocks to type 'free' (all other blocks are 'mapped'). This reduced the number of highly skewed elements, but when i created the real mesh and checked it, the interface areas between the different types of blocks contained uncovered faces.
Do you access to Simon's tip and tricks where he showed the method to handle the full hexa meshing in similar cases

Quote:

When I tried to convert the .msh file to use in OF (using fluentMeshToFoam), i got a weird error that did not occur for all mapped blocks.
Where this converter is available?


Quote:

so i think the problem is that the different types of blocks need to be connected in some way? I read in another thread that you can simply merge the nodes with a certain tolerance, but that did not work for me.
Cant this problem be tackled with top-down approach more efficiently?

kpax November 13, 2012 10:31

Quote:

Originally Posted by Far (Post 391351)
Do you access to Simon's tip and tricks where he showed the method to handle the full hexa meshing in similar cases

no, do you have a link?


Quote:

Originally Posted by Far (Post 391351)
Where this converter is available?

It comes with OF, just type "fluentMeshToFoam mesh.msh" for a file named mesh.msh. usually works quite nicely.

Quote:

Originally Posted by Far (Post 391351)
Cant this problem be tackled with top-down approach more efficiently?

could you explain that in a bit more detail?


thx!


All times are GMT -4. The time now is 14:04.