CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] ICEM does not behave as expected (http://www.cfd-online.com/Forums/ansys-meshing/109300-icem-does-not-behave-expected.html)

RodriguezFatz November 14, 2012 11:27

ICEM does not behave as expected
 
3 Attachment(s)
Dear experts,

I am stuck. ICEM shows some curious behavior and I don't get the problem. :confused:

I am meshing a pipe with some other pipe sticking in it. (surface mesh of the inner pipe is switched of in the pictures)
Attachment 16959
The upper left part (dark green) shows the large pipe's surface mesh zoomed in at the point where the smaller pipe intersects. Now, at the boundary line between the two pipes the problem occurs. At point 1) the mesh is how I want it to be. At point 2) it becomes smaller and at point 3) the boundary line and the first line of the dark green mesh become one. I don't understand what happens here.
Now at the lower left of the first picture, where I define the size of the cell it seems to be fine:
Attachment 16961
So my adjustment on the edge and the actual premesh agree.
But at the other edge it looks like that:
Attachment 16960
Edge adjustment (red) and actual grid (dark green) are badly different.
Unfortunately, the numbers in the "Meshing Parameters" box (where you define the spacing, ratio, ...) show my settings, but the mesh just does not follow these values.

What I already tryed: I made sure all adjacent edges are associated to the curves, all faces to surface parts.

Every help is appreciated!:cool:

Far November 14, 2012 12:59

i cant understand the problem, do you mean that the edges and mesh lines do not match? or edges do not follow the curves?

diamondx November 14, 2012 14:21

Quote:

What I already tryed: I made sure all adjacent edges are associated to the curves, all faces to surface parts.
How about "apply to all parallel edge"

RodriguezFatz November 14, 2012 14:35

Quote:

Originally Posted by Far (Post 392102)
i cant understand the problem, do you mean that the edges and mesh lines do not match? or edges do not follow the curves?

Quote:

Originally Posted by diamondx (Post 392119)
How about "apply to all parallel edge"

Ok sorry, it's hard for me to explain the problem. I'll try again.

ICEM produced negative volume cells. When I was looking for the reason of that, I found that there is a problem at the location I show on the pictures: The cells that are close to the small circle (marked with "1)", "2)" and "3)" in the first picture) don't behave as expected. Although all perpendicular edges have the same parameters (spacing, ratio,...), the actual cell width changes along the circle. As you can see, at position 1) the first cell has a certain width, at position 2) it becomes smaller and at position 3) the width is zero.
The four edges (perpendicular to the circle), that determine the width of these cells all have the same setting. Picture 2 shows an edge where the setting works fine, picture 3 shows a problem: cell width and edge setting are completely different. In "Meshing parameters" it says, first cell has a width of 6.8e-6m, just like the cells in picture 2. But obviously this is not the case. The first cell is degenerated and also all other cells don't match the edge.

blackmask November 14, 2012 21:11

I suppose there is no association related problem in your operation. Try split the edge which is associated to the boundary line to split the adjacent block into more blocks. If that does not help, you will have to increase the size of first cell near the wall.

RodriguezFatz November 15, 2012 05:12

Thanks for your ideas. It did not work, I am currently meshing it again and hoping the error vanishes.
This feels like in the old days, when Windows 95 did something crazy and you tryed different things but couldn't fix it. Reinstalling was much faster most of the times...

energy382 November 15, 2012 05:30

Quote:

Originally Posted by blackmask (Post 392173)
I suppose there is no association related problem in your operation. Try split the edge which is associated to the boundary line to split the adjacent block into more blocks. If that does not help, you will have to increase the size of first cell near the wall.

Agreed. Did you also check, that your topo tolerance is smaller then your first cell height. Build topology with the value of first cell height and look at the problematic area. (if split edge doesn't solve your problem). You should also take a look on your projection limit setting

Cheers

RodriguezFatz November 16, 2012 08:51

Dear energy,

I made the geometry with DesignModeler and imported it to ICEM. I never had problems with the things you write. Can they be relevant to me? How do I check them?



Solved: Settings -> Model/Units-> Tolerance to one order lower and now it works.
Hey, you are the best!!! :)

Far November 16, 2012 10:03

Your problem is solved, but this post may be helpful to others. Very informative posts by Simon... http://www.cfd-online.com/Forums/ans...l-turbine.html

RodriguezFatz November 20, 2012 03:26

Hey Far,
Indeed, that's why I wrote that your hints worked ;)
Also, I had a quite similar error, that I could fix with Simon's information from the thread you linked. Thanks a lot!


All times are GMT -4. The time now is 03:17.