CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[ICEM] Meshing problem in Formula one

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree3Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   January 20, 2013, 11:14
Default
  #101
Super Moderator
 
diamondx's Avatar
 
Ghazlani M. Ali
Join Date: May 2011
Location: Canada
Posts: 1,291
Blog Entries: 23
Rep Power: 20
diamondx will become famous soon enough
may i know where does the problem lie ??
__________________
Regards,
New to ICEM CFD, try this document --> http://goo.gl/G2gkE
Ali
diamondx is offline   Reply With Quote

Old   January 20, 2013, 20:19
Default
  #102
Far
Super Moderator
 
Far's Avatar
 
Sijal Ahmed Memon (turboenginner@gmail.com)
Join Date: Mar 2009
Location: Islamabad Pakistan
Posts: 3,905
Blog Entries: 6
Rep Power: 38
Far will become famous soon enoughFar will become famous soon enough
Send a message via Skype™ to Far
Ali this method is perfect. But I am not able to generate the volume mesh in the inner domain through denauly. No matter Whatever I do, I always get one big larger than inner domain!!!!
Far is offline   Reply With Quote

Old   January 20, 2013, 21:43
Default
  #103
Super Moderator
 
diamondx's Avatar
 
Ghazlani M. Ali
Join Date: May 2011
Location: Canada
Posts: 1,291
Blog Entries: 23
Rep Power: 20
diamondx will become famous soon enough
how come ?? you did it already with tgrid ???
__________________
Regards,
New to ICEM CFD, try this document --> http://goo.gl/G2gkE
Ali
diamondx is offline   Reply With Quote

Old   January 28, 2013, 07:00
Default Problem in Denauly mesh
  #104
Far
Super Moderator
 
Far's Avatar
 
Sijal Ahmed Memon (turboenginner@gmail.com)
Join Date: Mar 2009
Location: Islamabad Pakistan
Posts: 3,905
Blog Entries: 6
Rep Power: 38
Far will become famous soon enoughFar will become famous soon enough
Send a message via Skype™ to Far
Now I am trying to generate denauly using surface mesh as shown in previous posts. But volumes are leaking as can be seen attached Figs.
What is the problem? I checked through build topology and did not find any problem there.









Far is offline   Reply With Quote

Old   January 28, 2013, 09:55
Default
  #105
Super Moderator
 
diamondx's Avatar
 
Ghazlani M. Ali
Join Date: May 2011
Location: Canada
Posts: 1,291
Blog Entries: 23
Rep Power: 20
diamondx will become famous soon enough
but if you remove the small box and consider the big beometry , wil it work ???
How about in t-grid ? will it do same ?
__________________
Regards,
New to ICEM CFD, try this document --> http://goo.gl/G2gkE
Ali
diamondx is offline   Reply With Quote

Old   January 28, 2013, 10:13
Default
  #106
Far
Super Moderator
 
Far's Avatar
 
Sijal Ahmed Memon (turboenginner@gmail.com)
Join Date: Mar 2009
Location: Islamabad Pakistan
Posts: 3,905
Blog Entries: 6
Rep Power: 38
Far will become famous soon enoughFar will become famous soon enough
Send a message via Skype™ to Far
Big box is deleted so there is only small box (should be same now? ). Tgrid does make the grid and even prisms successfully but there is some thing strange happening there as well (quite different than ICEM)
Far is offline   Reply With Quote

Old   January 28, 2013, 10:57
Default
  #107
Far
Super Moderator
 
Far's Avatar
 
Sijal Ahmed Memon (turboenginner@gmail.com)
Join Date: Mar 2009
Location: Islamabad Pakistan
Posts: 3,905
Blog Entries: 6
Rep Power: 38
Far will become famous soon enoughFar will become famous soon enough
Send a message via Skype™ to Far
Tgrid is making prisms in the first wing (from left to right on screen) correctly but it is penetrating prism inside the wing instead of extruding them on wing 2 and 3. See attached pics and files are also attached.

https://dl.dropbox.com/u/68746918/Inneronly.rar





Far is offline   Reply With Quote

Old   January 28, 2013, 12:33
Default
  #108
Super Moderator
 
diamondx's Avatar
 
Ghazlani M. Ali
Join Date: May 2011
Location: Canada
Posts: 1,291
Blog Entries: 23
Rep Power: 20
diamondx will become famous soon enough
i get the same mesh as you
__________________
Regards,
New to ICEM CFD, try this document --> http://goo.gl/G2gkE
Ali
diamondx is offline   Reply With Quote

Old   January 28, 2013, 12:55
Default
  #109
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 35
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
Quote:
Originally Posted by Far View Post
Now I am trying to generate denauly using surface mesh as shown in previous posts. But volumes are leaking as can be seen attached Figs.
What is the problem? I checked through build topology and did not find any problem there.
That doesn't look like leaking... It is some other problem. I have seen it before, but not for years. I recall it had something to do with an edit operation that triggered a bug where the nodes were mis-numbered during the save operation.

There are two sets of node numbers, the ones in the forground and the ones in the background...

Basically, it messes up the surface mesh node numbers in the background so that when delaunay runs it gets the wrong connectivity.

To fix it, try running the Edit mesh option to re-number nodes before running delaunay.
__________________
-----------------------------------------
Please help guide development at ANSYS by filling in these surveys

Public ANSYS ICEM CFD Users Survey

This second one is more general (Gambit, TGrid and ANSYS Meshing users welcome)...

CFD Online Users Survey
PSYMN is offline   Reply With Quote

Old   April 21, 2013, 07:50
Default
  #110
New Member
 
Marinus
Join Date: Apr 2013
Posts: 3
Rep Power: 4
Marinus is on a distinguished road
Quote:
Originally Posted by PSYMN View Post
That doesn't look like leaking... It is some other problem. I have seen it before, but not for years. I recall it had something to do with an edit operation that triggered a bug where the nodes were mis-numbered during the save operation.

There are two sets of node numbers, the ones in the forground and the ones in the background...

Basically, it messes up the surface mesh node numbers in the background so that when delaunay runs it gets the wrong connectivity.

To fix it, try running the Edit mesh option to re-number nodes before running delaunay.
I am having the same problem, re-numbering the nodes did not fix it. Any other suggestions?
Marinus is offline   Reply With Quote

Old   April 21, 2013, 08:50
Default
  #111
Far
Super Moderator
 
Far's Avatar
 
Sijal Ahmed Memon (turboenginner@gmail.com)
Join Date: Mar 2009
Location: Islamabad Pakistan
Posts: 3,905
Blog Entries: 6
Rep Power: 38
Far will become famous soon enoughFar will become famous soon enough
Send a message via Skype™ to Far
Delete mesh and regenerate surface mesh. After that compute mesh.

PS: There is no clear pattern for this problem to happen
Far is offline   Reply With Quote

Old   April 23, 2013, 10:40
Default
  #112
New Member
 
Marinus
Join Date: Apr 2013
Posts: 3
Rep Power: 4
Marinus is on a distinguished road
Quote:
Originally Posted by Far View Post
Delete mesh and regenerate surface mesh. After that compute mesh.

PS: There is no clear pattern for this problem to happen
Eventually the problem did not show up when I first made an octree mesh, then after saving deleting the volume mesh and then computing the delauney volume mesh from the surface mesh.

Somewhere during saving the element numbers were changed automatically, however when I tried doing this manually it did not fix the problem. Maybe I did this wrong. Luckely I found a working solution .

Thanks for the help.
Marinus is offline   Reply With Quote

Old   April 23, 2013, 11:45
Default
  #113
Far
Super Moderator
 
Far's Avatar
 
Sijal Ahmed Memon (turboenginner@gmail.com)
Join Date: Mar 2009
Location: Islamabad Pakistan
Posts: 3,905
Blog Entries: 6
Rep Power: 38
Far will become famous soon enoughFar will become famous soon enough
Send a message via Skype™ to Far
What working solution you found?
Far is offline   Reply With Quote

Old   April 23, 2013, 12:36
Default
  #114
New Member
 
Marinus
Join Date: Apr 2013
Posts: 3
Rep Power: 4
Marinus is on a distinguished road
Quote:
Originally Posted by Far View Post
What working solution you found?
As I described, first I saved the octree mesh. Then deleted the volume mesh, then created Delaunay. Works for me.
Marinus is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Other] Hex meshing problem DM12 patrick ANSYS Meshing & Geometry 7 January 9, 2015 08:21
Problem with querying the meshing database in CFX-Pre ashtonJ CFX 4 August 15, 2014 20:55
[GAMBIT] 3D boundary layer and meshing problem in GAMBIT 2.4.6 prashanthreddyh ANSYS Meshing & Geometry 1 December 20, 2011 01:35
[ICEM] Hexa meshing blocking problem fergal ANSYS Meshing & Geometry 0 June 28, 2011 10:01
Strange ANSYS Meshing 13.0 Problem brunob ANSYS Meshing & Geometry 3 June 21, 2011 20:03


All times are GMT -4. The time now is 04:08.