CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] surface boundary doesn't match the curve (http://www.cfd-online.com/Forums/ansys-meshing/111895-surface-boundary-doesnt-match-curve.html)

motorbean January 17, 2013 11:02

surface boundary doesn't match the curve
 
1 Attachment(s)
Attachment 18258Hi, everyone, I have a problem.

I plan the segment the surface with the curves that forms the shape of the blade. But after the segmentation and deletion of the surface inside the blade, I found that the surface boundary doesn't match the blade curve, especially at the leading edge, as shown in Fig 1. Can anyone tell me why and how to let the surface match the curve please?

By the way, I've set the overall topo tolerance as 3e-4 and triangular tolerance as 1e-8, but the problem persists.

Thank you very much!

BrolY January 17, 2013 11:42

The option Segment surface doesn't work all the time .. I've been using this tool for years, and the way it works is still a mystery for me ...

1) you need a very good surface to use this tool.
2) be sure the curves with which you want to segment the surface are attached to that surface.

If it doesn't work, you can also try Geom -> Create/modify curve -> Project curve on surface (don't forget to select the option "trim surfaces). Sometimes it works.
Otherwise, try to redo your surface .. or redo the curves (by intersecting 2 surfaces for example) ..
Sometimes, just close and reopen ICEM ..
Good luck ;)

Far January 17, 2013 11:51

It may be Visual artifacts. Make the mesh and see if it follow the surface and curve properly.

BrolY January 17, 2013 11:53

Did you turn on the option "Show full" of your surfaces ?
If not, Far is right.
If yes, good luck ;)

motorbean January 17, 2013 12:47

Thanks, guys! I turn on "show full" and it works!

Also, I've found another way to do the segment: Repair Goemtry->Build Diagnostics Geometry. Then build from the curves and the surface.

After that, the curves will trim the surface, and they are associated to the surface as well! This is useful if you are going to do an unstructure mesh, and useful for automatic meshing.

Far January 17, 2013 12:55

Quote:

Originally Posted by motorbean (Post 402491)
Thanks, guys! I turn on "show full" and it works!

Also, I've found another way to do the segment: Repair Goemtry->Build Diagnostics Geometry. Then build from the curves and the surface.

After that, the curves will trim the surface, and they are associated to the surface as well! This is useful if you are going to do an unstructure mesh, and useful for automatic meshing.

Yes Build topology is awesome tool and it do many tasks in automatic fashion like attaching curves and points to respective surface, subtract the surface at the intersection with another surface and trim when necessary.

Build toplogy tool is pre-requisite for the tetra mesh.

diamondx January 17, 2013 15:11

Quote:

Originally Posted by BrolY (Post 402472)
The option Segment surface doesn't work all the time .. I've been using this tool for years, and the way it works is still a mystery for me ...

1) you need a very good surface to use this tool.
2) be sure the curves with which you want to segment the surface are attached to that surface.

If it doesn't work, you can also try Geom -> Create/modify curve -> Project curve on surface (don't forget to select the option "trim surfaces). Sometimes it works.
Otherwise, try to redo your surface .. or redo the curves (by intersecting 2 surfaces for example) ..
Sometimes, just close and reopen ICEM ..
Good luck ;)

I tought i was not good at using that feature, i guess i m not the only one. i rely too much on the build topology with checking the option split surface...


All times are GMT -4. The time now is 11:59.