CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] Negative volumes (http://www.cfd-online.com/Forums/ansys-meshing/112332-negative-volumes.html)

Bollonga January 26, 2013 06:23

Negative volumes
 
1 Attachment(s)
Hi everybody,

I'm working on a 3D geometry of an inclined flat plate. I'm doing a hexa mesh as it is a rather simple topology. Before converting it into unstructured mesh (to export it to Fluent) I check it and fix the problems, then I smooth (with smooth for hex/orth mesh tool) it for 10 iterations, including the volume orientations option. I also make the first layer to be 1e-5 to have a low y+.

The problem is that Fluent says there are negative volumes, and I can't fix it with Icem tools.

How can I solve that?

Any suggestions are welcome! Thanks!

Bollonga January 26, 2013 07:11

This is the message that always appears when I try to fix or to smooth the mesh:

Running diagnostics for Volume orientations in subset "all"
52 problems were found for Volume orientations
52 elements could not be fixed -- probably the element quality is too bad.

Bollonga January 26, 2013 08:07

I've ploted the negative volume elements, they are all in two blocks. I've redone the edge and vertex associations and remeshed, nothing changed.
I've tried to invert blocks orientations, and nothing has changed.

What else can I try? Please help.

Daniel C January 26, 2013 09:28

I am currently running into the same problem. I assume it is caused by the geometry. Have you loaded a step file? You could check if the coordinates off all points are properly aligned.

Just a thought.

Bollonga January 27, 2013 06:54

1 Attachment(s)
Quote:

Originally Posted by Daniel C (Post 404181)
I am currently running into the same problem. I assume it is caused by the geometry. Have you loaded a step file? You could check if the coordinates off all points are properly aligned.

Just a thought.

I've just made all the geometry as it is rather simple. I'm trying now to improve the quality cause I haven't noticed before the Quality menu in the blocking tab. It's giving error messages like the one in the image.


I guess I have to improve the quality, but this messages doesn't allow me to proceed!

Far January 27, 2013 07:09

Hi.

There must some basic mistake. Smoothing will not help in this case...

Bollonga January 27, 2013 07:26

I have many negative 3x3 determinants, I don't know what that means, but I'm trying fixing it with the quality up to -0.7 which is the minimum value reached. If I put a positive value, i.e. 0.2, the former message appears. I'm waiting for the results now, I'll let you know.

Far January 27, 2013 07:41

There are many reasons like you had in previous posts. Or it may be due to block orientation and can be rectified through tools in blocking tab or edit mesh tab.

Few pics or icem files would be necessary to comment further.

Bollonga January 27, 2013 09:16

1 Attachment(s)
Hi Far,

Here you are my icem files. I haven't uploaded the .uns files cause they're pretty big.
I have similar problems with a bigger mesh (1.8Gb) so I'd like to know the process to fix it.

Thanks!

Far January 27, 2013 09:27

Same problem so same solution. Please refer to your own thread and read Post # 16.

Post # 16 By Simon
http://www.cfd-online.com/Forums/ans...em-fluent.html

Bollonga January 28, 2013 08:20

I've redone all the blocking again until I got no negative 3x3x3 determinant. I don't know why I can never execute the pre-mesh quality tool. All the same I's smooth it 20 iterations and exported it to fluent. I all seems to go okay but fluent says there are some left-handed and right-handed faces. I'm already running the simulation but I would like to know what that means and how to fix it.

I've searched this thread but I didn't get much useful info.
http://www.cfd-online.com/Forums/flu...nded-face.html

Thanks!

Pospelov January 28, 2013 09:03

1 Attachment(s)
Hello.
You have missed the surface.

Bollonga January 28, 2013 09:36

Quote:

Originally Posted by Pospelov (Post 404502)
Hello.
You have missed the surface.

Thanks, I already corrected that.

Far January 28, 2013 10:29

1 Attachment(s)
I think it is very simple case for ICEM. I also see many curves and points which are really not required in ICEM except they are made for some special purpose and in fact it is the hidden power of ICEM.

Pospelov January 28, 2013 11:25

1 Attachment(s)
And you should create O block like this. ))))

Bollonga January 28, 2013 11:31

Thanks Far, my blocking is still running without any problem. It is very similar to the one you made for me. I'll let you know the results.

Bollonga January 28, 2013 11:37

Quote:

Originally Posted by Pospelov (Post 404535)
And you should create O block like this. ))))

Thanks a lot Pospelov! You have used the o-grid block option in the blocking tab, right? I also use to force some 1st layer thickness at the smoothing stage.

Pospelov January 28, 2013 11:43

Yes. I used it there.

Far January 28, 2013 11:44

Yes O-grid will make the solution more accurate

Bollonga January 28, 2013 18:44

Quote:

Originally Posted by Pospelov (Post 404535)
And you should create O block like this. ))))

How have you made this O-grid exactly? from block? from faces? Edges? vertices?

Thanks


All times are GMT -4. The time now is 04:51.