CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [DesignModeler] Boolean Error (http://www.cfd-online.com/Forums/ansys-meshing/114301-boolean-error.html)

Monstrobolaxa March 8, 2013 12:09

Boolean Error
 
Hi,
I've starting learning this week how to work with Ansys Workbench and have been following a few tutorials.

I've imported an assembly from CATIA made by 2 parts. These were made as solids in CATIA.

I've imported them, created the enclosure but when performing the boolean operation to get the fluid domain and I get an error (red circle with white question mark)

Any ideas?

Monstrobolaxa March 8, 2013 12:29

1 Attachment(s)
Further to my previous post. I've isolated the problem to one of the geometries. Doing the boolean operation with the fluid volume - body it works fine. It's only when I try to subtract the wing (attached image) from the fluid volume.

Any ideas?

diamondx March 8, 2013 13:43

are they solid or surfaces ???

Monstrobolaxa March 8, 2013 13:59

It was designed as a solid. And should be a solid, unless during the import it changed something. But I imported 2 geometries in the assembly (both solids) and the other one (not shown) is fine.

diamondx March 8, 2013 14:13

what error do you get

Monstrobolaxa March 8, 2013 14:21

Error: Boolean Operation Failed
Context: Geometry Engine, while generating Feature Boolean1

In the meantime I'll recheck the geometry in catia to see if I missed anything.

It has been designed a while ago and has been in the wind tunnel for 2 years, I simply just cleaned the geometry in catia last night. it's easier for me to do it there than in modeler!

Monstrobolaxa March 8, 2013 16:07

So here's an interesting one...if I create the flow volume using Primitives - Box, the boolean operation works perfectly. It's just the enclosure that doesn't work.

Any ideas?

rushupwards April 4, 2014 15:00

2 Attachment(s)
I am also getting this error. Can you guys help me. I am doing the boolean operation for surface. I have attached screenshot of my geometry.

In this one part is imported as .igs & added as Frozen operation. The other part is constructed over this part in Designmodeler itself.

It would great if you guys help me.

Thanks
Rushabh

sa_m July 26, 2014 23:48

Quote:

Originally Posted by rushupwards (Post 483933)
I am also getting this error. Can you guys help me. I am doing the boolean operation for surface. I have attached screenshot of my geometry.

In this one part is imported as .igs & added as Frozen operation. The other part is constructed over this part in Designmodeler itself.

It would great if you guys help me.

Thanks
Rushabh

hi rushabh
u must convert surfaces to solid.


All times are GMT -4. The time now is 14:29.