CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [GAMBIT] 3D Two pipe T-shape junction mesh (

Jing April 25, 2013 07:53

3D Two pipe T-shape junction mesh
1 Attachment(s)
Hi everyone,

I am drawing a 3d 2 pipe T-shape junction mesh. I mainly followed the method described in Gambit manual about the 3 pipe intersection. Now, I have finished to interface mesh building, as shown in the figure attached. My problem is when I meshed the volume(i.e. the three pipes), using cooper and Hex/Wedge for the scheme, no matter which interval count I specified in spacing, the meshed volume is always the same with the default spacing (i.e. interval size 1) which is too denser for me. I tried to draw an edge on the pipe surface and meshed that edge first, hoping the volume meshing could follow that spacing on the edge, but it did not work.

Could anybody give me some instruction I can I get a volume mesh with a specified spacing along the pipe direction? Many Thanks!


-mAx- April 25, 2013 09:15

If your splits are well done, you should have 3 volumes, for your 3 pipes.
Now as you already did, you need to mesh the "interface" surfaces first.
Then just pick a volume, and mesh it with Cooper (it should be automatically selected, if not you may enforce it, and you need to specify your sources: 3 surfaces in your case (2 from (interfaces" and the opposite cap)).
Once it is done (meshed), check how looks like the opposite cap's mesh. It should have same size then your meshed sources (since it is a cooper projection).
If not, then something is wrong, and I would gamble on face connectivity at t-junction.
The element size parameter in the volume mesh influences only the mesh in the axial direction; which means any cross section must have same size than your sources.
I hope I am clear.
If not, just try to move one volume with any translation vector. If the volume is moved, then you have a problem (because it is not connected to the other)

Jing April 25, 2013 10:09

1 Attachment(s)
Hi Maxime,

Thank you for your reply. Yes, I have three volumes for three pipes, and the interfaces are connected. When pick a volume, the Cooper is also automatically selected, and with sources (interfaces and the opposite cap )automatically selected too.
But when it is done, the mesh along the axial direction is too sense, which is what I want to change (as is shown in figure). I tried to specify the interval count when mesh the volume, it did not work. No matter which interval count is, it is always the same. Is there a way to specify the mesh density along the axial direction? Say denser near the intersection.


-mAx- April 25, 2013 10:23

you can use size function by selecting your source surfaces (meshed) as source and the volume as attachment.
Be sure that the cap face (opposite) isn't mesh (on your picture, it seems you have another meshed volume on the left).
If size function doesn't work, then try to enforce by meshing the cylinder face with map

Jing April 25, 2013 11:23

Thanks a lot for quick reply. I tried a lot again, still not working...
Yes, in that figure it seems another meshed volume on the left, but the cap face is not meshed before meshing the volume, but once the volume is meshed, it looked like that. Seems that Gambit sweeps the mesh node patterns from the two sides of the pipe even the cap face is not meshed.
I wander is there a way I could spacing an edge along the pipe first. But now there is no edge along the pipe axial direction.


-mAx- April 25, 2013 12:02

try this:
delete all volume mesh (with lower geometry enabled)
delete all surface mesh (should be already done, but who knows...)
delete all edge mesh (should be already done, but who knows...)
delete all size functions.
mesh only the 2 surfaces from "interface" (take only one volume)
If it is still not working, share me your dbs file, I will check

Jing April 26, 2013 05:52

1 Attachment(s)
Hi Maxime,

I tried, still not working. Attached is the dbs file, please check. Thank you a lot for your time.

P.s. I drew the cylinder by sweeping along an edge, hoping mesh the edge then could get a meshed volume with the specified interval density along the axial direction. But not working.


-mAx- April 26, 2013 10:28

1 Attachment(s)
ok, it is weird, but I managed myself.
You need to create edges along the cylinder surface. But not as you did, since those edges don't belong to any surfaces.
-delete edge 6
-delete edge 2
-split edge 7 with u-value 0.5 (you get 2 more edges)
-split those 2 edges with also u-value 0.5
-split cylinder surface (6) with vertice 9 and the opposite (on the cap face)
-same with vertice 8
-Now you have both edges on which you can appls and edge mesh as your convenient. Once it is done you can mesh volume

One point more, you need one more split below your "interfaces", in that way you get the 3 volumes.
Attachment 21179

Jing April 26, 2013 12:27

Hi Maxime,

Awesome! Following your instruction, finally I know how to make it and have made it.

Best Regards,


All times are GMT -4. The time now is 13:21.