CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[ICEM] Large elements after creating prism layers

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 15, 2013, 16:21
Default Large elements after creating prism layers
  #1
Member
 
Kevin Hoopes
Join Date: Oct 2010
Posts: 40
Rep Power: 7
khoopes is on a distinguished road
Hello,

I am having trouble creating an unstructured mesh in ICEM. The mesh is almost exactly what I want but for some reason, after I create the prism layers, I get these really large elements start to show up on my outlet surface.



Before running the prism maker, the outlet is covered in the small triangular elements seen near the center of image, but after the prism they look like this. I have tried reducing the 'max size' in the part sizing window but that does not seem to do anything. For reference, I am using the octree mesher with curvature and proximity refinement, but like I said the mesh looks great before creating prisms. Also these elements are only on the outlet surface. Further into the volme the mesh looks great. Could it be some issue with the prism layer stoping on the outlet?

Is there some prism setting that I need to change?

Thanks,

Kevin
khoopes is offline   Reply With Quote

Old   June 15, 2013, 20:56
Default
  #2
Senior Member
 
Join Date: Dec 2009
Posts: 129
Rep Power: 10
mjgraf is on a distinguished road
it is caused by that wedge shape formed by the surfaces when the prism layers are grown.

I typically refined my surface mesh in those areas to keep the prism layer thinner, but never really gave it much more work. So not sure if there are other settings in the prism control that would help.

are the tet sizes on the side surface (we can not see) adjacent to the outlet similar in size?
mjgraf is offline   Reply With Quote

Old   June 16, 2013, 17:31
Default
  #3
kad
Senior Member
 
Join Date: Feb 2013
Location: Germany
Posts: 171
Rep Power: 13
kad will become famous soon enoughkad will become famous soon enough
Large elements can appear when smoothing the mesh with the allow node merging option turned on. Prism, when operating under default settings, smooths the surface mesh before creating prism. So this could be the problem.

Prism gives best results with a perfect surface mesh. This is why you should smooth the mesh manually before running prism and then set surface smoothing steps to 0 under prism settings. Good Idea is to work with Laplacian Smoother for optimal node positioning. If necessary you can turn off node merging, too. After that you can improve individual element quality withe normal smoother. Search this forum for best way of creating prism and smoothing. There are a lot of tips and tricks, especially by PSYMN.

One more tip: For volume mesh I would rather go for delauney mesh, as it has much smoother transitions in cell size. Remember that octree uses 2^n sizes of the smallest mesh size, so you have jumps in your cell sizes. You can keep the octree surface mesh, as delaunay needs an input surface mesh anyway. So you could just delete the volume octree mesh and smooth the surface mesh, because now the smoother has more freedom to move nodes. After that create delaunay volume mesh and smooth only the volume mesh. This would be the starting point for creating prism mesh. You can also carefully smooth the final mesh for better transition between prism and volume mesh, but with penta_5 (prisms) frozen (important!).
kad is offline   Reply With Quote

Old   June 16, 2013, 18:17
Default
  #4
Senior Member
 
Join Date: Dec 2009
Posts: 129
Rep Power: 10
mjgraf is on a distinguished road
i have had similar issues (if I recall correctly) even with the prism mesher set to 0 surface smoothing. I tend to not allow this type of topology in my models now when the freedom allows it.
This is even following a recommended procedure of creating the octree volume mesh, smoothing the surface with laplacian then starting the prism mesher without surface smoothing.
mjgraf is offline   Reply With Quote

Old   June 17, 2013, 13:05
Default
  #5
Member
 
Kevin Hoopes
Join Date: Oct 2010
Posts: 40
Rep Power: 7
khoopes is on a distinguished road
Thank you all for your detailed replies, I tried your suggestions kad and am still running into issues. I set the number of surface smooth steps to 0 and like mjgraf said I am still getting these large weird shaped elements on the surface. Here are the steps that I followed

Create surface mesh, all triangles patch independent
The computed surface mesh looked good so I did not smooth it
create delaunay volume mesh from current mesh
turn off all smoothing options for prism creation
create prisms

Is there some smoothing option that it uses even when it is disabled in the settings?

The reason that I chose the octree mesher was that I wanted the curvature and proximity refinement option that it has. Will I get the same effect if I create a patch independent surface mesh with curvature and proximity set, and then use a delauny volume mesh?

Thanks again for your help.
khoopes is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating inflation layers for elbow with airfoil ! Aplus CFX 1 March 13, 2006 23:22
Penetrating elements in extruded mesh Michael P CFX 2 May 20, 2005 08:06
Prism Elements ashish CFX 0 April 20, 2005 06:03
need help on Prism Mesh Generation Pete CFX 0 December 6, 2004 03:11
"flat tetrahedral elements" Tudor Miron CFX 4 March 18, 2004 17:23


All times are GMT -4. The time now is 05:47.