CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] Problem with Y+ elements in 3D blade mesh (http://www.cfd-online.com/Forums/ansys-meshing/123111-problem-y-elements-3d-blade-mesh.html)

SlapGas September 4, 2013 11:51

Problem with Y+ elements in 3D blade mesh
 
Greetings to all forum users!

I've been reading threads by fellow CFD Online users for months now, especially those aimed at 3D blade meshing. I learned a lot about using ICEM properly so I ought to thank all those who share their knowledge and experience with the not so experienced.
I recently came across a strange problem in 3D blade mesh creation. I did the best I could but I couldn't find a solution.

Explained:

There was a need to create 3D blade meshes for some calculations, so I started watching tutorials and reading threads in this forum. I had experience in 2D grids so the transition wasn't that rough. I managed to understand the basic principles behind the creation of a 3D grid in ICEM, as well as the corresponding tools I need to use.
I went on to experiment and I was able to create pretty much what I wanted. I was fluent in creating grids of good quality (according to ICEM quality checker).

Due to the nature of our the in house code that I use to simulate the airflow around a blade, sometimes there is a need for really small Y+ cells. Y+ are the cells that begin from the blade surface. The meshing law starting from the blade and leading to the farfield is always geometric, the bunching starting from the blade.

As far as the first cell was greater than 10e-05, the ICEM mesh checker didn't display any problems with volume orientation. Unfortunately, viscous simulations may require even smaller starting cells. Here is the problem: if I want the first cell to be 10e-06, the ICEM mesh checker says I have erroneous elements. This doesn't happen when the first cell is 10e-05.

Here's a link to download the whole project, see for yourselves.

https://dl.dropboxusercontent.com/u/...9/3D_blade.zip

The blade has 120 degrees periodicity, as it is a part of a 3-wing wind turbine.
The first cell is 10e-06. Run the mesh checker and you'll see the erroneous elements.
If you change it back to 10e-05, there will be no erroneous elements.

I need to find a solution to this problem (if possible) so I can run our navier-stokes code and compare the results with experimental measurements. Values greater than 10e-06 don't produce satisfactory results.

Any help will be appreciated.
If anyone needs more information regarding the project, I'll be glad to answer. :)

energy382 September 4, 2013 12:10

take a look at topo tolerance/triangulation and reduce the values

SlapGas September 4, 2013 12:29

Topo tolerance: 0.0000000001
Triangulation tolerance: 1e-12

I still get the same erroneous elements.

energy382 September 4, 2013 13:53

What are we talking about, hexa or tet/prism?
And what's exactly the error message from ICEM?

SlapGas September 4, 2013 15:32

I am talking about hexa elements, I'm trying to create a structured mesh.
When you convert the pre-mesh into unstruct mesh, in order to generate the output file, there are some options under the "mesh" tab that allow you to check for errors in mesh structure and also in mesh quality. These two are the "Check Mesh" and "Mesh Quality" options.

When you go through "Check Mesh", there are options regarding what the user wants ICEM to check for. You can check for Volume orientation problems, for Penetrating elements, for Overlapping elements, for Periodicity problems and so on.

My problem is with volume orientations. I have elements with misoriented volumes for no apparent reason. These bad elements produce negative volumes in our navier stokes code thus making it impossible to get results.

energy382 September 4, 2013 17:00

Ok, now I understand. Can you provide some pics from these elements?
I guess, you've done a o-grid arround your blade to resolve the boundary flow. It seems, that there's some trouble with correct projection and therefore inverted elements.

What you could try:
1. Project to b-splines
1. associate faces to part (blade) => create two parts: suction and pressure side and associate faces in the area of inverted elements to the correct part.
2. interpolate faces where inverted elements occure

But I really need some pics of geometry, blocking and inverted elements to help your more precisely

SlapGas September 5, 2013 06:37

I have tried associating faces with blade surface to no avail.
In my first post, I included a .zip file with the whole project.You can download it and see the erroneous elements. It is approximately 300mb.

I think this will be more effective than me sending pictures of the geometry and the erroneous elements, although I am not doing this because I'm lazy.

Disclaimer: I don't aim at simply getting a corrected version back; I really want to understand what procedure must be done in order to eradicate those elements.
The only reason I found it practical to include the project (with all the necessary files) is for someone to have a complete view of the problem and be able to try different things to see if they work. :)

adunne304 September 6, 2013 06:55

Problems Solved!

Firstly,
1. You haven't associated any of the blocking faces to the surfaces. This means that the mesher is projecting the block faces to whatever face it chooses. This has caused mix-up problems with projections at the base of the blade and the periodic boundaries. Simply associating the faces to the blade surface and the periodic faces to the periodic surfaces solved this; as it forces the correct face projection.
You should have all of your surfaces associated to block faces.
1. On the blade surface, I splined an edge, this meant that the cells were better alligned and having less trouble negotiating the curved surface. I also added some more nodes here, as you had only a few, which was causing some trouble in resolving the trailing edge of the blade near the base.
See images attached.

[IMG]http://i39.tinypic.com/10dvzhh.jpg[/IMG]
http://i39.tinypic.com/2e4dheq.jpg

Impressive blocking work all the same.

SlapGas September 6, 2013 09:07

adunne, thanks a lot for your reply. :)

I am not at the office right now so that means I won't be able to try your solution until Monday, though that doesn't mean I am not eager to see if it works!

Are you sure you tried it with the first cell of the geometric bunching being 10e-06?
If you downloaded my project and managed to fix the problem without changing any values, then your solution must be correct!!!

adunne304 September 6, 2013 09:33

Hi Man,

I've had a look at it since again. There's problems at the base of the blade where the surfaces of the blade meet the periodic boundaries. Elements are inverting here when you lower the first cell height due to the tolerance of the intersecting surfaces (they do not meet exactly) and this is causing the volume orientation problem. I'll work on it more when I get the chance and see what I can come up with.
If you get the chance to, try re-import the geometry with a tighter tolerance. I'll see what I can do in the meantime.

SlapGas September 6, 2013 10:08

That's exactly where the problem is.
I will try importing the surfaces with a tighter tolerance.

energy382 September 8, 2013 08:39

I'll take a look on it tomorrow

khoopes September 12, 2013 11:40

Another thing that has helped me in this situation is the "Project to Bsplines" option under settings -> Meshing options -> Hexa Meshing

from the help

"projects the mesh to the true Bspline geometry rather than the faceted representation, which is the internal triangulated representation of surface data as defined by Settings > Model > Triangulation Tolerance. This can be used instead of decreasing the tri-tolerance or using projection limit, where small gaps in the faceted representation create skewed elements on a Navier-Stokes grid. This, however, takes longer and more memory to compute the pre-mesh."


All times are GMT -4. The time now is 16:40.