CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[ICEM] ICEM CFD hex mesh with very small y+

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 6, 2013, 17:05
Default ICEM CFD hex mesh with very small y+
  #1
Member
 
Shenren Xu
Join Date: Jan 2011
Location: London, U.K.
Posts: 63
Rep Power: 6
Shenren_CN is on a distinguished road
I try to generate the all-hex mesh and have had the blocking done properly.

The mesh quality is very good is I set the edge to be uniformly spaced.

However, whenever I try to refine the boundary layer mesh with small y+,
by setting the edge pre-mesh params to a small length on one end and
use geometric growth for the edge, and then COPY THE PARAMETERS
TO ALL PARALLEL EDGES, the resulting mesh always have negative vol
cells.

I suspect it is because that the PARALLEL EDGES all have (slightly) different
length, and thus I don't know what really happens when the PARAMETER
for one edge is copied to the rest.

Has anyone experienced the same issue, and any suggestions on how to
resolve this?

Cheers,
Shenren
Shenren_CN is offline   Reply With Quote

Old   December 6, 2013, 18:10
Default
  #2
Member
 
Kevin Hoopes
Join Date: Oct 2010
Posts: 40
Rep Power: 7
khoopes is on a distinguished road
I have had this problem before where it will break for small values of first element distance. I think the problem is that you are trying to make elements that are smaller than the underlying triangulation of the geometry that ICEM defaultly uses to place the elements. You can either adjust this triangulation to make it finer or use the project to b-splines option and the projection limit to not use the triangulation for node placement.

adjust triangulation
Settings -> Models/Units -> Triangulation
make it really low

or (the first one is kind of a quick fix)

Project to Bsplines
Settings -> Meshing Options -> Hexa Meshing
turn it on

You will have to adjust the projection limit as well, from the help:

"The Projection limit is set to a non-zero value in cases where you want to keep the nodes on the edges and avoid projection to the underlying surfaces. This option is typically used for Navier-Stokes grids where the grid spacing is small relative to the geometry tolerance. Allowing nodes within a gap in the geometry to project would skew the elements. With a value P set to slightly larger than the gap, the nodes would instead be interpolated. The value may have to be set by trial and error depending on skewness or negative determinants being reported by pre-mesh quality checks."
khoopes is offline   Reply With Quote

Old   December 6, 2013, 18:31
Default
  #3
Member
 
Shenren Xu
Join Date: Jan 2011
Location: London, U.K.
Posts: 63
Rep Power: 6
Shenren_CN is on a distinguished road
Thanks for the reply, Kevin. I'll give a try and let you know. Indeed, my first element distance to wall is extremely small in order to get y+ around one.

BTW, Did you happen to have encountered the issue of not having all the edges of the same length when "COPY PARAMETERS TO PARALLEL EDGES". I originally thought this has caused my problem.

Cheers,
Shenren

Quote:
Originally Posted by khoopes View Post
I have had this problem before where it will break for small values of first element distance. I think the problem is that you are trying to make elements that are smaller than the underlying triangulation of the geometry that ICEM defaultly uses to place the elements. You can either adjust this triangulation to make it finer or use the project to b-splines option and the projection limit to not use the triangulation for node placement.

adjust triangulation
Settings -> Models/Units -> Triangulation
make it really low

or (the first one is kind of a quick fix)

Project to Bsplines
Settings -> Meshing Options -> Hexa Meshing
turn it on

You will have to adjust the projection limit as well, from the help:

"The Projection limit is set to a non-zero value in cases where you want to keep the nodes on the edges and avoid projection to the underlying surfaces. This option is typically used for Navier-Stokes grids where the grid spacing is small relative to the geometry tolerance. Allowing nodes within a gap in the geometry to project would skew the elements. With a value P set to slightly larger than the gap, the nodes would instead be interpolated. The value may have to be set by trial and error depending on skewness or negative determinants being reported by pre-mesh quality checks."
Shenren_CN is offline   Reply With Quote

Old   December 9, 2013, 09:50
Default
  #4
Member
 
Kevin Hoopes
Join Date: Oct 2010
Posts: 40
Rep Power: 7
khoopes is on a distinguished road
I have never had an issue with different sized parallel edges. That has always worked fine for me.
khoopes is offline   Reply With Quote

Reply

Tags
boundary layer mesh, icem, y plus

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ICEM] Scrambled data in exported Fluent mesh from ICEM CFD bjnieuwboer ANSYS Meshing & Geometry 1 October 18, 2013 06:56
[ANSYS Meshing] Generating Hexa-Core with ICEM CFD Interactive dawdybishop ANSYS Meshing & Geometry 0 July 15, 2013 05:29
Boddy fitted Hexcore Mesh in ICEM Cfd Mitch CFX 0 December 29, 2008 07:07
----------------2D mesh with ICEM CFD Abir FLUENT 2 September 12, 2008 23:55
prob while exporting icem cfd hexa mesh to fluent mani CFX 4 March 7, 2007 04:41


All times are GMT -4. The time now is 21:59.