CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   [ICEM] Wrong association for pre-mesh? (

FluidCFD February 11, 2014 11:44

Wrong association for pre-mesh?
3 Attachment(s)

I'm new to ICEM and am struggling with a quite complicated geometry for a beginner. Its a storage tank with a stratifier inside. Currently I'm trying to mesh the water around the stratifier. I made a C-grid at the back half of the storage cylinder. This looks fine (see attachment, Premesh1.png) until I set the edge parameters for the vertical edges (Premesh2.png). Then the mesh gets warped although I think I set the associations correctly. Anyone an idea?

After that I will have to mesh the front part around the stratifier (see, Geometry.png). Is there a good strategy for the block set-up? Where to cut best? I did the inner part of the stratifier already, so now I need to mesh the surrounding water.

Best regards

RodriguezFatz February 12, 2014 06:15

Hi. In ICEM on the left hand side, you can click on edges and select "show associations". Each edge will have an arrow to the geometry (curve) it is associated to. If the edge lies on the curve you will not see the arrow. But if you have strange associations to some far places, you will see long black arrows in your 3d view. Then, you know which edges have these bad associations.

Edit: I don't undertand your pictures. Did you block just half of the geometry? It looks like ICEM tries to put the front faces to the outer cylinder...

FluidCFD February 12, 2014 07:18

1 Attachment(s)

thanks for your help. I know the "Show associations" option, but there everything seems to be fine. That's why I'm a little bit confused. I wanted to start with the easy part on the rear side of the storage tank. I think I'll redo it from scratch, maybe something went wrong somewhere. I attached a new pic to better show my geometry.


RodriguezFatz February 13, 2014 04:05

Oh... as far as I know, you can not just block half of the geometry.
In your case, the block you use has one face (the front left in the upper picture) that is not associated to any geometry. ICEM needs every face to be associated to i) another block's face or ii) to the geometry. I think what ICEM tries is to find the closest surface for that face and that's what you see.
Just block everything and you will be fine.

FluidCFD February 18, 2014 05:50

Thanks for the help, the missing surface was indeed the problem. I meshed everything at a time and it worked fine.

All times are GMT -4. The time now is 01:09.