CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [GAMBIT] gambit with xming doesn't work (http://www.cfd-online.com/Forums/ansys-meshing/63525-gambit-xming-doesnt-work.html)

hbsld April 11, 2009 09:26

gambit with xming doesn't work
 
I want to run gambit in locale.

I have installed and configed xming followd the suggestion in
http://rc.usf.edu/trac/doc/wiki/XmingInstall

But gambit also prompt that unable to open display.

I wonder why ssh must be involved, and how what the remote machine should be set in Xlaunch configure.

I set 127.0.0.1, but the ssh.exe just show in a cmd window, and close the window immediately.

calemarie April 22, 2009 05:59

Hi hbsld,

I had some troubles with Xming and Gambit as well, but not as you described. I had no problem to make the connection to display, however, no way to get the grid shown inside Gambit (the graphic window remains black, while all other buttons and controls work perfectly well).

I understand that you have some misconfiguration with Xming, but I think it is worthless to put any effort on solving this: as I figured it out by myself, this site also claims to be aware that "Xming and Gambit [...] don't operate well together".

An alternate: use Cygwin/X...

Hope this helps

Calemarie

calemarie April 22, 2009 07:32

hbsld,

I revert to what I wrote earlier: indeed, after disabling OpenGL, I managed to have a working Xming-Gambit session. To do so, I simply used the "-dev X11" option to launch Gambit, as explained here.

Regards,
calemarie

hbsld April 22, 2009 11:52

thanks for your reply.

I have tried to install cygwin X server. The Xwin server can launch normally, but the xterm can't show. If I use startx in cygwin bash, it prompt that:

xterm Error 29 errno 11: resources temporarily unavaiable

Gambit prompt :
TRANS(SocketINETGetAddr): tnamebysocket() failed
TRANS(SocketINETConnect): TRANS(SocketINETGetAddr) () failed
TRANS(Open): transport open failed for tcp/ld-pc:0
Unable to open display

calemarie April 23, 2009 06:24

It seems from our google friend that there are issues with such an error 29, especially under Vista (have a look here for instance). A summary of my findings:

- whether under Vista or not
. maybe a firewall issue -> check your settings
. maybe a DLL address space collision issue -> install the cygwin 'rebase' packing and follow instruction of the readme
- if under Vista
. well, 'rebase' again...

Maybe this can help... I am running XP and faced no such problems so maybe the Vista thing is the key...

Regarding the Gambit messages, it seems like it is a consequence of the cygwin error (see here).

Regards,
calemarie

spliter200 January 29, 2012 17:27

xming problems
 
can anyone help I am having some problems?
when i run xming and gambit on my computer it runs fine provided that i lunch it with -dev X11. I can mesh and export to fluent and everything works. the problem is that when you are working in Gambit the drop down menus begin to get bigger and bigger and bigger and before i know it goes off screen i cannot select faces or edges. so again the problem is that drop down menus get bigger and bigger as you open them, also the buttons of APPLY and CLOSE are fat and big. Does anyone know why this is happening??



i tried to install Cygwin to see if this would help but i cannot get gambit to run

i do the following

startx

then it opens another white terminal

and i put the following

/cygdrive/c/Fluent.Inc/ntbin/ntx86/gambit.exe -r2.4.6 (hit enter)

and it opens gambit i click run

then there is a message that says that failed to locate exceed
then at the end there i get a message

Cannot open connect stream.
TRANS(SocketINETGetAddr): tnamebysocket() failed
TRANS(SocketINETConnect): TRANS(SocketINETGetAddr) () failed
TRANS(Open): transport open failed for tcp/LOCALPC:0
Unable to open display

so again i get this when i try to run the cygwin/x

if anyone could help me out?

p_kmb March 23, 2014 10:24

Quote:

Originally Posted by spliter200 (Post 341778)
the problem is that when you are working in Gambit the drop down menus begin to get bigger and bigger and bigger and before i know it goes off screen i cannot select faces or edges.

I have the same problem. Does anyone know how to solve it?


All times are GMT -4. The time now is 22:39.