CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   ICEM: setting tolerance (

lost.identity April 28, 2009 06:32

ICEM: setting tolerance

When creating a surface using ICEM it asks for a tolerance and I'm not sure what value to enter.

Lets say I have a cuboid with the following dimensions, l=1 m, b=0.00017 m and h=0.07 m. If I were to create surfaces on each of the six side what would I set the tolerance to be? Would it be a value less than 0.00017m?


PSYMN April 29, 2009 11:08

The tolerance you are talking about is to connect adjacent curve ends within in this tolerance. This function automatically closes gaps between boundary edges using a best fit approximation. For best results, just connect the curves end to end to form a closed loop that doesn’t need the tolerance to close gaps… In your case, the default setting of 0.01 is fine.

One other thing… For creating this geometry, you will save time by creating it using Create/Modify Surfaces => Standard Shapes => Box… You just need to enter the three dimensions and it will create the connected box for you.

lost.identity May 9, 2009 10:21

Thanks for the reply.

My real geometry is actually an angular segment as I'm trying to do an axisymetric geometry. The problem is the CFD code I'm using can't deal with a true angular segment where the two side surfaces meet on the axis. So I'm having to create a surface with a finite size as the 'bottomwall'.

This finite surface has a width of 2e-5 m and length 1.2m. I created the geometry in ICEM with the tolerance set at the default 0.01. Then I clicked repair geometry and it highlighted the curves on the bottomwall as yellow (shown below). I don't know how I could fix this.


PSYMN May 9, 2009 22:04

Create a Surface
If using the Repair geometry option, you want to choose "fill"...

But I would probably just use the "create surface" from "2 to 4 curves" tool. In that case, since the curves actually connect at corner points, this tolerance won't even come into play. I would just leave it at the default. You can also create the surface from the 4 corner points if that suits you, in which case, there is no tolerance needed.

lost.identity May 11, 2009 07:02

Cheers mate. I'm creating the surfaces from 2-4 curves. I just thought that it's a bit strange to leave the tolerance at default (esp. when my smallest dimension is smaller than the default tolerance). But I'm gonna take your word for it.

Also I thought that I always have to use the Repair Geometry tool every time I make a geometry so that it fixes the geometry? Or for such a simple geometry as mine would it suffice just to make the surfaces?

PSYMN May 11, 2009 09:26

These tools evolve over time.
These tools evolve over time.

For instance, that tolerance setting was added to support some customers with sloppy data who wanted the geometry to handle gaps between the ends of the curves. It is to allow the curves to extend by that much to make the loop. In your case, they don’t need to extend and the tolerance won’t even come into play. Before responding to you the first time, I tested it on a few cases to make sure.

The suite of surface creation and repair tools also evolved. The surface create tools were originally in DDN, but were brought over when that tool died. Once in ICEM CFD, the connectivity code was improved so that when you create a surface it automatically establishes the connectivity and you don’t need to go into the repair menu…

ICEM CFD is not a CAD tool, but it has a lot of ways to get something done. If one doesn’t work, try another…

Moving forward, the ANSYS Design Modeler tool will become the primary geometry creation and repair tool for ICEM CFD (in addition to the CAD interfaces). You should tray that out if you want to do more advanced things including adding or removing fillets, parameterizing geometry, etc.

lost.identity May 11, 2009 12:22

Thanks for the detailed explanation.

I still have a few doubts on ICEM. Sometimes I feel that ICEM creates curves over the curves I've already drawn. I'm saying this because when I delete a curve, there's another curve, on the exact same location as the one I deleted. This also happens with points. I'm certain that I didn't create extra curves. I know it doesn't affect my mesh or anything but just thought that it's a bit strange.

PSYMN May 13, 2009 10:16

Color by count...
For the curves, turn on color by count... If you see yellow curves between two surfaces, then they are each single edge curves and you probably have two... Build topology will remove the duplicate if your tolerance is sufficient. This will also change the curve color by count to red, meaning a single curve is between those surfaces.

As for deleting curves, it really just makes them dormant. When you recreate a curve in the same location later, it first tries to restore the dormant curve. This has the effect of keeping your hopefully highest quality CAD curves. Not sure if that is what you are seeing, but I thought it was a good feature.

Good luck with ICEM CFD.

All times are GMT -4. The time now is 05:10.