CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] Surface Meshing Problems - Need Help (http://www.cfd-online.com/Forums/ansys-meshing/64332-surface-meshing-problems-need-help.html)

Jules May 7, 2009 07:26

Surface Meshing Problems - Need Help
 
Hi everyone,

while working with ICEM/CFX for a thesis work, I have encountered a reccuring problem with the surface meshing function of ICEM.

Some surface patches that are to be meshed in a structured manner (for boundary layer/ shear layer resolution) with "all quad" option on and equal no. of nodes on opposing edges are instead meshed unstructured, with ugly elements near the edges, growing to big square elements where I want high aspect ratio BL cells.
Other patches are meshed the way I want them, using the same procedure. I've tried to re-mesh the concerning surfaces but it simply doesn't work. I've checked curve directions, node numbers, spacings, ensured "all quad" option, nothing helped. I have tried to delete all elements and surfaces and restart from the curves, as this has helped once before, but it doesn't work either.
Also, adjecent surface patches that I want to mesh unstructured with "quad dominant" options do not properly connect to the the structured patches. Although they share a common curve, some nodes are omitted, covering 2-3 faces of the structured patch with only 1 face in the newly created patch.

I wonder if there are some hidden options that I missed to set or if it's a bug in the program. I have spent hours on end reading the manual and remeshing and/or rebuilding the geometry/domain over and over again and I'm a little desperate right now.

Any help is greatly appreciated.

Thanks, Jules

Background:
I want to mesh a quasi-2D domain by generating a surface mesh on one symmetry plane and then extrude it with 1 cell depth towards the other symmetry plane.
The geometry I'm trying to mesh is pretty simple, basically a rectangular region (3 walls are inlet, outlet and opening, the other is a flat plate wall). The flat plate features a slot orifice, where another mesh for the cavity of a fluidic actuator is to be connected later.
I have subdivided my symmetry plane into a bunch of patches for boundary layer and shear layer and free regions to get a good control over the node spacing in different regions of the domain, bacause simply using the bounding courves and using inflation layers didn't give me the desired mesh quality.

PSYMN May 8, 2009 15:09

Hints?
 
It is hard to know from just what you have written but your mail gave me some hints...

Check the max element setting under global mesh params... I have seen this cause my mesh to ignore the specified curve parameters if one of the nodes would have exceeded this size. The result is that you no longer have equal numbers of nodes and are not going to get a mapped mesh. Since the mesh isn’t mapped, it uses the recursive loop algorithm instead, which is not great at high aspect ratio quads.

A similar problem can happen if your ignore size is greater than your mesh size.

Other settings you should check are mostly under Global Mesh Setup => Shell Meshing Parameters and include;

1) Increase the “force Mapping” to 0.6 or something…
2) Increase max nodes adjustment. This will adjust the number of nodes by a percentage to give mapping instead of forcing you to manually set all the edges to the same. I usually use 20%.
3) Is Adapt (to) mesh interior on? This setting causes the surface mesh size to have an effect on the final mesh instead of just marching in from the curve sizes. I would leave this off.

Your other issue is a separate one. You said that the mapped regions are not connecting with the quad dominant regions… Did you not mesh them at the same time? Check your topology. If you meshed them at the same time and the surfaces are connected (you should see red “double” curves), these should always be connected. If you meshed them separately, (which you shouldn’t really do), you need to make sure you have turned on the option to “respect line elements”

You can probably get help on things like this by sending the files to techsupp@ANSYS.com

Jules May 10, 2009 07:27

Problem solved
 
1 Attachment(s)
Simon,

I have applied your suggestions and this seems to have solved my problem. All the surface patches that I wanted to be meshed with structured quads are fine now. Also, like you suggested, I had indeed tried to mesh the structured (mapped) patches first and then the unstructured ones afterwards.
Thank you very much for your help. I owe you a big chunk of cake now ;).

P.S. what e-mail of mine are you talking about :confused:


Just to let anyone share my experience in case I didn't make my problem clear in the first post, here's a picture of the domain I needed to mesh. The blocks marked with a yellow X are the ones to have mapped quads.

Best wishes,

Jules

PSYMN May 11, 2009 09:31

Glad you are on your way...
 
I am glad it worked out.

As for the mail, I just meant your above post... I felt like I was a detective looking for clues. ;)

Simon


All times are GMT -4. The time now is 21:49.