CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [GAMBIT] how to generate orthogonal mesh using GAMBIT? (http://www.cfd-online.com/Forums/ansys-meshing/64524-how-generate-orthogonal-mesh-using-gambit.html)

ivanbuz May 13, 2009 14:24

how to generate orthogonal mesh using GAMBIT?
 
I am trying to generate a mesh around an airfoil using GAMBIT. The mesh needs to be structured and orthogonal in the boundary layer. Structured mesh is not a problem, but I just cannot make it orthogonal in the boundary layer. After a lot of attempts and search online, I am almost convinced that Gambit cannot generate orthogonal mesh.

Any suggestion will be appreciated!

siw October 19, 2009 10:45

I, too, would also like to know the answer to this old(ish) question.

Can anyone help?

-mAx- October 20, 2009 01:51

Gambit can build whatever you want.
You just need to build a topology around your airfoil, which enable a full orthogonal mesh.
For the BL, you aren't forced to use the BL-toll, but you can create a subvolume surrounding your airfoil (that will be your BL). From that, you can continue building the topology by creating subvolumes orthogonal to this prior subvolume

siw October 20, 2009 10:21

So there's no option to ensure that quad boundary layer elements are forced to be perpendicular to the edge/surface they are on - or even a text command that can be put in a journal file?

For my model (which is not an aerofoil) making extra geometry instead of using the in-built boundary layer mesh features is a real pain.

-mAx- October 21, 2009 01:21

I didn't pay attention on what you wanted, I thought you were expecting an orthogonal mesh around the BL.
Can you post a picture of your issue

siw October 21, 2009 02:54

2 Attachment(s)
I've attached two areas were my boundary layer is not perpendicular to the surface.

I can understand that the line on the corner tip cannot be perpendicular to anything, but I would expect Gambit to allow all the other line to be made perpendicular if the User want them to be.

-mAx- October 21, 2009 03:07

I suppose it is because of the meshed edge grading.
Is your curved surface isolated or it is merged with another one?
If it is merged, try to split it (to isolate only the curved surface).
Then try to apply the BL only on the curved surface.
If you the issue isn't solved, as I said you can try to create a surface surrounding your body. With splits, etc... you can enforce having a full orthogonal mesh. The last version of Gambit has a offset tool in the surface panel. So you can offset your body's surface, and juste split your volume with it.
Hope it helps

siw October 21, 2009 03:36

Yes, all the boundary layers are linked together so, as you say, the grading is causing this, but I had expected that feature could be switched OFF.

I did change the default parameter MESH.BLAYERTGRID.ORTHOGONAL_LAYERS to 15 (this is my quanity of layers) but that made no difference. So I'm guessing that this option is not being used.

How deterimental are these tilted elements compared to perfect quad elements on a solution? Since i will not be able to get perfect quad elements I can't compare solution results.

-mAx- October 21, 2009 03:41

no idea about the parameters, and I wouldn't play with them.
Try to isolate the curved surface and apply the BL on this surface.


All times are GMT -4. The time now is 12:33.