CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[GAMBIT] how to generate orthogonal mesh using GAMBIT?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 13, 2009, 14:24
Default how to generate orthogonal mesh using GAMBIT?
  #1
Member
 
Ivan
Join Date: May 2009
Posts: 85
Rep Power: 8
ivanbuz is on a distinguished road
I am trying to generate a mesh around an airfoil using GAMBIT. The mesh needs to be structured and orthogonal in the boundary layer. Structured mesh is not a problem, but I just cannot make it orthogonal in the boundary layer. After a lot of attempts and search online, I am almost convinced that Gambit cannot generate orthogonal mesh.

Any suggestion will be appreciated!
ivanbuz is offline   Reply With Quote

Old   October 19, 2009, 10:45
Default
  #2
siw
Senior Member
 
Join Date: Jul 2009
Posts: 446
Rep Power: 14
siw will become famous soon enough
I, too, would also like to know the answer to this old(ish) question.

Can anyone help?
siw is offline   Reply With Quote

Old   October 20, 2009, 01:51
Default
  #3
Super Moderator
 
-mAx-'s Avatar
 
Maxime Perelli
Join Date: Mar 2009
Location: Switzerland
Posts: 2,992
Rep Power: 30
-mAx- will become famous soon enough
Gambit can build whatever you want.
You just need to build a topology around your airfoil, which enable a full orthogonal mesh.
For the BL, you aren't forced to use the BL-toll, but you can create a subvolume surrounding your airfoil (that will be your BL). From that, you can continue building the topology by creating subvolumes orthogonal to this prior subvolume
__________________
In memory of my friend Hervé: CFD engineer & freerider
-mAx- is offline   Reply With Quote

Old   October 20, 2009, 10:21
Default
  #4
siw
Senior Member
 
Join Date: Jul 2009
Posts: 446
Rep Power: 14
siw will become famous soon enough
So there's no option to ensure that quad boundary layer elements are forced to be perpendicular to the edge/surface they are on - or even a text command that can be put in a journal file?

For my model (which is not an aerofoil) making extra geometry instead of using the in-built boundary layer mesh features is a real pain.
siw is offline   Reply With Quote

Old   October 21, 2009, 01:21
Default
  #5
Super Moderator
 
-mAx-'s Avatar
 
Maxime Perelli
Join Date: Mar 2009
Location: Switzerland
Posts: 2,992
Rep Power: 30
-mAx- will become famous soon enough
I didn't pay attention on what you wanted, I thought you were expecting an orthogonal mesh around the BL.
Can you post a picture of your issue
__________________
In memory of my friend Hervé: CFD engineer & freerider
-mAx- is offline   Reply With Quote

Old   October 21, 2009, 02:54
Default
  #6
siw
Senior Member
 
Join Date: Jul 2009
Posts: 446
Rep Power: 14
siw will become famous soon enough
I've attached two areas were my boundary layer is not perpendicular to the surface.

I can understand that the line on the corner tip cannot be perpendicular to anything, but I would expect Gambit to allow all the other line to be made perpendicular if the User want them to be.
Attached Images
File Type: jpg CurvedBLmesh.jpg (25.4 KB, 34 views)
File Type: jpg StraightBLmesh.jpg (44.4 KB, 34 views)
siw is offline   Reply With Quote

Old   October 21, 2009, 03:07
Default
  #7
Super Moderator
 
-mAx-'s Avatar
 
Maxime Perelli
Join Date: Mar 2009
Location: Switzerland
Posts: 2,992
Rep Power: 30
-mAx- will become famous soon enough
I suppose it is because of the meshed edge grading.
Is your curved surface isolated or it is merged with another one?
If it is merged, try to split it (to isolate only the curved surface).
Then try to apply the BL only on the curved surface.
If you the issue isn't solved, as I said you can try to create a surface surrounding your body. With splits, etc... you can enforce having a full orthogonal mesh. The last version of Gambit has a offset tool in the surface panel. So you can offset your body's surface, and juste split your volume with it.
Hope it helps
__________________
In memory of my friend Hervé: CFD engineer & freerider
-mAx- is offline   Reply With Quote

Old   October 21, 2009, 03:36
Default
  #8
siw
Senior Member
 
Join Date: Jul 2009
Posts: 446
Rep Power: 14
siw will become famous soon enough
Yes, all the boundary layers are linked together so, as you say, the grading is causing this, but I had expected that feature could be switched OFF.

I did change the default parameter MESH.BLAYERTGRID.ORTHOGONAL_LAYERS to 15 (this is my quanity of layers) but that made no difference. So I'm guessing that this option is not being used.

How deterimental are these tilted elements compared to perfect quad elements on a solution? Since i will not be able to get perfect quad elements I can't compare solution results.
siw is offline   Reply With Quote

Old   October 21, 2009, 03:41
Default
  #9
Super Moderator
 
-mAx-'s Avatar
 
Maxime Perelli
Join Date: Mar 2009
Location: Switzerland
Posts: 2,992
Rep Power: 30
-mAx- will become famous soon enough
no idea about the parameters, and I wouldn't play with them.
Try to isolate the curved surface and apply the BL on this surface.
__________________
In memory of my friend Hervé: CFD engineer & freerider
-mAx- is offline   Reply With Quote

Reply

Tags
gambit orthogonal mesh

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Maximum no. of mesh fixed at 100k in Gambit? Peter FLUENT 5 July 16, 2008 20:44
Use Gambit to generate 3D mesh ! ! ! yuanye FLUENT 0 June 3, 2008 22:03
fluent add additional zones for the mesh file SSL FLUENT 2 January 26, 2008 12:55
Mesh Resolution in Gambit Vidya Raja FLUENT 2 January 19, 2006 00:35
3-D Mesh Check in Gambit..... SHR FLUENT 4 March 25, 2003 04:10


All times are GMT -4. The time now is 10:04.