CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   Meshing Ring Element (http://www.cfd-online.com/Forums/ansys-meshing/68583-meshing-ring-element.html)

Jalen September 24, 2009 11:18

Meshing Ring Element
 
Hi,

i am trying to mesh a verry thin ring volume Element (diamater about 400 mm, thickness 50 micros) with icem cfd. I am using the blocking approach to create a hexa mesh. (create o-grid) Because the simple geometry, i use one Block, assign the edges to the outer-ring-curves. Then i create an o-grid, i delete the block in the midle and assign the inner edges to the inner ring curves.

My problem is that some surfaces are overlapped or simply disapeared after pre mesh. I tried for some days now but i always have the same problem. I controlled the surfaces an they do not overlap.

Do somebody have experiance with the meshing of such a thin geometry? Is it possible that icem cfd is not suited for such a case? Are there maybe some settings to control the quality of the geometry? (tolerances or something like this)

I realy appreciate your help.

Regards, Jalen

PSYMN October 12, 2009 14:41

Give it another try?
 
I am a bit late responding, is it taken care of yet?

It could be that the geometry is not as well resolved as your mesh needs it to be. There are some settings you could try.

If you could post the geometry, I could give it a try.

Simon

Jalen October 20, 2009 09:21

Geometry accuracy
 
Hello Simon,

thanks for your reply. I think i figured it out.

As you mentioned the accuracy of the geometry was a problem. I first used a step format to import the geometry into icem.
The inaccuracy of this format caused that two surfaces crossed each other.
After i used the catiaV4 format .model, this problem was solved.

The other problem was that i first did'nt recognize that the blocking edges where crossed.
I assigned the blocking vertices to the geometry curves, so that they could still move on the curves. After another assign function icem moved the vertices automaticly so that some of them caused crossed edges on the o-grid.

After a lot of zooming in to controll vertices and edges, it worked, an despite the small gap it was possible to create 15 layers without problems.

Best regards,

Jalen


All times are GMT -4. The time now is 16:05.