CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] Edge Params - Spacing limit values (http://www.cfd-online.com/Forums/ansys-meshing/69104-icem-edge-params-spacing-limit-values.html)

shogologo October 12, 2009 10:08

[ICEM] Edge Params - Spacing limit values
 
Hello everybody,

when trying to specify very small values of spacing (i.e. 0.001) in "Blocking -> Meshing Parameters -> edge params" on a vertical edge (lenght of a vertical pipe) it seems that elements collapse as the first outer nodes from Inlet/Outlet are projected to the horizontal surfaces (inlet/outlet of the tube), while for values of 0.005 mesh is correct.
I tried to force with "Asociate Face -> Surface - Method part" with no success.
Is there a way to do this other than splitting the unstructured mesh?

Thanks in advance.

PSYMN October 16, 2009 09:11

Projection Limit.
 
This sometimes happens because the geometry is not as good as you want your mesh to be...

You are inserting lots of nodes near the edge of the surface and the surface may not really be there for them to project to. You could turn off the projection for the whole surface, but the easiest fix is to go into

Settings => Meshing Options => Hexa Mixed.

Set the Projection limit to something like 0.01.

This will project the curve nodes to the curves and then interpolate the projection of the nodes within 0.01 of the edge instead of projecting them to the poor geometry.

If that is not enough, try a larger projection limit, 0.02 or 0.05...

If that still fails, you could turn on the option to "Project to Bsplines". Usually, this is more important for very fine mesh rather than for very close wall spacing, but some times this is also necessary. Without this option, Hexa projects to a faceted representation of the geometry (based on tri-tolerance), this saves time but may create a faceted appearance for fine mesh which could then interfere with fine near wall spacing... But when you turn this on, it will actually take the time to use the B-spline definitions to calculate the projection.

PSYMN October 16, 2009 09:13

Other threads...
 
I was sure this was not my first post about this, I found these, but to be fair, I used the answer as my search ;)

http://www.cfd-online.com/Forums/ans...ner-layer.html

http://www.cfd-online.com/Forums/ans...m-cfd-cfx.html

shogologo October 19, 2009 02:24

Quote:

Originally Posted by PSYMN (Post 232909)
You could turn off the projection for the whole surface, but the easiest fix is to go into

Settings => Meshing Options => Hexa Mixed.

Set the Projection limit to something like 0.01.

This will project the curve nodes to the curves and then interpolate the projection of the nodes within 0.01 of the edge instead of projecting them to the poor geometry.

If that is not enough, try a larger projection limit, 0.02 or 0.05...

If that still fails, you could turn on the option to "Project to Bsplines". Usually, this is more important for very fine mesh rather than for very close wall spacing

Thanks for your kind reply.

The first issue effectively does not work for me...even setting smaller tolerance values (1e-3; 1e-4; 1e-5).
But the second issue ("project to B-splines") allows to create the desired fine mesh near wall.

Thanks a lot for the support. Hope this help someone else as well.

PSYMN October 19, 2009 21:49

Facetization...
 
Great, so your problem was more about the facetization of the model rather than the mis match of bspline surfaces.

With ICEM CFD, there always seems to be a work around.

Simon


All times are GMT -4. The time now is 04:19.