CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[ICEM] Edge Params - Spacing limit values

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 12, 2009, 10:08
Default [ICEM] Edge Params - Spacing limit values
  #1
New Member
 
Join Date: May 2009
Posts: 17
Rep Power: 8
shogologo is on a distinguished road
Hello everybody,

when trying to specify very small values of spacing (i.e. 0.001) in "Blocking -> Meshing Parameters -> edge params" on a vertical edge (lenght of a vertical pipe) it seems that elements collapse as the first outer nodes from Inlet/Outlet are projected to the horizontal surfaces (inlet/outlet of the tube), while for values of 0.005 mesh is correct.
I tried to force with "Asociate Face -> Surface - Method part" with no success.
Is there a way to do this other than splitting the unstructured mesh?

Thanks in advance.
shogologo is offline   Reply With Quote

Old   October 16, 2009, 09:11
Default Projection Limit.
  #2
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 36
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
This sometimes happens because the geometry is not as good as you want your mesh to be...

You are inserting lots of nodes near the edge of the surface and the surface may not really be there for them to project to. You could turn off the projection for the whole surface, but the easiest fix is to go into

Settings => Meshing Options => Hexa Mixed.

Set the Projection limit to something like 0.01.

This will project the curve nodes to the curves and then interpolate the projection of the nodes within 0.01 of the edge instead of projecting them to the poor geometry.

If that is not enough, try a larger projection limit, 0.02 or 0.05...

If that still fails, you could turn on the option to "Project to Bsplines". Usually, this is more important for very fine mesh rather than for very close wall spacing, but some times this is also necessary. Without this option, Hexa projects to a faceted representation of the geometry (based on tri-tolerance), this saves time but may create a faceted appearance for fine mesh which could then interfere with fine near wall spacing... But when you turn this on, it will actually take the time to use the B-spline definitions to calculate the projection.
PSYMN is offline   Reply With Quote

Old   October 16, 2009, 09:13
Default Other threads...
  #3
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 36
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
I was sure this was not my first post about this, I found these, but to be fair, I used the answer as my search

(ICEM)Negative volumes instead of thiner layer

negative mesh volume problem (icem-cfd/cfx)
PSYMN is offline   Reply With Quote

Old   October 19, 2009, 02:24
Default
  #4
New Member
 
Join Date: May 2009
Posts: 17
Rep Power: 8
shogologo is on a distinguished road
Quote:
Originally Posted by PSYMN View Post
You could turn off the projection for the whole surface, but the easiest fix is to go into

Settings => Meshing Options => Hexa Mixed.

Set the Projection limit to something like 0.01.

This will project the curve nodes to the curves and then interpolate the projection of the nodes within 0.01 of the edge instead of projecting them to the poor geometry.

If that is not enough, try a larger projection limit, 0.02 or 0.05...

If that still fails, you could turn on the option to "Project to Bsplines". Usually, this is more important for very fine mesh rather than for very close wall spacing
Thanks for your kind reply.

The first issue effectively does not work for me...even setting smaller tolerance values (1e-3; 1e-4; 1e-5).
But the second issue ("project to B-splines") allows to create the desired fine mesh near wall.

Thanks a lot for the support. Hope this help someone else as well.
shogologo is offline   Reply With Quote

Old   October 19, 2009, 21:49
Default Facetization...
  #5
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 36
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
Great, so your problem was more about the facetization of the model rather than the mis match of bspline surfaces.

With ICEM CFD, there always seems to be a work around.

Simon
PSYMN is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Actuator disk model audrich FLUENT 0 September 21, 2009 07:06
Where's the singularity/mesh flaw? audrich FLUENT 3 August 4, 2009 01:07
fluent add additional zones for the mesh file SSL FLUENT 2 January 26, 2008 12:55
ICEM Extrude faces - Edge params. Santiago Orrego. CFX 0 June 19, 2007 12:08
Star mesh import problem chris1980 OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 20 May 8, 2006 01:07


All times are GMT -4. The time now is 09:11.