CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] prism problem (http://www.cfd-online.com/Forums/ansys-meshing/70381-prism-problem.html)

zkdkeen November 22, 2009 23:16

prism problem
 
Dear experts:
i have met a problem during tetra-prism meshing.
- geometry is a pigeon.
- tetra is good.
- i defined 20 layers' prism to generate after that. but the result is not very good, since the layers near wing back edge is reducing.

how to avoid that? thanks for your answer.

PSYMN November 23, 2009 15:29

Prism on a sharp trailing edge.
 
1 Attachment(s)
Sure, I am guessing that you have a sharp trailing edge and that you are seeing stair stepping as the prisms approach the edge.

It could be that the Max prism angle is too low (in needs to be 180 to "wrap around" the trailing edge.

Or it could be that your min quality is too high, therefore forcing the prisms to fail rather than bend around the trailing edge. This will even cause a message to pop up saying that the Max prism angle has been reduce to something (like 176) in order to maintain the required quality. The ICEM CFD prism calculation is extremely conservative, so don't worry about setting the min prism quality to 0.0000001.

You could also consider extruding the trailing edge back as a zero thickness baffle surface and then you could run the prisms on that also. 12.1 (due out Dec 1st, 2009) includes improvements wrt prisms on baffles, but this will also work well with older versions of the software. It also enables better wake capture.

I will try to attach some images to help.

PSYMN November 23, 2009 15:31

Sounds like fun.
 
By the way, this sounds like a fun, if academic, model to play with. If you sent it too me (privately), I would play with it and show you the settings needed to optimize the prism mesh.

gajemon November 24, 2009 09:45

the same problem
 
1 Attachment(s)
I have the same problem you are telling. I'm seeing stair stepping as the prisms approach the edge. I have defined all parameters of prizm meshing as you have told. But results is bad.
what should I do for getting connected prizm layers around tight bends.
thanks in advance

PSYMN November 24, 2009 18:15

Stair stepping option on zero thickness baffles.
 
2 Attachment(s)
It looks like you have a zero thickness baffle. We had an issue with these always stair stepping (even if you turn off the option) at 11 and 12.0. This has been fixed for 12.0 due out Dec 1st.

I will attach a 12.1 screen shot, with and without the stair stepping option (found under advanced prism params)...

On the other hand, you will probably find that the quality is better with stair stepping. Perhaps extend the baffle with a construction surface. Also use the construction surface to grow prisms and then delete the construction surface shells so they don't affect the flow. This will better capture the wake behind the baffle and since stair stepping will gently reduce the prism layers further from your critical zone, improve the solution quality.

Simon

zkdkeen December 2, 2009 21:54

Thanks for your advise! It helps a lot. As the model, a simple pigeon, made all by myself, which is not very good looking...,I will mail to you later.


All times are GMT -4. The time now is 01:04.