CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] what is wrong with my blocking "meshing parameters"? (http://www.cfd-online.com/Forums/ansys-meshing/70456-what-wrong-my-blocking-meshing-parameters.html)

snailstb November 25, 2009 04:49

what is wrong with my blocking "meshing parameters"?
 
3 Attachment(s)
i want to create hex mesh with ICEMCFD,two relative edges which seems to be parallel each other.

but actually, they are not showed when i select "to all parallel edges", just like 1w and 2w figture.

i want to distribute the same nodes in the two edges. for example, when i set 3 nodes in second edge, the first edge became 15, but when i set 15 nodes in second edge, the first one became 27. i tried several methods such "linked bunching, to match the nodes number between these two edges, but unsuccessful.

i want to know which causes this? any hint and reply is Extremely grateful. thank you all.

PSYMN November 28, 2009 00:31

Implied splits.
 
These edges are not as parallel as you think ;)

In fact, I assume the second edge is a component of the first. When you increase the component, it adds to the other. The other edge that combines has 12 nodes... So anything you add to the second (3 or 15) is combined with the 12 to give your final counts on the first edge...

Users get into this kind of trouble by using partial splits...

It is easy for new users to forget that that the splits they make continue on even through the sections where you can't see them (we call these "implied splits"... It is just the nature of multiblock and can't really be avoided; if you split an index, it is split, even in the areas where you don't see the split, because otherwise the math wouldn't add up. When you make a new split in the previously hidden region, if it is right on the implied split, it will use that index, but if it is a little off, it will create a new split which may then propagate other implied splits, etc.

I avoid this trouble by extending my splits thru the entire blocking (unless I really have a good reason not to)... Some say it is "messy", but at least I can see the splits and don't need to keep track of implied ones. If you do that (Split blocks => Extend split) here you will see the two splits and be able to collapse a layer. If you had done it initially (Split with all blocks displayed), the split would have already been at the second location and you wouldn't have felt the need to split again... (It was the the second split also created an "implied split" at the first location causing your trouble.)

The fix is to find that edge with 12 nodes and adjust it... If you can't then extend some splits and see where they go. You may decide you want to fix it (collapse an index with merge verts and propagate) or if it is really bad, chalk it off to the learning curve and start again with fully propagated edges (split with all blocks visible) unless you are really sure what you are doing.

Hope this answer doesn't confuse more than it helps.

snailstb December 1, 2009 08:32

Quote:

Originally Posted by PSYMN (Post 238025)
Hope this answer doesn't confuse more than it helps.

firstly, thank you, simon.

i split the first edge and second edge using "extend split" respectively.
i find that implied splits between these two edges disappear.but the first edge index is not the second index.

so i have no choose but create a new block once again, and split through this two deges in order to make them continuous. the implied edge disappear.when i select "copy to parallel edges", these two edges show parallel.

i wonder when the implied edges will come out? splitting the block is the only way to avoid the implied edges?

by the way, when i meshing, one error occour as follow:

"A minor internal error has occurred.
You may continue to work but if problems arise they may be related to this error.
Try using the check/fix function to fix the problem
The following message was designed to aid developers fix the problem:
error meshing edge 276 283"what causes this error? how to solve it? and what is meaning about "edge 276 283", does it mean that edge 276 is the edge number? i can not find out how to know the edge number in ICEMCFD.

thank you very much.

PSYMN December 1, 2009 23:48

Edge vertex1 vertex2
 
The edges are named by the verts on either side.

In the model tree, you can right click on vertex and turn on the option to show the numbers.

Under the blocking tab, you can try the check/fix to see if it will sort out the problem.

Not all of these errors will stop you from meshing.


To get rid of issues due to implied splits, I usually use the option to "Extend splits".

I have a development task in place to improve this and allow the select tool to lock onto hidden implied splits so that it can use the existing index instead of creating a new one; hopefully we can take care of that before the next release...

snailstb December 2, 2009 02:42

Quote:

Originally Posted by PSYMN (Post 238401)
The edges are named by the verts on either side.

In the model tree, you can right click on vertex and turn on the option to show the numbers.

Under the blocking tab, you can try the check/fix to see if it will sort out the problem.

Not all of these errors will stop you from meshing.


To get rid of issues due to implied splits, I usually use the option to "Extend splits".

I have a development task in place to improve this and allow the select tool to lock onto hidden implied splits so that it can use the existing index instead of creating a new one; hopefully we can take care of that before the next release...

than you for your reply. That is a good idea for ICEMCFD hex user. you said"The edges are named by the verts on either side." my block is very complex, and it is a tough task to find the number of vertexs i want. is there any short cut to get the edge such as "edge 12 50"? for example, when i enter the vertexs number of edge, then the edge will highlight. i think there may be a good method for user to find the error related to the edge.

thank you .

PSYMN December 2, 2009 15:31

display_nodes
 
Ok, sure, you can do anything with ICEM CFD, but there isn’t always a button. ;)

Go to the model tree and make sure Vertices is off… But right click on Verticies and activate the display option for “Numbers”.

Then type the display nodes command in the message window (in a fresh line at the bottom) and hit enter.

display_nodes number n1 n2 …
e.g: display_nodes number 25
display_nodes number 25 30

It will display just these verts (rather than all the vertices) with their vertex node numbers ( n1, n2) … on the screen.

There are lot of hidden things you can do from Tcl. You can see them if you setenv HEXA_DEBUG 1. :cool:


All times are GMT -4. The time now is 15:54.