CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

How to change Gambit's default directory

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 5, 2010, 12:16
Default How to change Gambit's default directory
  #1
New Member
 
Alejandra
Join Date: Mar 2009
Posts: 17
Rep Power: 7
alemenchaca is on a distinguished road
Can someone tell me how to change Gambit's default directory? I am tired of having to click on a thousand paths to get to my files every time I use Gambit...
Thanks.
alemenchaca is offline   Reply With Quote

Old   February 5, 2010, 12:17
Default
  #2
New Member
 
Alejandra
Join Date: Mar 2009
Posts: 17
Rep Power: 7
alemenchaca is on a distinguished road
I meant the "working directory".
alemenchaca is offline   Reply With Quote

Old   February 8, 2010, 02:18
Default
  #3
Super Moderator
 
-mAx-'s Avatar
 
Maxime Perelli
Join Date: Mar 2009
Location: Switzerland
Posts: 2,872
Rep Power: 29
-mAx- will become famous soon enough
For the windows version:
On the Gambit Icon, right-click --> Properties --> Start In:
Give the path of your working directory
__________________
In memory of my friend Hervé: CFD engineer & freerider
-mAx- is offline   Reply With Quote

Old   February 8, 2010, 11:50
Default
  #4
New Member
 
Alejandra
Join Date: Mar 2009
Posts: 17
Rep Power: 7
alemenchaca is on a distinguished road
Thanks -mAx-, but I tried that already... and does not work!
It keeps giving me C:\Documents and Settings\Username
alemenchaca is offline   Reply With Quote

Old   February 8, 2010, 13:17
Default
  #5
Super Moderator
 
-mAx-'s Avatar
 
Maxime Perelli
Join Date: Mar 2009
Location: Switzerland
Posts: 2,872
Rep Power: 29
-mAx- will become famous soon enough
It should work.
Replace C:\Documents and Settings\Username, with your valid path.
To be sure that your path is correct, copy it from the explorer
__________________
In memory of my friend Hervé: CFD engineer & freerider
-mAx- is offline   Reply With Quote

Old   February 8, 2010, 13:22
Default
  #6
New Member
 
Alejandra
Join Date: Mar 2009
Posts: 17
Rep Power: 7
alemenchaca is on a distinguished road
I double checked the path, and copied it from explorer just in case. Still not working

I do notice something strange: Everytime I open Propoerties again, the path I had recently typed now has quote marks. If I remove them, they appear again when I go to Properties.

Could that be a hint to the potential problem?
alemenchaca is offline   Reply With Quote

Old   February 8, 2010, 13:28
Default
  #7
Super Moderator
 
-mAx-'s Avatar
 
Maxime Perelli
Join Date: Mar 2009
Location: Switzerland
Posts: 2,872
Rep Power: 29
-mAx- will become famous soon enough
And the path is the right one or it shows the default's one?.
Try with or without quote, it should work: I did it on Friday
__________________
In memory of my friend Hervé: CFD engineer & freerider
-mAx- is offline   Reply With Quote

Old   February 8, 2010, 13:37
Default
  #8
New Member
 
Alejandra
Join Date: Mar 2009
Posts: 17
Rep Power: 7
alemenchaca is on a distinguished road
It's the right one, but with quotes.
Not working with or without quotes.

Note that "Start in:" used to be blank before I added my own path.

I just checked with my office mate, his "Start in:" is also empty, and his Gambit doesn't start from the same "C:\Documents and Settings\Username" directory but from "C:\"

Confusing...!
alemenchaca is offline   Reply With Quote

Old   April 15, 2010, 23:08
Default
  #9
New Member
 
Jack
Join Date: Mar 2010
Posts: 28
Rep Power: 6
aggie is on a distinguished road
I tried it and now working directory is fine.
thank you very much that was killing me.
aggie is offline   Reply With Quote

Old   April 16, 2010, 10:07
Default
  #10
New Member
 
Alejandra
Join Date: Mar 2009
Posts: 17
Rep Power: 7
alemenchaca is on a distinguished road
That's funny, I never got it to work myself...!
alemenchaca is offline   Reply With Quote

Old   April 16, 2010, 15:17
Default
  #11
New Member
 
Jack
Join Date: Mar 2010
Posts: 28
Rep Power: 6
aggie is on a distinguished road
When I run gambit again, it saved the document to C:\Windows\System32 . I searched the directory and could not see the file. I re-open gambit and changed the both start-in from properties and working directory from gambit startup and it saved the file to my working directory. As far as I understood, each time I open gambit, I should re submit the working directory..
aggie is offline   Reply With Quote

Old   April 30, 2010, 11:11
Default It think I got it
  #12
New Member
 
Alejandra
Join Date: Mar 2009
Posts: 17
Rep Power: 7
alemenchaca is on a distinguished road
I think the problem is the length of the file path.
If I set C:\, then it works like a charm. If I set the file path for my fluent files (~ 6 subfolders with long names), then it doesn't work.
alemenchaca is offline   Reply With Quote

Old   October 31, 2011, 07:18
Cool Got it!!!
  #13
Member
 
Join Date: Oct 2011
Posts: 72
Rep Power: 5
tsram90 is on a distinguished road
I have been google ing this for a while.. Never got a solution anywhere...

The things is to give your working directory address in Start in.. But the problem is the address should not have any spaces .

My address was C:\Main Project\Gambit Files.

I changed it to C:\Main_Project\Gambit_Files it works now..

(You should Change the original folder name also)
tsram90 is offline   Reply With Quote

Reply

Tags
gambit

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re : Problem Installing OpenFOAM on Centos -5.3 mohanphy OpenFOAM Installation 1 February 7, 2010 20:09
Problem installing on Ubuntu 9.10 -> 'Cannot open : No such file or directory' mfiandor OpenFOAM Installation 2 January 25, 2010 10:50
Gambit Default Working Directory Virgil Howardson FLUENT 5 December 19, 2009 07:13
Compiling OpenFOAM13 on AMD64 with Redhat Enterprise mbeaudoin OpenFOAM Installation 20 June 17, 2008 07:43
Gerris software installation mer Main CFD Forum 2 November 12, 2005 09:50


All times are GMT -4. The time now is 06:27.