CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] wing body tutorials, problem (http://www.cfd-online.com/Forums/ansys-meshing/72625-wing-body-tutorials-problem.html)

zxin February 12, 2010 06:19

wing body tutorials, problem
 
Hi, guys,

I got a trouble when doing the tutorials of ICEM, the wing body, hexa mesh. I followed the instructions and steps carefully. But the result I got is different from the mesh size that the tutorial shows. I got 40 millions nodes and hexas, after I set the surface mesh parameters as, maximum size to 300, height to 300 and height ratio to 1. This lead me can't even see the grid in the pre-mesh.

on the same edge, I got 3332 nodes, and tutorial shows only 115.

Hope somebody can help me with this rokie problem.

Thank you!

PSYMN February 14, 2010 19:05

not sure...
 
I am not sure what went wrong... perhaps you had something set finer than you thought. If you post the files (*.tin and *.blk), I could take a quick look.

In the mean time, you can fix the edge distribution manually

Use the middle icon to adjust edge distribution, select the edge and change the number of nodes to 115.


Simon

zxin February 18, 2010 06:08

Quote:

Originally Posted by PSYMN (Post 246009)
I am not sure what went wrong... perhaps you had something set finer than you thought. If you post the files (*.tin and *.blk), I could take a quick look.

In the mean time, you can fix the edge distribution manually

Use the middle icon to adjust edge distribution, select the edge and change the number of nodes to 115.


Simon

Hi Simon,

Thank you for your information and sorry for this late reply.
I solved the problem by changing the number of nodes on the edge manually. But I still don't know why the default number of nodes get that high.
Because there is something wrong with my computer, the file lost. I will mesh it again and if the problem remains, I will post it to you and hope you can make a quick look. Thank you ^_^

Xin

nuovodna February 23, 2010 11:04

OT Where can i found wing body tutorial?!?! Thanks FOUND IT (Help section of software)

cylee March 9, 2010 16:40

Quote:

Originally Posted by zxin (Post 245819)
Hi, guys,

I got a trouble when doing the tutorials of ICEM, the wing body, hexa mesh. I followed the instructions and steps carefully. But the result I got is different from the mesh size that the tutorial shows. I got 40 millions nodes and hexas, after I set the surface mesh parameters as, maximum size to 300, height to 300 and height ratio to 1. This lead me can't even see the grid in the pre-mesh.

on the same edge, I got 3332 nodes, and tutorial shows only 115.

Hope somebody can help me with this rokie problem.

Thank you!

I am having a similar problem. I follow the surface mesh setup instructions to first set the size globally (300, 300, 1) then locally on the wing-body (50, 50, 1.4) and end up with 750 million nodes and hexas. The pre-mesh won't even generate because it is so large. Checking edge parameters on 25-130 I see that it has 3943 nodes instead of the expected 115. I've gone over the steps of the entire tutorial 3 times with the same result. I will try to set the edge parameters manually but would appreciate some help in finding out why I had the initial error to begin with.

Thanks,

Conrad Lee

lehoang_mai March 16, 2010 09:19

I have an error as, how fix it, everybody?

A minor internal error has occurred.
You may continue to work but if problems arise they may be related to this error.
Try using the check/fix function to fix the problem
The following message was designed to aid developers fix the problem:

failed to allocate space for 140393388 nodes of 32 bytes each

PSYMN March 16, 2010 14:52

Too many nodes, check edge params.
 
lehoang_mai

Your mesh is just too big (too many, 140 million, nodes) for your machine...

Chances are that something went wrong when you setup the sizes and things are really much finer than you think...

In the model tree, right click on edges and turn on the option for bunching... I am pretty sure you will find some edges with way too many nodes. Then use Blocking tab to adjust the edge parameters for those edges to have fewer nodes...

If you really did need 140 million nodes, then perhaps you should get a bigger 64 bit machine.

Simon

lehoang_mai May 2, 2010 16:12

Thanks Simon!

Tony12 March 22, 2011 02:05

I ran into the same problem, but I was able to considerably reduce the number of nodes by manually changing the number of nodes through bunching. Thanks Simon that really helped me out!

Tony


All times are GMT -4. The time now is 16:01.