CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[ICEM] wing body tutorials, problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 12, 2010, 06:19
Default wing body tutorials, problem
  #1
New Member
 
zhao xin
Join Date: Feb 2010
Location: Goteborg
Posts: 28
Rep Power: 7
zxin is on a distinguished road
Hi, guys,

I got a trouble when doing the tutorials of ICEM, the wing body, hexa mesh. I followed the instructions and steps carefully. But the result I got is different from the mesh size that the tutorial shows. I got 40 millions nodes and hexas, after I set the surface mesh parameters as, maximum size to 300, height to 300 and height ratio to 1. This lead me can't even see the grid in the pre-mesh.

on the same edge, I got 3332 nodes, and tutorial shows only 115.

Hope somebody can help me with this rokie problem.

Thank you!
zxin is offline   Reply With Quote

Old   February 14, 2010, 19:05
Default not sure...
  #2
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 35
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
I am not sure what went wrong... perhaps you had something set finer than you thought. If you post the files (*.tin and *.blk), I could take a quick look.

In the mean time, you can fix the edge distribution manually

Use the middle icon to adjust edge distribution, select the edge and change the number of nodes to 115.


Simon
PSYMN is offline   Reply With Quote

Old   February 18, 2010, 06:08
Default
  #3
New Member
 
zhao xin
Join Date: Feb 2010
Location: Goteborg
Posts: 28
Rep Power: 7
zxin is on a distinguished road
Quote:
Originally Posted by PSYMN View Post
I am not sure what went wrong... perhaps you had something set finer than you thought. If you post the files (*.tin and *.blk), I could take a quick look.

In the mean time, you can fix the edge distribution manually

Use the middle icon to adjust edge distribution, select the edge and change the number of nodes to 115.


Simon
Hi Simon,

Thank you for your information and sorry for this late reply.
I solved the problem by changing the number of nodes on the edge manually. But I still don't know why the default number of nodes get that high.
Because there is something wrong with my computer, the file lost. I will mesh it again and if the problem remains, I will post it to you and hope you can make a quick look. Thank you ^_^

Xin
zxin is offline   Reply With Quote

Old   February 23, 2010, 11:04
Default
  #4
Senior Member
 
Emanuele
Join Date: Mar 2009
Posts: 110
Rep Power: 8
nuovodna is on a distinguished road
OT Where can i found wing body tutorial?!?! Thanks FOUND IT (Help section of software)

Last edited by nuovodna; February 23, 2010 at 11:08. Reason: Solved
nuovodna is offline   Reply With Quote

Old   March 9, 2010, 16:40
Default
  #5
New Member
 
Conrad Lee
Join Date: Mar 2010
Posts: 1
Rep Power: 0
cylee is on a distinguished road
Quote:
Originally Posted by zxin View Post
Hi, guys,

I got a trouble when doing the tutorials of ICEM, the wing body, hexa mesh. I followed the instructions and steps carefully. But the result I got is different from the mesh size that the tutorial shows. I got 40 millions nodes and hexas, after I set the surface mesh parameters as, maximum size to 300, height to 300 and height ratio to 1. This lead me can't even see the grid in the pre-mesh.

on the same edge, I got 3332 nodes, and tutorial shows only 115.

Hope somebody can help me with this rokie problem.

Thank you!
I am having a similar problem. I follow the surface mesh setup instructions to first set the size globally (300, 300, 1) then locally on the wing-body (50, 50, 1.4) and end up with 750 million nodes and hexas. The pre-mesh won't even generate because it is so large. Checking edge parameters on 25-130 I see that it has 3943 nodes instead of the expected 115. I've gone over the steps of the entire tutorial 3 times with the same result. I will try to set the edge parameters manually but would appreciate some help in finding out why I had the initial error to begin with.

Thanks,

Conrad Lee
cylee is offline   Reply With Quote

Old   March 16, 2010, 09:19
Default
  #6
Member
 
lehoang_mai's Avatar
 
User_CFD
Join Date: Mar 2010
Posts: 48
Rep Power: 7
lehoang_mai is on a distinguished road
I have an error as, how fix it, everybody?

A minor internal error has occurred.
You may continue to work but if problems arise they may be related to this error.
Try using the check/fix function to fix the problem
The following message was designed to aid developers fix the problem:

failed to allocate space for 140393388 nodes of 32 bytes each
lehoang_mai is offline   Reply With Quote

Old   March 16, 2010, 14:52
Default Too many nodes, check edge params.
  #7
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 35
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
lehoang_mai

Your mesh is just too big (too many, 140 million, nodes) for your machine...

Chances are that something went wrong when you setup the sizes and things are really much finer than you think...

In the model tree, right click on edges and turn on the option for bunching... I am pretty sure you will find some edges with way too many nodes. Then use Blocking tab to adjust the edge parameters for those edges to have fewer nodes...

If you really did need 140 million nodes, then perhaps you should get a bigger 64 bit machine.

Simon
PSYMN is offline   Reply With Quote

Old   May 2, 2010, 16:12
Default
  #8
Member
 
lehoang_mai's Avatar
 
User_CFD
Join Date: Mar 2010
Posts: 48
Rep Power: 7
lehoang_mai is on a distinguished road
Thanks Simon!
lehoang_mai is offline   Reply With Quote

Old   March 22, 2011, 02:05
Default
  #9
New Member
 
Tony
Join Date: Oct 2010
Posts: 11
Rep Power: 6
Tony12 is on a distinguished road
I ran into the same problem, but I was able to considerably reduce the number of nodes by manually changing the number of nodes through bunching. Thanks Simon that really helped me out!

Tony
Tony12 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get good results on ahmed body research Michael Main CFD Forum 8 September 17, 2008 13:55
Laminar wing profiles and drag gregorv OpenFOAM Running, Solving & CFD 4 December 4, 2007 14:25
Simulate flow field of moving body by dynamic meshes luckyluke OpenFOAM Running, Solving & CFD 5 January 10, 2006 05:37
Periodic flow boundary condition problem sudha FLUENT 3 April 28, 2004 08:40
Problem about 3D blunt body high Re simulation David FLUENT 0 September 27, 2002 10:59


All times are GMT -4. The time now is 14:44.