CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] Low quality mesh at curve-surface intersections (http://www.cfd-online.com/Forums/ansys-meshing/73211-low-quality-mesh-curve-surface-intersections.html)

AndBra March 2, 2010 07:55

Low quality mesh at curve-surface intersections
 
Hi!
I have a problem with ICEM Hexa. I get low quality cells close to curves since the surfaces and curves don't match up (poor quality CAD). I know that this can be solved by using Projection Limit, but that creates problem in other areas of the mesh where I wan't the cells to be projected.
Is there a way to fix either the geometry and remove the "gaps" or set individual projection limit for certain areas?

I should mention that I am self-learned when it comes to ICEM, so there is a possibility that I have missed some really basic stuff, especially when it comes to geometry handling. Therefore all advice is appreciated.

Thanks in advance
/Andreas

PSYMN March 3, 2010 09:51

Lots of options.
 
I am glad you know about projection limit, that would have been my first suggestion. Not that it is out of the way...;)

In certain situation, I might use "associate face to surface => Interpolate" . Basically, it uses the edge projection but interpolates the surface projection for that face...

Another option is to look at the associate edge to curve options, there is one in there that does the projection in two steps. It starts with the curve and then projects down to the surface. It makes edges purple instead of green.

A third option is to clean up your geometry or get better geometry. If you are dealing with a very thin first layer height, simply increasing your tri-tolerance (Settings => Model) may make a big difference.

Post an image of a zoom in on the geometry problem and I may have more specific geometry repair suggestions.

Good luck.

Simon

AndBra March 4, 2010 08:33

2 Attachment(s)
Simon. Thank you for your advice!
I've tried your suggestions but none of them really solves my problem. I've created some pictures showing one problem area.
The first picture show the original look and the second one the same thing after I've changed the tri-tolerance.

Attachment 2472
Attachment 2473

Firstly I thought that changing the tri-tolerance had solved the problem, but some cells still give really low quality(less than zero...)
Can this be because the surfaces and curve still don't exactly match, as can be seen in the second picture?

PSYMN March 4, 2010 10:45

More options...
 
Right, so things got better with improved tri-tolerance, but not all the way...

Had you done any geometry repair, build topology or anything when at the lower tri-tolerance? If so, then go back and start from scratch with the higher tolerance. You may have damaged the model by doing those operations at a sloppy tolerance.

but there are still two more options (at least).

1) You could untrim those surfaces and then re intersect and retrim them with the intersection curves... Or you could try match edges, etc. There are lots of geometry repair tools.

2) Where did you get this model, if you broght it in as IGES but it came from CAD, perhaps you could use a better format. IGES is pretty much the worst. Direct CAD is best, but if you must use a third party format, I recommend ACIS (*.sat) for good quality. A few minutes spent figuring out a better way to get your model in could save you a lot of hassle with fixing sloppy geometry.

kiddmax July 3, 2013 09:00

Dear AndBra

Did you solve this problem? I have the same one now.

Best regards,
Ye


All times are GMT -4. The time now is 18:13.