CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[ICEM] Low quality mesh at curve-surface intersections

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 2, 2010, 06:55
Default Low quality mesh at curve-surface intersections
  #1
New Member
 
Join Date: Mar 2010
Posts: 4
Rep Power: 6
AndBra is on a distinguished road
Hi!
I have a problem with ICEM Hexa. I get low quality cells close to curves since the surfaces and curves don't match up (poor quality CAD). I know that this can be solved by using Projection Limit, but that creates problem in other areas of the mesh where I wan't the cells to be projected.
Is there a way to fix either the geometry and remove the "gaps" or set individual projection limit for certain areas?

I should mention that I am self-learned when it comes to ICEM, so there is a possibility that I have missed some really basic stuff, especially when it comes to geometry handling. Therefore all advice is appreciated.

Thanks in advance
/Andreas
AndBra is offline   Reply With Quote

Old   March 3, 2010, 08:51
Default Lots of options.
  #2
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,650
Blog Entries: 1
Rep Power: 33
PSYMN will become famous soon enoughPSYMN will become famous soon enough
I am glad you know about projection limit, that would have been my first suggestion. Not that it is out of the way...

In certain situation, I might use "associate face to surface => Interpolate" . Basically, it uses the edge projection but interpolates the surface projection for that face...

Another option is to look at the associate edge to curve options, there is one in there that does the projection in two steps. It starts with the curve and then projects down to the surface. It makes edges purple instead of green.

A third option is to clean up your geometry or get better geometry. If you are dealing with a very thin first layer height, simply increasing your tri-tolerance (Settings => Model) may make a big difference.

Post an image of a zoom in on the geometry problem and I may have more specific geometry repair suggestions.

Good luck.

Simon
PSYMN is offline   Reply With Quote

Old   March 4, 2010, 07:33
Default
  #3
New Member
 
Join Date: Mar 2010
Posts: 4
Rep Power: 6
AndBra is on a distinguished road
Simon. Thank you for your advice!
I've tried your suggestions but none of them really solves my problem. I've created some pictures showing one problem area.
The first picture show the original look and the second one the same thing after I've changed the tri-tolerance.

screen1.jpg
screen2.jpg

Firstly I thought that changing the tri-tolerance had solved the problem, but some cells still give really low quality(less than zero...)
Can this be because the surfaces and curve still don't exactly match, as can be seen in the second picture?
AndBra is offline   Reply With Quote

Old   March 4, 2010, 09:45
Default More options...
  #4
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,650
Blog Entries: 1
Rep Power: 33
PSYMN will become famous soon enoughPSYMN will become famous soon enough
Right, so things got better with improved tri-tolerance, but not all the way...

Had you done any geometry repair, build topology or anything when at the lower tri-tolerance? If so, then go back and start from scratch with the higher tolerance. You may have damaged the model by doing those operations at a sloppy tolerance.

but there are still two more options (at least).

1) You could untrim those surfaces and then re intersect and retrim them with the intersection curves... Or you could try match edges, etc. There are lots of geometry repair tools.

2) Where did you get this model, if you broght it in as IGES but it came from CAD, perhaps you could use a better format. IGES is pretty much the worst. Direct CAD is best, but if you must use a third party format, I recommend ACIS (*.sat) for good quality. A few minutes spent figuring out a better way to get your model in could save you a lot of hassle with fixing sloppy geometry.
PSYMN is offline   Reply With Quote

Old   July 3, 2013, 09:00
Default
  #5
Member
 
Ye Zhang
Join Date: Dec 2009
Location: Delft,Netherland
Posts: 76
Rep Power: 6
kiddmax is on a distinguished road
Dear AndBra

Did you solve this problem? I have the same one now.

Best regards,
Ye
kiddmax is offline   Reply With Quote

Reply

Tags
icem. projection limit

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ICEM] Unstructure Meshing Around Imported Plot3D Structured Mesh ICEM kawamatt2 ANSYS Meshing & Geometry 17 December 20, 2011 11:45
fluent add additional zones for the mesh file SSL FLUENT 2 January 26, 2008 11:55
mesh quality and independency..!?? michelle CFX 0 October 15, 2007 05:50
Different types of Mesh quality hagupta CFX 1 June 30, 2006 07:42
mesh quality: urgent Madhukar Rapaka FLUENT 2 June 8, 2006 09:43


All times are GMT -4. The time now is 06:47.