CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [GAMBIT] GAMBIT 2.4.6 on Ubuntu 10.04 (http://www.cfd-online.com/Forums/ansys-meshing/75971-gambit-2-4-6-ubuntu-10-04-a.html)

DoHander May 10, 2010 23:09

GAMBIT 2.4.6 on Ubuntu 10.04
 
Hello,

does anyone has any experience with Gambit on Ubuntu 10.04 64 bits ? I've just installed Gambit and Fluent on Ubuntu 10.04, after the usual libstdc5 and libmotif everything seems to be just fine. Until my mouse was stuck on one of the GUI buttons from Gambit. I've encountered this bug twice and I was forced to kill Gambit by switching to a Console :o.

Any ideas of how can I avoid these kind of problems ?

Thanks,

Do

skhelladi May 11, 2010 06:30

same problem
 
Hi,
I have exactly the same problem. Yesterday I did a kernel update (2.6.32-22-generic x86_64) and I don't know if this bug is due to this update or not.
What version are you using?

I will try with my last kernel (2.6.31-16) and let you know.

skhelladi May 11, 2010 06:39

same problem
 
I have the same problem with 2.6.31-16 kernel...

DoHander May 11, 2010 07:40

Thanks Sofiane,

on the other hand Fluent works just fine.
Unfortunately for me I can't use Ubuntu 9.04 on my laptop, on Ubuntu 9.04 both Fluent and Gambit works perfectly, so ... I've installed in a VirtualBox Ubuntu 9.04 :) with Gambit, this is a temporary measure but I can do my work.

Do

skhelladi May 11, 2010 12:07

temporary solution!
 
Hi DoHander,
to use right button functions with ubuntu 10.04, one temporary solution I found is to use simultaneously left+right mouse buttons in this order and then select the function you need.
In the meantime, I hope someone will find the solution.

Quote:

Originally Posted by DoHander (Post 258312)
Thanks Sofiane,

on the other hand Fluent works just fine.
Unfortunately for me I can't use Ubuntu 9.04 on my laptop, on Ubuntu 9.04 both Fluent and Gambit works perfectly, so ... I've installed in a VirtualBox Ubuntu 9.04 :) with Gambit, this is a temporary measure but I can do my work.

Do


DoHander May 11, 2010 14:34

Thanks,

anyway it seems that Gambit is dead, since it is not included with Fluent 12. I suppose I will have to learn ICEM-CFD or Pointwise.

Do

Yankee May 17, 2010 05:09

I've the same problem as DOHandler with a 32-bit version, since I upgraded to ubuntu 10.04 : any right-mouse button click inside a gambit button makes the cursor stuck inside this gambit button
Furthermore, whenever I try to define a faces (or probably any other geometry part) gambit stops with a message :
Received exception: Assertion failed in MeshPacket.cc, line 358: mesh_packet

Not sure it's related to the change of kernel... suppose it's a problem of graphic libraries!

Of course, the best way would be to switch to Ansys meshing, but unfortunatly the meshing product doesn't work on 32bits ubuntu... See the cfd-online forum 'ANSYS Workbench on "Uncertified" Linux Distros'

fsaltara May 27, 2010 15:09

xorg server issue
 
The problem with gambit is related to a xorg-server bug that affects all motif applications. See https://bugs.launchpad.net/ubuntu/+bug/581032.

fsaltara June 9, 2010 11:49

The problem is related to motif applications, and is solved.

a) create a folder "tmp" in your user directory.

b) Download the patch "xorg-server_xastir_fix.patch" from http://launchpadlibrarian.net/495740...stir_fix.patch and copy it to the newly created "tmp" folder.

c) follow the steps:

$ cd ~/tmp
$ sudo apt-get install build-essential fakeroot dpkg-dev devscripts
$ apt-get source xserver-xorg-core
$ sudo apt-get build-dep xserver-xorg-core
$ cd xorg-server-1.7.6/
$ patch -p1 <~/tmp/xorg-server_xastir_fix.patch
$ dpkg-buildpackage -rfakeroot -uc -b
$ cd ..
$ sudo dpkg -i xserver-common_1.7.6-2ubuntu7_all.deb


then, depending if your system is 64 or 32 bits:


$ sudo dpkg -i xserver-xorg-core_1.7.6-2ubuntu7_amd64.deb


or


$ sudo dpkg -i xserver-xorg-core_1.7.6-2ubuntu7_i386.deb


d) reboot


After rebooting, the "trapped mouse" bug will be solved.


regards.


Fabio

skhelladi June 13, 2010 06:26

Thanks Fabio
 
The procedure you sent works very well.
Thanks Fabio.

mundhwam June 28, 2010 17:03

Hi could you please guide me how to start fluent and gambit in ubuntu..!!

Quote:

Originally Posted by DoHander (Post 258250)
Hello,

does anyone has any experience with Gambit on Ubuntu 10.04 64 bits ? I've just installed Gambit and Fluent on Ubuntu 10.04, after the usual libstdc5 and libmotif everything seems to be just fine. Until my mouse was stuck on one of the GUI buttons from Gambit. I've encountered this bug twice and I was forced to kill Gambit by switching to a Console :o.

Any ideas of how can I avoid these kind of problems ?

Thanks,

Do


dinesh2n@gmail.com July 4, 2010 12:29

tapped mouse
 
wow!!....thank you very much fsaltara
your procedure works great.
this is also described at https://bugs.launchpad.net/ubuntu/+bug/581032

two problem I faced in #9
1) in step 6th ; when I was patching as a non-root it did not patched; and threw an error of permission denied. So I needed to patch as root user.
2) Further at step 10th, instead of
dpkg -i xserver-xorg-core_1.7.6-2ubuntu7_i386.deb
I had to use dpkg -i xserver-xorg-core_1.7.6-2ubuntu7.2_i386.deb
This is just by typing upto xserver-xorg-core and pressing --> tab finds whatever version is available and runs.
So finally all worked fine

thank you very much

dinesh



PSYMN July 5, 2010 20:03

Gambit is still available if you need it.
 
To DoHander; Re Gambit is Dead...

Yes, our Gambit developers are all working hard to put the best bits of Gambit (such as the sizing function, Cooper tool, etc.) into ANSYS Meshing.

However, Gambit is still available. You can keep using the last release of Gambit if that is what suites your needs. That last version of Gamibit is still included with the latest version of Fluent (as long as you are not using the new ANSYS Licensing).

If you do switch to ANSYS Fluent and get the new Workbench Project Page, ANSYS Meshing, the new ANSYS Post (much better than Fluent Post), etc. and you want Gambit, you can add that to the order and get a permanent key...

And of-course, Fluent still accepts mesh from a variety of other meshers such as ICEM CFD or Pointwise.

enry August 2, 2010 05:26

Hi guys,
I found very interesting these post. I solved the problem of trapped mouse as the posts suggests, but I have a problem when I update my ubuntu. The problem of trapped mouse reappear after updating. Have you got the same problem?
Thanks in advance.

dinesh2n@gmail.com August 2, 2010 08:45

Quote:

Originally Posted by enry (Post 269773)
Hi guys,
I found very interesting these post. I solved the problem of trapped mouse as the posts suggests, but I have a problem when I update my ubuntu. The problem of trapped mouse reappear after updating. Have you got the same problem?
Thanks in advance.

I did not exactly noticed that but I had a doubt that updating might have created that trapped mouse problem. I think updating might have changed that xserver package. But it did not happen again for me. I mean now I have updated ubuntu many times and I do not have any problem with gambit; it works fine. the trapped mouse problem does not appear.
But what ever may be the reason you follow the procedure again; hopefully problem shall not reappear.

best

dinesh

enry August 2, 2010 09:15

Thanks !
Yes, repeating the procedure the problem will not appear. I will do it if the problem reappear after updating.
Bye!

bugra August 12, 2010 05:25

gambitt setup
 
hi everybody,

I had been using gambit in windows and now I want to use it in Ubuntu. I have software with license from university. but I can not open fluent and gambit. I think I couldn' t run the license.

Is there anyone can help me? How can I run my license in Ubuntu?

dinesh2n@gmail.com August 12, 2010 06:06

Quote:

Originally Posted by bugra (Post 271266)
hi everybody,

I had been using gambit in windows and now I want to use it in Ubuntu. I have software with license from university. but I can not open fluent and gambit. I think I couldn' t run the license.

Is there anyone can help me? How can I run my license in Ubuntu?


Ok how I did
1) I had gambit as
/home/dinesh/gambit/
2)$ cd /home/dinesh/gambit/Fluent.Inc/license/
$ls
arch_info license.dat lnamd64 lnx86
3) u may need to put this license.dat into lnx86
and then following command will run the gambit...i.e write the whole path of the executable gambit on the terminal as below
4) /home/dinesh/gambit/Fluent.Inc/bin/gambit

let me know if it helps u

dinesh

bugra August 12, 2010 07:20

Quote:

Originally Posted by dinesh2n@gmail.com (Post 271273)
Ok how I did
1) I had gambit as
/home/dinesh/gambit/
2)$ cd /home/dinesh/gambit/Fluent.Inc/license/
$ls
arch_info license.dat lnamd64 lnx86
3) u may need to put this license.dat into lnx86
and then following command will run the gambit...i.e write the whole path of the executable gambit on the terminal as below
4) /home/dinesh/gambit/Fluent.Inc/bin/gambit

let me know if it helps u

dinesh

hi,

I tried this but It's not running still. Is there anyother thing to do?

dinesh2n@gmail.com August 12, 2010 08:40

Quote:

Originally Posted by bugra (Post 271287)
hi,

I tried this but It's not running still. Is there anyother thing to do?

what is the error u are getting....
did u see any message on the terminal...


All times are GMT -4. The time now is 08:04.