CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] 3D blocking with a 2D surface inside (http://www.cfd-online.com/Forums/ansys-meshing/78422-3d-blocking-2d-surface-inside.html)

BrolY July 21, 2010 12:15

3D blocking with a 2D surface inside
 
Hi,

I created a 3D blocking for my model, and there are 2D surfaces inside it.
Those surfaces are solids and are inside the fluid domain. I splitted my blocks all around those surfaces and associated the edges to the curves.
But, when I pre-mesh the model, the surfaces aren't meshed, they are assigned to the fluid part.
How can I solve this?

I thought about associated the surfaces to the faces of the blocks, but those surfaces are in contact with 2 faces, so I didn't which one I should choose.

Thanks for your help,

BrolY July 22, 2010 05:31

Associated one of the faces of the blocks around the the 2D part with the surface worked well. The 2D surface is well meshed.
The index control is very useful for this operation!

PSYMN July 22, 2010 11:31

Face to Part...
 
Glad you figured it out... For the benefit of others let me explain...

In Hexa if you have the same block material on both sides of a face, the default is no projection and no shells. Even if you associate the perimeter edges to curves, the face default is still unassociated.

If you have a different material on the other side, the default is to associate face to the nearest surface. ICEM CFD hexa assumes you will have a surface between blocks of different materials. Some users may have blocks in different materials for other reasons (porus media or just to separate various fluid regions for display/modeling purposes), but without intent for actual walls between them. You can handle this with the Face to surface option for shared walls. it will let you pic whole blocking materials and decide the default between them.

In your particular case, you just had a zero thickness surface between blocks of the same material and needed to override the default (not projected). The fix is just to go into "Associate Face" and manually override with a new association to nearest or even a particular part. If you have two superimposed surfaces, it is probably better to pick one part so the mesh comes out consistent.


All times are GMT -4. The time now is 21:50.