CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   problems with 2d rectangular geometry (http://www.cfd-online.com/Forums/ansys-meshing/79247-problems-2d-rectangular-geometry.html)

ariereath August 17, 2010 21:17

problems with 2d rectangular geometry
 
I would like to create a basic, 2d, rectangular mesh using Ansys Workbench and export it into FLUENT 12.0. So far, I have made a surface from a sketch and meshed the surface, but when I try to import it into FLUENt, it says "Surface Meshes cannot be read".

Any ideas?

Also, tutorials/basics for Workbench are hard to find, so if anyone has some helpful links, it would be much appreciated

Thanks!

PSYMN August 18, 2010 10:14

Checks...
 
Is the 2D model in the XY plane (Z=0)?

I assume you created the 2D surface in DM using Create => Surface from Sketches or Surface From Edges?

Go back to the project schematic (main WB window) and click on your geometry. This should bring up a window named something like "Properties of Schematic A2:Geometry". In row 15, you will see "Analysis Type", make sure it is set to 2D (not 3D).

If the Geometry is officially 2D, the ANSYS Meshing app won't be asking you for the thickness. It will instead show the geometry as a "Surface Body.

What about Bocos? (not part of your question, but people ask this all the time). Just right click on each entitiy where you want a boco and create a "named selection". You will be selecting edges of the box for your bocos (INLET, OUTLET, WALLS), and the 2D face for the FLUID.

Are you linking ANSYS Meshing to Fluent inside Workbench or do you export the *.msh file and then launch Fluent separately?

If you are in WB and you did it right with a 2D geometry and Mesh, when you launch Fluent, it is smart enough to grey out the option for Dimension (2D or 3D) (top left of the Fluent Start window). If you are launching Fluent separately, you will need to make sure you choose 2D.

Thats it... When I opened Fluent, under General I see that the solver is default set to 2D Space Planar...

ariereath August 18, 2010 10:51

Yes, I am using a .msh file and opening FLUENT separately. I did define my Geometry as 2D, and I did create a surface from a sketch. I successfully imported a rectangular mesh, but the mesh element size was very large, they were 1 m x 1 m and my rectangle is only 1m x 10m. I am interested to learn how to make the element size smaller. Any ideas?

Thanks for your help!

PSYMN August 18, 2010 11:38

There are many controls in ANSYS Meshing that you could use to make the mesh smaller... You could start by setting a smaller max size or increasing the relevance... TO make the defaults better, make sure your physics is set to CFD (FLUENT) and not Mechanical...

Other than that I am not really sure what trouble you are running into. It works well for me. Maybe someone else has some ideas.

PSYMN August 18, 2010 11:39

Tutorials are on the customer portal, some may also be included in the help (depending on your version).


All times are GMT -4. The time now is 00:28.