CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] why is the edge color changed? (http://www.cfd-online.com/Forums/ansys-meshing/79733-why-edge-color-changed.html)

ringtail September 1, 2010 22:35

why is the edge color changed?
 
3 Attachment(s)
When I open the project, I will find the color of some edges have changed. As the following picture show, it changed to black.
Attachment 4568

But, if I turn off 'Edges' and then turn it on, the color will come back.

Attachment 4569
What's the matter?

And when I check the mesh quality, as the below picture show, there are some elements between 0.714717 and 0.72898075. But when I lighten the bar, I can't find anything. And the message is showed as below.
Attachment 4570
0.714717 -> 0.72898075, 1 values
0 elements

Anybody can help me? Thanks very much.

BrolY September 2, 2010 08:23

Open the ICEM help menu and search for 'move vertex'. You will find the explanation about the color of the edges. So, make sure you have associated all your curves with the good edge.

About the 'change color', I have never seen that before.
About the 'missing' element, try to convert your premesh into an unstructured mesh, and see if it happens again.

ringtail September 2, 2010 08:41

Quote:

Originally Posted by BrolY (Post 273746)
Open the ICEM help menu and search for 'move vertex'. You will find the explanation about the color of the edges. So, make sure you have associated all your curves with the good edge.

About the 'change color', I have never seen that before.
About the 'missing' element, try to convert your premesh into an unstructured mesh, and see if it happens again.

hi BrolY, thanks for your reply.

I have checked the ICEM hlep (v12.0), but it doesn't mention the 'black color' edges. And I'm sure all the edges have been associated with right curves. What's more, I have converted the mesh into unstructured mesh for FLUENT v12, and the mesh works well.

Then, about the 'missiong' element, It has already been convert into unstructured mesh. When I check the premesh, everything seems good.

BrolY September 2, 2010 09:57

When the edges are black, it means that they haven't been associated with any curves and that there are no constrains on the edges.
For the example, when you creat your first block, the edges are black.

About the missing element, could it be an edge or something like that? Anyway, your mesh quality is very good (> O.7 is nice. usually, > 0.3 is good for almost all solvers), so I guess it's not an issue.

PSYMN September 2, 2010 15:14

Sorry, I dont know what the problem is, but at least it is not stopping you.
 
That is strange (about the 0 elements)... What metric were you using?

As for the edge changeing colors from blue (volume edges) to black (surface associated), I don't have enough info to guess. Are those edges supposed to be in the volume or on the surface? And I have no idea why the color would change.

But in the end, it seems like your quality is very good and you can move on.


All times are GMT -4. The time now is 17:48.