CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] Suggestions for my Grid (http://www.cfd-online.com/Forums/ansys-meshing/80645-suggestions-my-grid.html)

Josh October 1, 2010 20:14

Suggestions for my Grid
 
Hi all -

Below are pictures of a grid I created for an external aerodynamics simulation at low Reynolds numbers.

http://img191.imageshack.us/img191/995/medgrid5.th.png

http://img709.imageshack.us/img709/5391/medgrid4.th.png

http://img405.imageshack.us/img405/9152/medgrid3.th.png

http://img192.imageshack.us/img192/49/medgrid2.th.png

http://img706.imageshack.us/img706/9092/medgrid1.th.png

Here are the mesh files:

http://rapidshare.com/files/422589463/New_Folder.rar


I'm looking for general suggestions into grid improvements. All of the elements are at least 90% in quality. Nearly all the elements have less than a four degree deviation from perfect orthogonality. The grid is well-resolved - I've validated it against results.

However, the quality is not as high as I would like it. When I use the smoother, although many elements improve in quality, many others (e.g., the ones in the farfield) see a huge decrease in quality.

Any and all suggestions are welcome. Thanks in advance!

PSYMN October 3, 2010 14:33

You could try matching edges... Particularly around the far field. This will allow for a smoother transition.

Once the edges are matched and transitioning the the way that you want, you could try the smoother.

Yes, the smoother may lower individual element quality a little bit, but the quality should still be well above the requirements demanded by your solver. The overall mesh quality (angles and transitions between elements) should be significantly improved, and those are also very important for convergence.

We are working on releasing R13... I could try smoothing this with the latest build on Monday or Tuesday if you want to send it to me... I could also compare with how 12.1's smoother behaved. Please reference this thread so I can connect the dots back and post the settings and final images.

Josh October 4, 2010 01:34

Hi Simon -

Thanks for the reply.

I successfully matched the edges close to the airfoil. However, when I matched the farfield, it would affect the edges close to the airfoil in a negative way (de-match them, for lack of a better term), almost as if one cannot be matched without negatively affecting the other.

Before smoothing, nearly all of the elements had a quality (determinant) value larger than 0.95, and all of the elements were above 0.9. After smoothing, whether orthogonally or via Laplace, the quality distribution was worse, with some elements possessing negative qualities and others with values less than 0.3. I tried using the field control (or whatever it's called) to only smooth the elements around the airfoil (since the farfield elements are the only ones that decrease in quality after smoothing) to no avail.

If there's a way to smooth only the airfoil region elements, perfect. The farfield and wake are of good quality pre-smoothing.

I'll send the files your way, though I posted them above, as well.

Thanks again!

PSYMN October 4, 2010 21:08

Smoothing...
 
Hey Joshua, (I typed this and send the response before reading what you posted, I think this should sort you out, without necessarily answering your direct questions.)

Things go wrong with these 2D models if you smooth all the curves. It tends to over smooth the curves and gets too far ahead of the surface mesh. However, if you set that curve smoothing to none, it smooths quite nicely...

So, What I do is first get my perimeter as smooth as I can. In your case, I looked at the far field and set the edge spacing and ratios to smoothly transition... You don't need to copy to parallel. Just fix the perimeter and let the smoother handle the internal spacings...

For the edges along the airfoil, the edge parameters list the intial spacing as if the edge were straight... In your case, it listed it as 1.87. However, that edge gets projected to a much longer curve segment and that stretches the final size to 2.75. If you just match edges, it won't look right. SO either use edge splits to make the edge fit the curve better so it gives a more accurate number, and then match edges, or else just set the initial spacing of the adjacent edge interactively until it looks right.

You didn't have a problem with associations, but others might. Before smoothing, make sure your edges are properly associated to curves (not just surface associated and aligned to a curve), verts can be associated to points to prevent their motion, etc.

Once the blocking perimeter (far field and airfoil) looks right, you can convert to unstructured mesh. I prefer to smooth the mesh rather than the premesh because smoothing the premesh messes with the blocking also... I would usually rather leave the blocking alone.

Go to the Smooth Mesh Orthogonally...

I set the number of surface iterations pretty high (50 iterations) once I am confident, but maybe not as high if I am just checking it out.

You will ignore pretty much all the other settings except "Release Orthogonality / Set initial height", select the airfoil part and then uncheck release orthogonality... I set the "Initial Height" to "-1". It interprets this nonsensical number to mean "keep the existing height for each element normal to that part. Make sure that you are not smoothing along curves... I set that to none.

Tada. 30 seconds later it is nice and smooth. Note: by smooth, I mean overall transitions. You may find that individual element quality is sacrificed, but should still be more than hight enough for your solver. Trust me, smooth transitions and adequate element quality is better than high element quality and sudden transitions.

Have fun. I will send my blocking and mesh files.

Simon

Josh October 4, 2010 23:26

Thanks for all the tips, Simon. The mesh looks really great.

Josh October 5, 2010 01:42

Another question:
"Make sure that you are not smoothing along curves... I set that to none. "

What do you mean here? I can't seem to find that option.

Josh October 5, 2010 01:56

Sorry to triple-post...

I tried following your steps above. I don't understand your comment about avoiding smoothing along the curves. This must be what I'm doing wrong because I followed your above steps (to try to recreate your mesh) and ended up with very poor farfield wake elements (quality from 0 - 0.5), unlike your mesh with all element quality > 0.5.

PSYMN October 5, 2010 17:48

Smoothing in 12.1
 
1 Attachment(s)
Sorry, I am using 13.0 where I fixed up the GUI to be readable by non-developers... I have been using it for months, but I guess you don't have access to it for a few more weeks.

In the older 12.x DEZ, it called the smooth along curves "Rebunch Edges"... Set Re-bunch Edges to None so it won't move nodes along curves...

I ended up with min quality of 0.56.

Attachment 4875

Josh October 5, 2010 19:02

Hi Simon -

By default, the rebunch edges option is unselected, yet my wake smoothing caused very poor element quality even with it off. Any ideas?

Josh October 5, 2010 22:36

Strange... If I smooth 50 iterations with your pre-mesh, the overall quality is fine. However, if I alter the pre-mesh (e.g., add more nodes on the suction surface) and adjust the blocking edges to allow for smooth transitions, then globally smooth, I have very poor quality elements in the far wake.

PSYMN October 7, 2010 12:37

I would need to take a look.
 
Please send me the problem examples and I will look at them here when I have time...

Best regards,

Simon

Josh October 25, 2010 22:43

Hi everybody -

I've been struggling with this problem for awhile. I just want to make sure I'm not missing any steps.

I wanted to convert Simon's pre-mesh, shown below, into an unstructured mesh and then smooth it.

http://img41.imageshack.us/img41/703...premesh.th.png

I didn't alter his pre-mesh. I just converted it into an unstructured mesh. Then, I followed his instructions above. I used "Release Orthogonality / Set initial height" in the hexahedral mesh smoother and set the value to -1. I then smoothed the surface and volume for 50 iterations. I changed nothing else. Here is the smoothed mesh:

http://img130.imageshack.us/img130/3...eshjosh.th.png

Notice that the downstream region is warped. Here's a closer look:

http://img688.imageshack.us/img688/5...shjosh2.th.png

Here is what the final smoothed mesh should look like (no warp):

http://img175.imageshack.us/img175/8...shsimon.th.png

Am I missing something or doing something differently? Could it be a problem with the v12.1 smoother?

Thanks!

Josh October 26, 2010 21:33

I think this minor problem is occurring because the O-grid smoothing is "displacing" to the H-grid area. Is there a way to keep the H-grid from being smoothed while smoothing the O-grid?

Josh October 27, 2010 04:48

I've tried freezing the H-grid portion of the mesh using the Lock Elements feature in Edit Mesh > Move Nodes. I selected the problematic wake region and locked those elements. I verified the correct elements were locked by showing locked elements in the display tree. However, when I smoothed using the orthogonal smoother, it seemed to ignore the fact that those elements were locked and it smoothed them, regardless. In fact, it converted them to unlocked elements!

I wouldn't care so much about this problem if the mesh quality changes were minor. Most of the mesh is smoothed very nicely, but the wake region in the center-line near the outlet has high aspect ratios that the smoother tries to fix, creating degenerate elements:

http://img828.imageshack.us/img828/5...lements.th.png

Does locking the elements not work for orthogonal smoothing? If so, what other ways are there to lock the wake elements? My only other guess is that I could turn the wake into its own part and freeze it during smoothing, but there must be a simpler way to avoid this problem.

I'm sorry to keep posting, but I've been working on this mesh for three weeks as of tomorrow. Thanks for any help.


All times are GMT -4. The time now is 14:13.