CFD Online Discussion Forums

CFD Online Discussion Forums (
-   ANSYS Meshing & Geometry (
-   -   Control mesh size in Cartesian (

lotus_blue November 25, 2010 17:59

Control mesh size in Cartesian

Has anyone worked with 'Femur' in Ansys ICEM tutorial? It uses Cartesian meshing. I am having trouble to control the mesh size.

I followed every step in the tutorial and ended up with a much coarser mesh than what the tutorial presents.

Actually I managed to create a very dense mesh somehow, like by lowering the 'max size' in 'Part Mesh Setup', and by increasing 'Nodes' in 'Pre-Mesh Param'. However, sometimes I find the above 2 ways just don't work. It seems to me I can't control mesh size effectively:p

Can anyone explain to me how it works?
Thanks in advance:D.

PSYMN November 27, 2010 12:13

BFCart size control explained...
There are two ways to control the sizes with the BFCart stuff.

1) Set max sizes on surfaces, etc. and let BFCart create the Cartesian background grid needed as a starting point for BFCart. This uses max sizes, etc, but since the Cartesian back ground process is a batch one (not internal to the med.exe where it could use the active memory), it only works off the saved tetin file parameters.

In other words, if you change the parameters, but don't save the geometry file (*.tin), it is still running off your last saved *.tin, and will use your last saved size settings.

2) You can use ICEM CFD Hexa to create the Cartesian background grid. This gives you a method to control the distributions for high aspect ratios or smooth transitions. The pre-mesh gets its sizes from the max sizes set on the geometry, but since the blocking is a separate layer you must go into the blocking tab and "update sizes" to transfer from the geometry to the blocking. Further adjustments can be made by adjusting the edge parameters themselves, but since it must be Cartesian, don't forget to copy to parallel edges.

Then you create the Cartesian file and give that file name to BFCart before you run it...

Again, if you go back to geometry and make changes, but don't update the pre-mesh, or if you update the pre-mesh, but don't create a new Cartesian file, you will not see your changes in the new BFCart mesh.

That should get you going again...

lotus_blue November 29, 2010 18:43

Thanks Simon.

Do I get it right?
(1) Set max sizes and go to "Recalculate Sizes" to change Cartesian mesh distribution according to the max sizes. Remember to "Write Cartesian Grid" and save the new tin file.

(2) If I want to further change the Cartesian grid, I need to go to "Edge Params" to set stuff like "Mesh law", "Spacing", etc. Yet another question, after this, should I go back to "Update sizes" and update again?

Another thing that puzzles me is that although I followed every step in the tutorial, I definitely cannot get such a fine mesh as shown in the tutorial material. I use 12.1.

lotus_blue November 29, 2010 18:47

The upper one is from tutorial.
The one below is mine.
All blocking parameters in the picture are the same.

Thanks Simon.

PSYMN November 30, 2010 15:24

1) Right.

2) No, don't go back and update sizes, that will reset your edge params from the geometry.

As for the pictures, yours looks right (count the elements to see if they match the edge parameter). The top one clearly has more nodes than is shown in the edge params. It is possible that something went wrong during the making of the tutorial (I probably forgot to replace the cartesian mesh) and I just didn't notice.

I think you are on your way...

PSYMN December 1, 2010 14:13

What do you think?
Please help guide development at ANSYS by filling in these surveys

Public ANSYS ICEM CFD Users Survey

This second one is more general (Gambit, TGrid and ANSYS Meshing users welcome)...

CFD Online Users Survey

All times are GMT -4. The time now is 16:48.