CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] Problems with export 2D mesh from ICEM to FLUENT (http://www.cfd-online.com/Forums/ansys-meshing/83958-problems-export-2d-mesh-icem-fluent.html)

newcomer January 17, 2011 03:22

Problems with export 2D mesh from ICEM to FLUENT
 
Hi guys,

I have been trying to export a 2D mesh from ICEM to FLUENT V6 but constantly received the errors message as "FLUENT received fatal signal" and the mesh .msh file could not be opened in the program..

I did not have this problems when using a 3D mesh but this problem always appeared when I want to export a 2D mesh... Would appreciate it very much if you could please advise how I could solve this problem...

Thanks a lot!

PSYMN January 19, 2011 10:32

2D boundaries...
 
In 3D, you need shell elements to form the boundary all around your 3D volume elements. In 2D, you need line elements to form the boundary all around your 2D volume elements.

I have found that this is one of the most common mistakes users make, particularly for 2D Hexa.

Go back and check your mesh... Turn on all your parts and turn on line elements but turn off shells... You should have line elements around the perimeter and between any two shell parts... If not, then that is your problem. The uncovered faces check should also find these.

The fix, if using ICEM CFD Hexa, is to go back and associate edges to curves... When an edge is associated to a curve, line elements form in the part name of the curve... No association, no line elements, no boundaries for fluent...

jsm January 20, 2011 05:15

Hi,

For fluent 2d simulations, the geometry must be in XY plane. Otherwise you will get error. If you made the geometry in XY plane, then check mesh and quality as Simon said

newcomer February 6, 2011 22:51

Hi Simon and JSM,

Thanks for your suggestions! I did miss that step in my previous attempt...

AlbertoP June 16, 2011 09:56

Hi,

I have the same problem... and I get "diagnostics: uncovered" around my airfoil (2d) even if I have LINE elements to form the boundary around it.

Any idea please?
many thanks

Alberto

PSYMN June 18, 2011 20:45

It may be something else, but it is something you need to fix.
 
Uncovered just means that you have elements that do not have a proper boundary around them... Every CFD code requires each fluid volume to have a boundary, so it is a critical problem to fix.

For a 2D mesh, it could be shell elements with no other elements next to them, such as no other shell elements in the same PART or no line elements to form the boundary... Or it could be shell elements next to other shell elements in a different part.

For instance, some users like to create Prism elements in a different part than the original FLUID. The solver will want some sort of boundary between these "different" fluids, so it will complain. If this is your problem, just right click on your FLUID part and Add to Part... In the selection toolbar, you can select all the 2D elements in the model (it is one of the last options on the right side), or you could just select by part and grab the Prism part from the list...

This is my first guess. It may be something else, but it is something. If that is not it, please run the check, create a subset, right click to add a few layers and take a snapshot so we can see what is really going on.

AlbertoP June 25, 2011 16:27

Thank you Simon,

the problem was due to a rotation of the mesh...I have not understood why actually, but I can handle it in another way, that doesn't lead to a such "error".

So thanks anyway...
regards

Alberto

Bollonga December 12, 2012 08:29

Quote:

Originally Posted by PSYMN (Post 312596)

For a 2D mesh, it could be shell elements with no other elements next to them, such as no other shell elements in the same PART or no line elements to form the boundary... Or it could be shell elements next to other shell elements in a different part.

This is exactly my case, I'm doing a 2D hex mesh, pre-mesh is fine, then I conert to unstruct mesh (to use it in Fluent) but when I uncheck shell and check lines, there is just one line in the perimeter. What can I do to get all lines? An also, what is the difference between pre-meshing and meshing?

Thanks a lot!

PSYMN December 12, 2012 10:24

@Bollogna


Quote:

What can I do to get all lines?
In ICEM CFD hexa, line elements are only created when you associate an edge to a curve... Many users remember to do this for curved edges where they want to capture the shape, but forget to do this for straight edges. When using hexa with a 2D geometry, it is very important to associate all the perimeter edges with the perimeter curves or fluent will not have any line elements to apply the boundary conditions to and you will get an error when you load the mesh.


Quote:

An also, what is the difference between pre-meshing and meshing?
Premesh is "structured" in that the data only really needs to store the edge information (topology, shape, distribution) and not the final locations of all the surface and volume nodes. You can still see these using cut planes, but it actually just works out their locations as it displays them to you. This makes the file size much smaller and makes updates faster. It also has inherent information about neighbors, which is why many of the early solvers were limited to this sort of "structured" mesh.

When you convert from pre-meshing to meshing, it actually extracts the node locations and connectivity for all the surface and volume elements and builds an actual unstructured mesh. This is the kind of mesh needed by most modern solvers (such as Fluent or CFX).

Bollonga December 12, 2012 11:24

Thanks for your reply Simon.

Now I've managed to fix that error, but I'm getting a new one when importing my 2d hex mesh into fluent. The error message is the following:

Cell centroid is xc 0.00000 yc 0.00000
WARNING: no face with given nodes. Thread 11, cell 6224
Clearing partially read grid

Error: Build Grid: Aborted due to ritical error.
Error Object: #f

How can I fix that? Thanks a lot in advance!

PSYMN December 12, 2012 14:40

Not sure, it seems to be saying that an element is missing.

Have you run thru all your mesh checks in ICEM CFD before exporting? Go to Edit mesh and check your mesh.

This may be something I could solve if I could look at it, or send it in to ANSYS Tech support.

Bollonga December 12, 2012 15:04

After some searching in the forum I tried the check mesh, and it seems to have fixed many stuff (much of it I haven't understood). But now I'm facing a new error when I try to open the mesh in fluent, it says:

Skipping zone (not referenced by grid)

I've tried to solve it with no result, and I don't find any useful tip in the forum. Your help will be much appreciated.

I'm attaching in this link my icem files in case you wanna have a look. Thanks a lot!

https://dl.dropbox.com/u/6986695/PS_2D_12_12.zip

PSYMN December 12, 2012 15:26

The "skipping zone" shouldn't have stopped you. It is just an informational thing. You probably had a part (aka Zone in Fluent) that had no elements in it. Fluent saw the name, realized it had no elements in it, and skipped it.

It is only a problem if you expected elements in that zone.

I am having a bit of trouble with my winzip. I will re-install and try again later.

Bollonga December 12, 2012 15:30

Here you have it in winrar format:

https://dl.dropbox.com/u/6986695/PS_12_12.rar

diamondx December 12, 2012 16:29

bollongo , i'm off for today, here is something you can do, there are curve that represent your fine plate. name those curves "wall" and do the associations again. there are no element on the fine plate even if you see a mesh there. LINE ELEMENTS has to be associated with the WALL CURVES you created. also because of your very dense mesh you have negative volume. give less element so you can track this error, or re-do the blocking, always starts by some few elements see if everything goes good then refine and apply the bunching law...

PSYMN December 12, 2012 16:30

1 Attachment(s)
I found a few issues.

First, I noticed that you had the fluid part set to internal wall instead of fluid. You also had a part for internal wall, which you didn't need. (i just un-associated all those edges).

Then I saw that you had some strange index stuff going on...

Are you familiar with the index control in hexa? Take a look at "I" between 2 and 4... There are some strangely squished indices. For this model you really only need 5 indices in the I direction, you have 2 extra. To see what I am looking at, try the following steps.

Open index control, reduce "I" down to 0:1. This should just show the inlet edge. Then increase the Min index so the range for I is "2:2". This should show the split ahead of your plate... It should show the whole split, but just shows the middle section of it. Then increase again, you see the left side. increase again, you see both sides, but not the middle... Increase again, you see the top and right side... Increase again, you see the outlet... This shows me that you didn't use the proper top down approach. You didn't create your split properly and you have "implied splits".

To clean this up...

1) Reset index control
2) Split Block => Extend Split => All Edges (you will see the extra splits revealed)
3) Merge Vertices (turn on option to "propagate merge") select a pair of verts that need to be merged away...
4) Confirm "delete station" (this removes the unnecessary indices, you should see the I index Max decrease to "5")
5) fix any lost projections... (this is why you still had an uncovered face, the tiny edge may not have been properly associated).

6) New premesh, new unstructured mesh, check mesh, output (2D), etc.

For check mesh (all defaults), you should only get "single edges" (which are fine), but no other complaints.

I was able to read this final mesh into Fluent without any problems...

I will attach my "fixed" blocking file and fbc file (along with a tin and prj file), you can easily regenerate the uns and msh from that...

Best regards,

diamondx December 12, 2012 16:52

balogna.zip :D funny how you could remember the name...

PSYMN December 12, 2012 16:57

Quote:

Originally Posted by diamondx (Post 397236)
balogna.zip :D funny how you could remember the name...

oops... I thought I had recalled it correctly until after I uploaded it... :eek:

Figured he would forgive as long as his mesh is fixed ;)

Bollonga December 12, 2012 17:37

Quote:

Originally Posted by PSYMN (Post 397226)
Are you familiar with the index control in hexa? Take a look at "I" between 2 and 4... There are some strangely squished indices. For this model you really only need 5 indices in the I direction, you have 2 extra. To see what I am looking at, try the following steps.

Well, I'm a newbie in Icem but yes, I've tried to use index control to just split the blocks I want. I'm sure I must have messed up with that so it resulted in some extra splits.

I'll try your steps 1) to 6) to get more used to Icem.

Quote:

Originally Posted by PSYMN (Post 397226)
oops... I thought I had recalled it correctly until after I uploaded it... :eek:

Figured he would forgive as long as his mesh is fixed ;)

Absolutely no worries, in fact Bollonga is not my real name!

Thanks a lot for your help! I'll let you know if I can follow all the steps correctly.

Bollonga December 12, 2012 18:03

All steps went fine! I managed to get my mesh right! by the way, where can I learn all this checking options? Is there any good advanced tutorial?

Thanks a lot again!


All times are GMT -4. The time now is 02:06.