CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   Error When Starting ICEM CFD in Ubuntu (http://www.cfd-online.com/Forums/ansys-meshing/89147-error-when-starting-icem-cfd-ubuntu.html)

cgriffin33 June 6, 2011 10:00

Error When Starting ICEM CFD in Ubuntu
 
I have found a great thread on the workarounds needed to install Ansys Workbench in Ubuntu, but I do not use the workbench and only use Fluent and ICEMCFD as standalones. It is simple enough to install both products, the only error I get is during install of ICEMCFD:

ANSYS installation: Fri Jun 3 16:34:14 2011
Revision: 13.0

[: 340: /ansys_inc/v130/aisol/dll/linx64/libans.common.clrhostmonou.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/libans.common.controlsu.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/libans.graphics.controlsu.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/libans.graphics.graphutilityu.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/*ud.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/*ud.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/*ud.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/*ud.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/*ud.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/*ud.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/*ud.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/*ud.so: unexpected operator
[: 340: /ansys_inc/v130/aisol/dll/linx64/*ud.so: unexpected operator

The real problem occurs when I start ICEM (FLUENT works fine). It will appear to be opening and I will even see the GUI for ICEM, but a dialog box opens with the following error:

segmentation violation - exiting after doing an emergency save

And the only option is to click OK, which shuts down ICEM. The following is printed to my terminal window while ICEM is loading:

ICEM_ACN is /usr/ansys_inc/v130/icemcfd/linux64_amd
ANSYSLIC_DIR is set to /usr/ansys_inc/shared_files/licensing
args
Missing font family helvetica
Window information: depth = 24
class = 4
visual depth = 24 class = 4
can't load font screen14, using variable
Signal 11 caught!
segmentation violation - exiting after doing an emergency save
Exiting...

Any help on what may be a solution to fix this would be greatly appreciated. So far, ICEM is the only thing keeping me attached to my Windows machine.

PSYMN June 7, 2011 10:06

Ubuntu is not officially supported...
 
Ubuntu Linux is not officially supported. This means we don't test on this platform and don't fix issues specific to this platform. I have heard of people making it work, but not officially (and I don't recall what they did)...

We support RedHat and Suse officially.

You might find other threads on CFD-Online where this was already discussed and may even fine a solution to make it work.

Best regards,

Simon

cgriffin33 June 7, 2011 13:12

I know ubuntu is not supported by ansys, that's why I posted in the forum and didn't bother with ansys support. I am just hoping someone had a similar situation and found a solution.

eysteinn June 16, 2011 09:04

Did you manage to fix this.
I have two computers with ubuntu 11.04.
Icem works fine on the one that I updated from 10.10 but not on a newly installed one and I'm not sure what I did with the other one that made it work :confused:

Best regards,
Eysteinn

eysteinn June 17, 2011 08:43

Well seems to work now after a restart. Not sure what fixed it.
Possibly installing libmotif4
and then
sudo ln -s /usr/lib/libXm.so.4 /usr/lib/libXm.so.3


and restarting.

brahim June 22, 2011 06:27

Hi all
I have the same problem as described by cgriffin33.
It seems that ICEM is running when I change the display options from "native" to "X11". The problem then is that the graphics are very slow....
Any help or hints are very welcome!

Best Regards - Brahim.

bigphil July 25, 2011 12:20

Quote:

Originally Posted by cgriffin33 (Post 310693)
ICEM_ACN is /usr/ansys_inc/v130/icemcfd/linux64_amd
ANSYSLIC_DIR is set to /usr/ansys_inc/shared_files/licensing
args
Missing font family helvetica
Window information: depth = 24
class = 4
visual depth = 24 class = 4
can't load font screen14, using variable
Signal 11 caught!
segmentation violation - exiting after doing an emergency save
Exiting...

Hi,

I also received the above error on my fresh install of ICEM on my OpenSUSE 11.4 (virtual machine).
I turned off 3D Graphics in the display settings of the virtual machine (virtualBox) and now it opens fine.

Hope it helps somebody,
Philip

cgriffin33 July 27, 2011 16:22

Just wanted to let everyone know I was able to get ICEM running in ubuntu 10.04. I did as eysteinn recommended and installed libmotif3 and I also had to install the cshell, just bash would not work. After that it works fine. Thanks for the help.

Jonathan July 28, 2011 08:17

solved
 
Hi,

Just thought I would share the fix for this.

I ran a clean install of Ubuntu 11.04 and found I could only run ICEM in X11, where as mentioned above, the display was not great + slow. I got the segmentation error and helvetica font msg when running in the NATIVE graphics environment.

Anyway, our linux administrator isolated the problem - it seems the fix is to install the xfonts-75dpi and xfonts-100dpi libraries which are not included in the 11.04 distro, but seem to be present if you upgrade from one of the earlier distributions (10.10 etc).

Anyway, all is working great / as it should, so hope this helps any other ubuntu users ...

cheers
jonathan

ginggs July 28, 2011 08:31

Quote:

Originally Posted by cgriffin33 (Post 310693)
ICEM_ACN is /usr/ansys_inc/v130/icemcfd/linux64_amd
ANSYSLIC_DIR is set to /usr/ansys_inc/shared_files/licensing
args
Missing font family helvetica
Window information: depth = 24
class = 4
visual depth = 24 class = 4
can't load font screen14, using variable
Signal 11 caught!
segmentation violation - exiting after doing an emergency save
Exiting...

Icemcfd crashes because of the missing font. :eek:

To fix:
Code:

sudo apt-get install xfonts-75dpi xfonts-100dpi
Then restart X or reboot your machine in order for the changes to take effect.

cgriffin33 July 28, 2011 09:44

Thanks for these fixes.

Chong070940103 July 25, 2014 17:49

Same problem. ginggs' answer works for my case. Thanks!

Sören Sander January 23, 2015 04:59

Hi,

I am getting the same problem, but installing xfonts does not solve the problem.
I am using a clean installation of ubuntu 14.04, though i tried with 12.04, too, and got the same issue. Am I missing any other dependencies?

Best regards

cgriffin33 January 23, 2015 12:26

install libmotif3 and libmotif4, this should help.

Sören Sander February 13, 2015 04:10

Sorry for the late reply. I tried to follow all above mentioned fixes without any result. The error still occurs.

cgriffin33 February 20, 2015 10:21

Did you install and use cshell, the default bash doesn't work for me on ubuntu.

mengql12 February 20, 2015 23:31

helpful
 
I installed libmotif3,libmotif4,xfonts-75dpi and xfonts-100dpi,problem solved.

ansys13 on ubuntu14.04

Sören Sander March 31, 2015 04:40

Thanks very much for your help again. I finally found a solution, although I am not sure if all parts of my solution are necessary:

Code:

apt-get install xfs xfstt
apt-get install t1-xfree86-nonfree ttf-xfree86-nonfree ttf-xfree86-nonfree-syriac xfonts-75dpi xfonts-100dpi
xset +fp /usr/share/fonts/X11/75dpi/
xset +fp /usr/share/fonts/X11/100dpi/

Best regards


All times are GMT -4. The time now is 12:46.