CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   [ICEM] o'ring not taken into account in the mesh in 3D error (http://www.cfd-online.com/Forums/ansys-meshing/89336-oring-not-taken-into-account-mesh-3d-error.html)

eleo June 9, 2011 19:09

o'ring not taken into account in the mesh in 3D error
 
4 Attachment(s)
Hello, I have a problem using the o'ring in 3D with ANSYS ICEM.

It is working ok in 2D (a circle): The o'ring changes the shape of the mesh.

In 3D, once I have meshed a cylinder, I then create the o'ring, but the o'ring is not merged in the mesh. Can you indicate me why? Thank you in advance.

jeevankumarb June 9, 2011 23:28

It will be difficult to know what is the problem in the mesh without images. if you can upload some images or the tetin and blockinf files then it will be easy to understand your problem.

Regards
jeevan

eleo June 13, 2011 14:07

Pb: mesh does not take into account the o-ring in 3D-Ansys ICEM mesh
 
4 Attachment(s)
Hello, I have a problem using the o'ring in 3D with ANSYS ICEM.

It is working ok in 2D (a circle): The o'ring changes the shape of the mesh.

In 3D, once I have meshed a cylinder, I then create the o'ring, but the o'ring is not merged in the mesh. Can you indicate me why? Thank you in advance.

Please find attached the files for respectively the 2D case and the 3D case :


Attachment 8024

Attachment 8025

Attachment 8026

Attachment 8027

ousegui June 13, 2011 14:57

1 Attachment(s)
try with this block file

Quote:

Originally Posted by eleo (Post 311817)
Hello, I have a problem using the o'ring in 3D with ANSYS ICEM.

It is working ok in 2D (a circle): The o'ring changes the shape of the mesh.

In 3D, once I have meshed a cylinder, I then create the o'ring, but the o'ring is not merged in the mesh. Can you indicate me why? Thank you in advance.

Please find attached the files for respectively the 2D case and the 3D case :


Attachment 8024

Attachment 8025

Attachment 8026

Attachment 8027


eleo June 13, 2011 15:37

Blocking
 
Thank you Ousegui, the new blocking is working ok. Could you indicate me why my blocking was wrong ? Thanks.
Eleo

ousegui June 13, 2011 15:48

I think the problem that you create three block (for bottom top and lateral surfaces) and after you made the o grid.
The correct way is to create one block for the all geometrie assciate the edges surounding the discs to the cercles, and creat o grid by selecting the block and the faces of discs and it will work
good luck



Quote:

Originally Posted by eleo (Post 311828)
Thank you Ousegui, the new blocking is working ok. Could you indicate me why my blocking was wrong ? Thanks.
Eleo


eleo June 14, 2011 16:10

Problem with the blocking
 
Hello
1) From the geometry file cyl1 attached previously, I click on blocking>1st icon
Part: live
Create block
Initialize blocks 3D Bounding Box – Project vertice is ticked –Apply
One box is created-
2) Then, I click on Blockink and 2nd icon
Split Block + 2nd icon
Select block I click on the 1st icon –go on the geometry and type "v" on the keyboard- the block appears
Then select face and 1st icon- I select the inlet and the outlet-
And Apply-
I don’t manage to get the same blocking than you ie which remains planar at both side when you look at it on a side view.
Do you use my geometry to create your blocking ? Do I have to change anything in the geometry before creating the block or is there anything wrong with the way of moving the vertices ...?
Thanks for your help.
Eleo.


ousegui June 14, 2011 19:11

honestly I don't know what's wrong with your approach, for me I use your geo file and I did the block and O grid, it's a basic case, just do some cases in tutorials and you will achieve your example easily
Regards

Quote:

Originally Posted by eleo (Post 312021)
Hello
1) From the geometry file cyl1 attached previously, I click on blocking>1st icon
Part: live
Create block
Initialize blocks 3D Bounding Box – Project vertice is ticked –Apply
One box is created-
2) Then, I click on Blockink and 2nd icon
Split Block + 2nd icon
Select block I click on the 1st icon –go on the geometry and type "v" on the keyboard- the block appears
Then select face and 1st icon- I select the inlet and the outlet-
And Apply-
I don’t manage to get the same blocking than you ie which remains planar at both side when you look at it on a side view.
Do you use my geometry to create your blocking ? Do I have to change anything in the geometry before creating the block or is there anything wrong with the way of moving the vertices ...?
Thanks for your help.
Eleo.


eleo June 14, 2011 19:46

Ansys ICEM Version
 
Could you please let me know which version you are using ? I am using 11.0. Do you think my software could be corrupted. Thanks.


All times are GMT -4. The time now is 12:20.