CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS Meshing & Geometry (http://www.cfd-online.com/Forums/ansys-meshing/)
-   -   Please help me.. Out of memory İn gambit (http://www.cfd-online.com/Forums/ansys-meshing/93267-please-help-me-out-memory-n-gambit.html)

emreg October 10, 2011 12:19

Please help me.. Out of memory İn gambit
 
i have these system specifications:
- i7 2600 intel 64x
- 8 gb ram
- 4 processors

I am trying to mesh a volume which has nearly 4-5 million cell. However suddenly i get a warning message "out of memory" in GAMBIT

But on the another computer (2 gb ram, dual core) i can manage 4.5 million meshes in the same conditions.

Where is the problem?

Thanks

VincentD October 10, 2011 15:05

Any chance your running a different OS (Operating system)?

If it's 32bit, then your maximum array is limited to 2^31 bits or roughly 2Gb.

Otherwise make sure your compiler setting are the same.

Heh, 2 million grid cells, gotta love Gambit for it's inefficient use of computer memory ^^ (and friendly user interface!)

emreg October 10, 2011 16:39

thanks
 
thanks for ur reply.
Probably i hav got it. While u are meshin for ex. 5 million mesh at once, Gambit doesnt allow us to be successed.
- We have to mesh the volumes by one by.
- or stitch in fluent.
- or less refined mesh. (not desired)

Now i hav 10 million mesh :D

-mAx- October 11, 2011 01:23

Quote:

Originally Posted by emreg (Post 327380)
Probably i hav got it. While u are meshin for ex. 5 million mesh at once, Gambit doesnt allow us to be successed.
- We have to mesh the volumes by one by.

Not probably, but for sure! ;)
The problem, will be when you will import your mesh in your solver, or even export your mesh (if you are on 32bit-OS).
I also have 8GB Ram but on XP-32bit. (so only 3.5GB Ram)
My solution was to create a 64bit-linux partition (openSuse, fedora, or whatever... but free), and installing Gambit 64bit for linux, and also 64-bit version of solver.
And it works perfectly

sumit singh October 11, 2011 05:09

while using solver say ansys or fluent in it try parallel computing otherwise calculations will stop after sometime or may be does'nt even start!

-mAx- October 11, 2011 05:17

That's what I meant.
which OS?

sumit singh October 11, 2011 05:51

yeah i got your point max but for person working on 32 bit and windows with limited RAM parallel computing can simply solve the problem. Whatsoever be the OS that wont make any difference! i am working almost same mesh mesh count on 3gb ram 32 bit window just with parallel computing!
definitely if give me some more options,i will be thankful :)

-mAx- October 11, 2011 07:09

what kind of parallel computing?
Shared memory or distributed?

emreg October 11, 2011 16:07

pufff. i couldnt start analysis
 
After exporting mesh file consisting of 13million cells, on a computer (8 gb ram, 4 processor) i couldnt start calculating in fluent ( it is definitely very slow). It was so slow that i had to cancel it.

Do you have any idea about that?

-mAx- October 12, 2011 02:04

Generally you need 1GB Ram for 1 million cells mesh.
That's why it's slow.
>>solutions:
*Reduce Number of cells
*increase Ram capacity
*parallel computation (distributed memory)

subashkumar47 October 19, 2011 01:09

sir ,

i while i start gambit 2.0.4 , i could not get the window displayed , it gives me following command , in my DOS window .

C:\Documents~1\SUBASH\C:\Fluent.Inc\ntbin\ntx86\\g ambit.exe
ERROR:IDENTIFIER "default_id" CURRENTLY OPEN.
usage:C:\Fluent.Inc\gambit2.0.4\ntx86\\gambit.exe.
-def<aultsfile>file
-dev<ice>X11:XWIN:OPEN<GL>:GL:XGL:SBX:STAR<BASE>
-doc<umentation>
-geom<entry>WIDTHXHEIGHT+X+Y
-help
-id name
-inp<ut file>file<implies batch run and no gui>
-init<file>file<a journal file to run at startup of gui mode>
-new:-old
-proe proe_command
-res<tore journal>file<implies batch run and no gui>


could you please tell me what happened ,

should i reinstall gambit & fluent

but my fluent is still functional


please do mail me at subashkumar47@gmail.com

thanks in advance.

-mAx- October 19, 2011 01:14

Sounds you had earlier a crash with a session called default_id.
Look for *.lok file and delete it.
Then restart


All times are GMT -4. The time now is 02:32.