CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > ANSYS Meshing & Geometry

[ICEM] Creating Block using Extrude Faces

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 6, 2012, 16:31
Default Creating Block using Extrude Faces
  #1
New Member
 
Burak Bayrak
Join Date: Jul 2010
Location: Istanbul
Posts: 8
Rep Power: 7
alienplanet is on a distinguished road
Hi all,
Nowadays , i m trying to mesh pipe line. I'm using two o-grid, and all o-grids edges must be linked main edge associated to curve or surface.
blocking.jpg
pipe1stblockusinglinkededges.jpg
I try to use the extrude faces with using extrude along the curve. thats the problems begun. When i using the option copy projection, all the main edges associated to master block surface.
Although there was a some problems i faced problem link edges process, o-grid edges linked to main edges.
usingextrusinalongthecurvewithcopyprojection.jpg
linkededgeerrors.jpg
When i put the option copy projection off, of course there was not any linked edges process.
notusingtheoptioncopyprojection.jpg
do you have any suggestions how to solve this problem?
using copy projection, main edges fail to associate to surface, not using this option i faced o-grid edges not associated. I think to write a script algorithm to do process the "link edges" but clearly i dont have any idea of how vertices numbering.

Last edited by alienplanet; January 7, 2012 at 18:40. Reason: uploading clear pictures
alienplanet is offline   Reply With Quote

Old   January 7, 2012, 18:42
Default
  #2
New Member
 
Burak Bayrak
Join Date: Jul 2010
Location: Istanbul
Posts: 8
Rep Power: 7
alienplanet is on a distinguished road
topic is updated
alienplanet is offline   Reply With Quote

Old   January 8, 2012, 17:30
Default
  #3
Senior Member
 
PSYMN's Avatar
 
Simon Pereira
Join Date: Mar 2009
Location: Ann Arbor, MI
Posts: 2,662
Blog Entries: 1
Rep Power: 36
PSYMN has a spectacular aura aboutPSYMN has a spectacular aura about
Yea, the associations are off. You can update the associations. Or you can just set them up manually... One issue you will have either way is that your edges don't line up to your curves. You may want to adjust the parameters of your extrude so that you have edges lined up with the curves. You may also want to run ISO curves around the bend so you can project your edges to those also...

A side note... Extrude is not the fastest way to handle this model. I would start with a top down blocking of the overall U shape (using a CGrid), then I would delete down to the correct topology. Then I would run an ogrid thru the final blocking. This is actually done as part of the basic training. The U pipe is done during the lecture, the corresponding tutorial is the sphere cube, which is similar.
__________________
-----------------------------------------
Please help guide development at ANSYS by filling in these surveys

Public ANSYS ICEM CFD Users Survey

This second one is more general (Gambit, TGrid and ANSYS Meshing users welcome)...

CFD Online Users Survey
PSYMN is offline   Reply With Quote

Old   January 14, 2012, 03:29
Default
  #4
New Member
 
Burak Bayrak
Join Date: Jul 2010
Location: Istanbul
Posts: 8
Rep Power: 7
alienplanet is on a distinguished road
Hi Simon,
Ty for you reply, actually this problem ( link edge problem in the o-grid edges) occurs while i m using " copy projection " option off. Because there is no surface or curves to be associated and also first main edges. because of the that problem ( problem that association of link edges with or wtihout using copy projection ) i guess this must be solved by writing a script file.

In addition to, for u pipes your advice is quite good for me. I'll try to generate c o-grid meshes. But, further process (link edges of the o-grid edges) doesn't help me. I need to link ogrid edges manually.
alienplanet is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
No layers in a small gap bobburnquist OpenFOAM Native Meshers: snappyHexMesh and Others 2 November 25, 2012 09:54
snappyHexMesh won't work - zeros everywhere! sc298 OpenFOAM Native Meshers: snappyHexMesh and Others 2 March 27, 2011 21:11
Cannot get the right mesh from gmsh JinBiao Open Source Meshers: Gmsh, Netgen, CGNS, ... 2 August 31, 2010 04:51
Icem Mesh to Foam jphandrigan OpenFOAM Mesh Utilities 4 March 9, 2010 03:58
external flow with snappyHexMesh chelvistero OpenFOAM 11 January 15, 2010 20:43


All times are GMT -4. The time now is 05:42.