CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS (http://www.cfd-online.com/Forums/ansys/)
-   -   Unexpected error by starting Ansys Workbench (http://www.cfd-online.com/Forums/ansys/75378-unexpected-error-starting-ansys-workbench.html)

alexmeier April 23, 2010 07:06

Unexpected error by starting Ansys Workbench
 
Hi there,

when I try to start Workbench I get the error message:

Unecspected error: Der Typeninitialisierer für "Ans.core.Units.UnitsManager" hat eine ausnahme verursacht.

If I display error details this is what I get:

System.Runtime.InteropServices.SEHException: Eine externe Komponente hat eine Ausnahme ausgelöst.
bei Ans.ComponentSystem.Interop.MiniCom.AnsCoCreateIns tance(Guid rclsid, Object pUnkOuter, UInt32 dwClsContext, Guid riid, IntPtr& ppv)
bei Ans.ComponentSystem.Interop.MiniCom.AnsCoCreateIns tance(Type classType, IntPtr aggr)
bei Ans.Units.CUEUnitsClass.CreateObject(IntPtr aggr)
bei Ans.Core.Units.UnitsManager..cctor()
--- System.TypeInitializationException: Der Typeninitialisierer für "Ans.Core.Units.UnitsManager" hat eine Ausnahme verursacht.
bei Ans.Core.Units.UnitsManager.AreValuesVirtuallyEqua l(Double a, Double b)
bei Ans.Core.DataSpecs.RealSpec`1.AreValuesEqual(Objec t a, Object b)
bei Ans.Core.DataSpecs.NumberSpec`1.IsValueUndefined(O bject value)
bei Ans.Core.DataSpecs.DataSpec.get_HasDefault()
bei Ans.Core.DataSpecs.DataSpec.ValidatePropertySettin gs()
bei Ans.Core.DataSpecs.SpecAttribute.SetSpecProperties (DataSpec spec)
bei Ans.Core.DataSpecs.SpecAttribute.CreateDataSpec(Ty pe type)
bei Ans.Core.DataSpecs.SpecFactory.BuildMemberSpec(Typ eSpec typeSpec, MemberData memberData)
bei Ans.Core.DataSpecs.SpecFactory.BuildTypeSpec(Type type, TypeSpec typeSpec)
bei Ans.Core.DataSpecs.TypeSpecAttribute.CreateDataSpe c(Type type)
bei Ans.Core.DataSpecs.SpecFactory.CreateTypeSpec(Type type, Boolean isCached)
bei Ans.Core.DataModel.DataObjects.DataObjectContainer .AddEntityTypesFromAssembly(Assembly assembly)
bei Ans.Core.DataModel.DataObjects.DataObjectContainer ..ctor(Assembly assembly, String typeString)
bei Ans.Core.DataModel.DataObjects.DataObjectContainer ..ctor(String typeString)
bei Ans.ProjectSchematic.Data.SchematicContainer..ctor ()
bei Ans.ProjectSchematic.Commands.CreateSchematicComma nd.Execute(CommandContext context)
bei Ans.Core.Commands.Concurrency.CommandWorkUnit.exec uteInContext(CommandContext subContext, IExecutionEngineCallback tracer)
bei Ans.Core.Commands.Concurrency.BaseWorkUnit.doExecu te(IExecutionEngineCallback executionEngine, CommandContext subContext)
bei Ans.Core.Commands.Concurrency.BaseWorkUnit.Execute (IExecutionEngineCallback executionEngine, Boolean dontCatchExceptions)
--- Ans.Core.Commands.CommandFailedException: Der Typeninitialisierer für "Ans.Core.Units.UnitsManager" hat eine Ausnahme verursacht.
Command: CreateSchematic()
bei Ans.Core.Commands.CommandAsyncResult.RethrowFailur eException(Exception e)
bei Ans.Core.Commands.CommandAsyncResult.Wait(Int32 milliSecondsTimeout, Boolean exitContext)
bei Ans.Core.DataModel.ProjectSystem.Project.InvokePro jectInitializationCommands(ICommandContext commandContext)
bei Ans.Core.DataModel.ProjectSystem.ResetCommand.Exec ute(CommandContext context)
bei Ans.Core.Commands.Concurrency.CommandWorkUnit.exec uteInContext(CommandContext subContext, IExecutionEngineCallback tracer)
bei Ans.Core.Commands.Concurrency.BaseWorkUnit.doExecu te(IExecutionEngineCallback executionEngine, CommandContext subContext)
bei Ans.Core.Commands.Concurrency.BaseWorkUnit.Execute (IExecutionEngineCallback executionEngine, Boolean dontCatchExceptions)
--- Ans.Core.Commands.CommandFailedException: Der Typeninitialisierer für "Ans.Core.Units.UnitsManager" hat eine Ausnahme verursacht.
Command: Reset()
bei Ans.Core.Commands.CommandAsyncResult.RethrowFailur eException(Exception e)
bei Ans.Core.Commands.CommandAsyncResult.Wait(Int32 milliSecondsTimeout, Boolean exitContext)
bei Ans.Core.DataModel.ProjectSystem.ResetCommand.Invo keAndWait(ICommandContext context)
bei Ans.Program.Runtime.Initialize(RuntimeSettings settings)

Has anyone an Idea how to solve this Problem?

bernd.ruessel April 27, 2010 10:42

Same Problem Here
 
I have the same problem here.

Windows 7 64 bit with Ansys WB 64bit.

alexmeier May 5, 2010 10:30

I have solved the problem
 
hi bernd.ruessel

With help from ANSYS a was able to solve my Problem.

The error message shown in your screenshot: Unexpected error: The type initializer for 'Ans.Core.Units.UnitsManager' threw an exception. ... is indicative of a particular type of installation error, which usually only occurs on Windows Vista, and possibly Windows 7. If it is Windows Vista or Windows 7, is there any chance that you installed the software without disabling user access control (UAC) or without running the installation as an administrator? In particular, if you failed and tried again with UAC disabled, it's possible that there are some environment variables which may have been left over from the previous failed installation. What sometimes happens is that without UAC disabled, the software installs in 'C:\ANSYS Inc' instead of 'C:\ANSYS Program Files\Inc' and certain environment variables are set. If the installation is repeated with UAC disabled (or as an administrator), the software installs in 'C:\ANSYS Program Files\Inc', but the environment variables are not updated. I would recommend checking the following: - Check where the software has been installed. Usually 'C:\Program Files\ANSYS Inc\v121'. - Go to 'Control Panel > System > Advanced > Environment Variables' - Look for the environment variable AWP_ROOT121. Make sure it is set to the location where the software is installed. It should normally be 'C:\Program Files\ANSYS Inc\v121', but it may be incorrect. If it is incorrect, change the value of this environment variable to the correct location. - Try running Workbench again. Hopefully that will fix the problem.

I hope this will solve your problem to.

bigB June 2, 2010 09:44

Still the same Problem
 
Workbench still not working!
I have also a Notebook with:
Windows 7, 64 bit, and Ansys 12.1 WB 64bit not working.
Have someone an other suggestion to solve my Problem?

alexmeier June 2, 2010 10:46

Can you specify what is not working?
did you change all the Environment Variables mentioned?

bigB June 2, 2010 16:23

I don´t find it
 
I don`t find: Control Panel > System > Advanced > Environment Variables' - Look for the environment variable AWP_ROOT121.
Is it under Ansys Inc?
Could you please take Screenshots?
Thank´s for help.
My Notebook is an i7. Could this be the problem?

alexmeier June 3, 2010 02:38

Here you are
I hope this will help you.

http://www.pictureupload.de/original...7_picture1.jpg
http://www.pictureupload.de/original...2_picture2.jpg
http://www.pictureupload.de/original...3_picture3.jpg

bigB June 3, 2010 03:18

Thank you
 
I can start the Workbench.
Thanks!!!

Reto July 6, 2010 16:14

@alexmeier

Thanks for your suggestion! It's really work. :)

amirsyafiq March 2, 2012 04:14

i cant open the image...helppp..i had a same problem too..too bad

amirsyafiq March 3, 2012 12:22

i cant see the image ...plss help me....... :(

smwaerospace January 16, 2014 13:37

Ans.Core.Units.UnitsManager error
 
2 Attachment(s)
Please anyone tell me how to fix this problem

hellovers60 February 20, 2014 02:00

Problem in Enteting Udf in ANSYS
 
I found from net, for entering the udf in ansys, open it with using visual basic command prompt..
Its working fine in fluent but the same thing is not working in ANSYS 14.5..
Its gives me error named "C:\ANSYS" is not recognized as an internal or external command...
I install it in C:\program file\ANSYS Inc as well C:\Ansys Inc.... Still i ma not able to open it with using command line.... :(
Same method is working in opening fluent... and m able to insert A udf

My ANSYS directory wich i insert in command
C:\ANSYS Inc\v145\fluent\fluent14.5.0\launcher\win64\launch er1

Pls help me to shortout this problem....
Thanks.....

Mlspts January 30, 2015 06:49

Hello,

Excuse me, i'm bad in english.

First, I'd like to thank you all for your help.

I had this problem, I have checked the environment variables, but they were correct.

I removed ansys and the antivirus software. I removed also all the keys of ansys and the antivirus in the register (regedit) ( !!! be careful when you manipulate the register !!!)
I restarted the computer and reinstalled ansys. Now I can run Ansys workbench.

I hope this could help someone.

Thank you !!

vijay755 April 7, 2016 05:53

Bug in ANSYS WORKBENCH!!
 
Hi All,
I am getting a strange problem in ANSYS Workbench.
an anyone sort this?

When I start Workbench from windows start menu, ANSYS page opens and then only the getting started page opens but the Workbench do not open.

I tried a lot to fix this error but could not succeed.

Can any one help me with this?

vijaykadli@gmail.com


All times are GMT -4. The time now is 06:01.