CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   ANSYS (http://www.cfd-online.com/Forums/ansys/)
-   -   Two way FSI in ANSYS 13(CFX + Transient Structural) (http://www.cfd-online.com/Forums/ansys/87867-two-way-fsi-ansys-13-cfx-transient-structural.html)

k_k May 1, 2011 07:34

Two way FSI in ANSYS 13(CFX + Transient Structural)
 
Hi, Please help me, I am trying to run 2 way FSI for a membrane pump. My previous FSI runs on simpler geometries gave good results.

I come across the following errors and warning,

1. Material number 2 (used by element 7393 ) should normally have at least
one MP or one TB type command associated with it. Output of energy by
material may not be available.

2. Element shape checking is currently inactive. Issue SHPP,ON or
SHPP,WARN to reactivate, if desired.

3. ANSYS results must be written into the database for Multifield
analysis. The /CONFIG,NOELDB,1 command is ignored.

4. This load step will be a static (steady-state) step. (Although my load is transient)

5. ANSYS and CFX use different Units

Have any one of you come across these warnings? If Yes, do u knw, how to fix them?

Please reply

Many Thanks

solomedic May 12, 2011 03:51

help regarding fsi
 
hello, I am doing fsi of agard445.6 wing because it is used as benchmark in aeroelastic analysis,but I dont know where to find geometry of that wing, please help me on that.

stumpy May 26, 2011 15:43

Those are all just warnings. None of them look like a problem.

Atze June 7, 2011 05:03

Hi,

@ K_K : can i run a 2 way fsi in ansys13 using fluent instead of cfx? have you some tutorial or advice?

thank you very much

lingdeer October 27, 2011 10:53

I have the same problem....but it just forces my FSI simulation to stop
(no error but same warnings....)
It works for the steady case though (warnings are ignored)
but transient it didnt work....

mvoss November 4, 2011 04:56

hey,

i am also working on smth. very similar. I can confirm that the warnings mentioned above are not crucial for the FSI. Is your run really stopping or is it crashing ? What is the latest error?

neewbie

lingdeer November 6, 2011 17:55

I tried many times and the same error showed up:



CFSImod--Transient (A5)

. . . . . . . . . . . . . . . . . . . . . . .

MULTI FIELD ANALYSIS STEP OPTIONS

TIME AT BEGINNING OF ANALYSIS. . . . . . . 0.0000
TIME AT END OF ANALYSIS. . . . . . . . . . 50.000
TIME STEP NUMBER. . . . . . . . . . . . . . . 1
STAGGER ITERATION NUMBER. . . . . . . . . . . 1. CUM MF ITER = 1

FIELD INFORMATION FOR MULTIFIELD ANALYSIS

CURRENT FIELD NAME FOR ANALYSIS. . . . . ANSYS
TIME AT BEGINNING OF CURRENT ANALYSIS. . . 0.0000
TIME AT END OF CURRENT ANALYSIS. . . . . . 0.10000E-01

THIRD SYNCHRONIZATION POINT OF MASTER CODE:
SERVE SLAVES THE TIME STEP CONTROL INFORMATION TO START A SOLVE

FOURTH SYNCHRONIZATION POINT OF MASTER CODE:
LOAD TRANSFER AT THE BEGINNING OF SOLUTION

FORCE SUM FOR FIELD 1 ACROSS INTERFACE 1

RECEIVING FORCE FX SUM = 0.73380E-05
RECEIVING FORCE FY SUM =-0.15485E-03
RECEIVING FORCE FZ SUM =-0.30712E-02


*** WARNING *** CP = 12.909 TIME= 16:47:42
Element shape checking is currently inactive. Issue SHPP,ON or
SHPP,WARN to reactivate, if desired.

*** NOTE *** CP = 13.018 TIME= 16:47:42
The model data was checked and warning messages were found.
Please review output or errors file (
/..../FluidFSI_006.ansys/ANSYS.err ) for these
warning messages.

*** SELECTION OF ELEMENT TECHNOLOGIES FOR APPLICABLE ELEMENTS ***
--- GIVE SUGGESTIONS AND RESET THE KEY OPTIONS ---

ELEMENT TYPE 1 IS SHELL181. IT IS ASSOCIATED WITH ELASTOPLASTIC
MATERIALS ONLY. KEYOPT(8) IS ALREADY SET AS SUGGESTED. KEYOPT(3)=2
IS SUGGESTED FOR HIGHER ACCURACY OF MEMBRANE STRESSES; OTHERWISE,
KEYOPT(3)=0 IS SUGGESTED. KEYOPT(3) CAN NOT BE RESET HERE. PLEASE RESET
IT MANUALLY IF NECESSARY.



*** WARNING *** CP = 13.078 TIME= 16:47:42
A check of your model data produced 1 warnings.
Should the SOLV command be executed? [y/n]

*** NOTE *** CP = 13.080 TIME= 16:47:42
*** The SOLVE command aborted ***

SOLU_LS1:

WRITE ALL COMPONENTS TO THE COMPONENTS FILE.
START WRITING AT THE BEGINNING OF FILE ANSYS.cm

COMPONENTS WERE WRITTEN TO FILE= ANSYS.cm

SOLU_LS1:

FINISH SOLUTION PROCESSING


***** ROUTINE COMPLETED ***** CP = 13.083



*** NOTE *** CP = 13.083 TIME= 16:47:42
A total of 4 warnings and errors written to
/...../FluidFSI_006.ansys/ANSYS.err.

BEGIN:

PURGE ALL SOLUTION AND POST DATA
SAVE ALL MODEL DATA

*** NOTE *** CP = 13.086 TIME= 16:47:42
NEW BACKUP FILE NAME= ANSYS.dbb.

ALL CURRENT ANSYS DATA WRITTEN TO FILE NAME= ANSYS.db
FOR POSSIBLE RESUME FROM THIS POINT


NUMBER OF WARNING MESSAGES ENCOUNTERED= 4
NUMBER OF ERROR MESSAGES ENCOUNTERED= 0

DATA INPUT WRITTEN ON /......./FluidFSI_006.ansys/ANSYS.log

+--------------------- A N S Y S S T A T I S T I C S --------------------





CFX output
+--------------------------------------------------------------------+
| Convergence History |
+--------------------------------------------------------------------+

+--------------------------------------------------------------------+
| Writing transient file 0_full.trn |
| Name : Transient Results 1 |
| Type : Standard |
| Option : Every Timestep |
+--------------------------------------------------------------------+

+--------------------------------------------------------------------+
| ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| CFX encountered the error: Read. Fatal error occurred when reque- |
| sting Total Mesh Displacement for wall. |
| |
| |
| |
| |
+--------------------------------------------------------------------+

+--------------------------------------------------------------------+
| ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| cplg_SendCommand failed to send the command: ERROR -- CFX encount- |
| ered the error: Read. Fatal error occurred when requesting Total |
| Mesh Displacement for wall. |
| |
| |
| |
+--------------------------------------------------------------------+

+--------------------------------------------------------------------+
| ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| Stopped in routine cplg_SendCommand |
| |
| |
| |
| |
| |
+--------------------------------------------------------------------+

+--------------------------------------------------------------------+
| An error has occurred in cfx5solve: |
| |
| The ANSYS CFX solver could not be started, or exited with return |
| code 255. No results file has been created. |
+--------------------------------------------------------------------+

End of solution stage.

lingdeer November 6, 2011 17:56

Oh its warning not error, by the way.

Thanks!!!

solomedic November 8, 2011 00:49

At lingdeer. Theerror you are getting is due to larg mesh displacement.you can make the run to cont, by using smaller timestep,or by making the mapped meshing.

lingdeer November 8, 2011 17:47

Thanks Solomedic!
Can you give me some advice on how to do the mapping? Or maybe which tutorial/guide should I look at? There are so many of them out there.
Thank you! :)

mvoss November 10, 2011 07:00

What do you mean by "mapped meshing" ? Remesh after the deformation and map the data onto the new mesh?

lingdeer November 10, 2011 11:27

to map the mesh to the solid I guess. Either way as long as it solves my problem. Thanks!

lingdeer November 16, 2011 20:28

I finally found the solution to this to suppress warning which prompt the 2way FSI simulations from another forum:

http://www.xansys.org/forum/viewtopi...ghlight=#70787

Since this problem bothered me for 2 months, I hope this will help someone else!

Nil December 23, 2012 01:52

Quote:

Originally Posted by lingdeer (Post 332439)
I finally found the solution to this to suppress warning which prompt the 2way FSI simulations from another forum:

http://www.xansys.org/forum/viewtopi...ghlight=#70787

Since this problem bothered me for 2 months, I hope this will help someone else!

Hi!.I am new in FSI and I am also facing the same problem. I am trying to work on human-artery using 2-way FSI. The error I am getting is:

" ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| CFX encountered the error: Read. Fatal error occurred when reque- |
| sting Total Mesh Displacement for Default Domain Default. "

I tried the "mapped meshing" and reduced my time-steps, (0.001s), but no luck :( I saw your link, but I couldn't get this. My apologies for that.

I believe you have solved this problem; so would you pls suggest me how to solve this one? It is getting very frustrating for me.

Thanks!

solomedic December 23, 2012 11:33

Quote:

Originally Posted by lingdeer (Post 332439)
I finally found the solution to this to suppress warning which prompt the 2way FSI simulations from another forum:

http://www.xansys.org/forum/viewtopi...ghlight=#70787

Since this problem bothered me for 2 months, I hope this will help someone else!

Can you please explain it hear, how got rid of that error?

SimonSomething March 15, 2013 08:07

Import geometery for 2way FSI
 
Sorry this is a bit off topic but I could really use some help.

I'm doing a 2way FSI analysis, very similar to the example.

It works fine until I try to use my own geometry. I'm importing parasolid files from solidworks and putting them in designmodeler.

I have even tried building the exact same geometry as the example but I still always get an error when I try to solve it.

Any help would be appreciated.

mvoss March 15, 2013 09:42

what kind of error? maybe start a new thread...

faraday34 June 13, 2013 16:44

To Nil
 
Have you solved the problem? I would be glad if you can share it bec. I have the same error in simulating flow through a vessel.

Thank you so much

Quote:

Originally Posted by Nil (Post 398734)
Hi!.I am new in FSI and I am also facing the same problem. I am trying to work on human-artery using 2-way FSI. The error I am getting is:

" ERROR #001100279 has occurred in subroutine ErrAction. |
| Message: |
| CFX encountered the error: Read. Fatal error occurred when reque- |
| sting Total Mesh Displacement for Default Domain Default. "

I tried the "mapped meshing" and reduced my time-steps, (0.001s), but no luck :( I saw your link, but I couldn't get this. My apologies for that.

I believe you have solved this problem; so would you pls suggest me how to solve this one? It is getting very frustrating for me.

Thanks!


ronggehejiumeizuiguo December 29, 2014 21:40

Quote:

Originally Posted by lingdeer (Post 329748)
I have the same problem....but it just forces my FSI simulation to stop
(no error but same warnings....)
It works for the steady case though (warnings are ignored)
but transient it didnt work....

hi,
the same problme i meet,when steady,the computer can solve it,but transient it didnt work,have u solve it?


All times are GMT -4. The time now is 08:21.