CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums

Comments

Register Blogs Members List Search Today's Posts Mark Forums Read

  1. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    I am experiencing the error LINK : fatal error LNK1104: cannot open file 'LIBCMT.LIB. I have tried Michael's method but i failed to make it work.

    Anyone has any other solutions to this?
    permalink
    Posted August 23, 2015 at 03:38 by tsaget tsaget is offline
  2. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Hi all,

    thanks dear Trollreign for your detailed explanation.
    unfortunately I have done all he same procedure mentioned but I couldn't compile the UDF.

    The system I am using:
    windows 8.1 x64
    visual studio 2013 ultimate
    visual studio 2010 ultimate
    Ansys fluent version 2015

    problem of "nmake" solved by installing both fluent and visual studios in the C:\ root. before installing in the same root I got that error.

    I still get the error
    The UDF library you are trying to load (libudf) is not compiled for 2d on the curent platform (win64).

    I am not an expert fluent user and the purpose of posting was only to share my experience. (failure experience )

    any comments would be appreciated.

    Best regards,
    Parham
    permalink
    Posted July 17, 2015 at 04:38 by Parham Vatankhah Parham Vatankhah is offline
  3. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    hi trollreign,

    this was a fantastic post. you saved me a lot of time!

    thanks
    ak
    permalink
    Posted July 10, 2015 at 03:43 by ak6g08 ak6g08 is offline
  4. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Hi all,

    I encountered the same problem:
    LINK : fatal error LNK1104: cannot open file 'LIBCMT.lib2

    The solution came when I added the following line in the path variable (see p.7 of the present post):

    ;C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\Tools;C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin;C:\Program Files\ANSYS Inc\v120\fluent\ntbin\win64
    permalink
    Posted January 14, 2015 at 10:59 by MichaelVS MichaelVS is offline
  5. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Quote:
    Originally Posted by MichaelVS View Comment
    Dear trollreign,

    Thank you very much for detailed description!
    Could you please specify how to "Start Fluent with "C:\Program Files\ANSYS Inc\v140\ fluent\fluent14.0.0\launcher\win64"". "win64" is a folder, how could i start fluent with it?
    I think it represents something like:
    "C:\Program Files\ANSYS Inc\v140\fluent\ fluent14.0.0\launcher\win64\launcher1.exe"
    or
    "C:\Program Files\ANSYS Inc\v140\fluent\ntbin\win64\fluent.exe" -r14.0.0 -shortcut
    that starts the Fluent Launcher panel, click OK you will enter Fluent, then load your case.
    permalink
    Posted July 29, 2014 at 23:07 by p36288 p36288 is offline
    Updated July 30, 2014 at 03:27 by p36288
  6. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    For anyone who don't have VS2010, there is a simple way solve the math.h problem:
    find the line as:

    _CRTIMP double __cdecl cbrt(_In_ double _X);

    delete or comment it.
    In VS 2013, it is located at Line 482.
    permalink
    Posted July 29, 2014 at 12:38 by p36288 p36288 is offline
  7. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    I encountered the below error, followed the step 1-5 and resolved it

    The UDF library you are trying to load (libudf) is not compiled for 2d on the curent platform (win64).
    The system cannot find the file specified.

    X:\<your working folder>libudf\win64\2d\libudf.dll
    #----------------------------------------------------------

    Step-1 : Enable visualization technology in the BIOS setting in Windows 8 or 7

    Step-2 : install Microsoft visual studio 2012 express

    Step-3 : open VS2012 X64 Cross tools Command Prompt, change directory to working folder , where you have the *.c file

    Step-4 : open Fluent V14.5 through step-3 command prompt window, make sure you open with appropriate 2D or 3D double precision options

    Step-5 : compile the UDF
    permalink
    Posted June 4, 2014 at 22:53 by jthiakz jthiakz is offline
  8. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    In the end, I uninstalled Microsoft Visual Studio Express 2010 and 2013. I installed Microsoft Visual Studio 2010 Ultimate and everything works!
    permalink
    Posted April 29, 2014 at 07:40 by macfly macfly is offline
  9. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Quote:
    Originally Posted by macfly View Comment
    Me too, at some point, I got the error "fatal error LNK1104: cannot open file 'libcmt.lib'."

    Then I found out that libcmt.lib is only present in the Microsoft Visual C++ 2010 Express (C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\lib).

    So I started to just use Microsoft Visual C++ 2010 Express, i.e. start Fluent from the Visual Studio Command Prompt (2010).

    My udf compiled flawlessly! I'm halfway there...

    But then when I try to load it, I got the following error:
    Opening library "my working directory\libudf"...
    Error: Error code: 193

    And I'm stuck... Anybody knows what to do with this error?

    Thanks.
    Same problem here. Help please!
    permalink
    Posted April 29, 2014 at 05:49 by warrior warrior is offline
  10. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Me too, at some point, I got the error "fatal error LNK1104: cannot open file 'libcmt.lib'."

    Then I found out that libcmt.lib is only present in the Microsoft Visual C++ 2010 Express (C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\lib).

    So I started to just use Microsoft Visual C++ 2010 Express, i.e. start Fluent from the Visual Studio Command Prompt (2010).

    My udf compiled flawlessly! I'm halfway there...

    But then when I try to load it, I got the following error:
    Opening library "my working directory\libudf"...
    Error: Error code: 193

    And I'm stuck... Anybody knows what to do with this error?

    Thanks.
    permalink
    Posted April 23, 2014 at 19:06 by macfly macfly is offline
  11. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Quote:
    Originally Posted by nenazarian View Comment
    I followed all these steps and now I get another error, similar to yours:
    LNK2019: unresolved external symbol

    Any suggestions?
    Did you solve it?
    permalink
    Posted February 18, 2014 at 07:40 by hrvig hrvig is offline
  12. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Hi,
    Thanks a lot for your guide. I've been trying to get UDFs til work for some time now.
    I am getting an error:

    LINK : fatal error LNK1104: cannot open file 'LIBCMT.lib2

    Does anyone have any suggestions on how to fix it?

    (windows 8.1, installed visual studio express 2013, visual studio 2010 (to get the old math.h), Microsoft .NET Framework 4.5.1, Windows Software Development Kit 8, and ANSYS Fluent v15 x64)

    Best regards,
    Jakob
    permalink
    Posted February 18, 2014 at 07:35 by hrvig hrvig is offline
  13. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Hi Trollreign,

    I am facing the x64 system problem. I have Fluent 14, win 7 and Visual Studio from 2008 to 2012.

    I have tried to start Fluent from the VS2012 Cross Tools command prompt and it didn't work. Then I decided to update the environment variables as Messi indicated in the post http://www.cfd-online.com/Forums/flu...tml#post471365
    I've used SDK v7.1A and visual studio 11 (I don't know why I haven't got a Visual Studio 2012 folder) instead of v6.0A and 9.
    This hasn't solved my problem either.
    Now I'm having this message:

    Code:
    c:\program files\ansys inc\v140\fluent\fluent14.0.0\src\global.h(10) : fatal error C1083: Cannot open the include archive: 'stdio.h': Invalid argument
    And then the former error:

    Code:
    Opening library "c:\users\<working directory>libudf"...
    Error: The UDF library you are trying to load (C:\Users\<working directory>\libudf) is not compiled for 3d on the curent platform (win64).
    What should I try next?

    Any comment would be highly appreciated.

    Thanks a lot!
    permalink
    Posted January 28, 2014 at 05:58 by Bollonga Bollonga is offline
  14. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Quote:
    Originally Posted by giovanni.el View Comment
    Dear Trollreign,
    Thanx for your help.
    I followed all the steps until 6.2, but when I start fluent again and i try to compile my UDF I get this message: "fatal error LNK1104: cannot open file 'LIBCMT.lib' ".
    Do you have any idea how to solve this issue?
    I followed all these steps and now I get another error, similar to yours:
    LNK2019: unresolved external symbol

    Any suggestions?
    permalink
    Posted January 24, 2014 at 14:41 by nenazarian nenazarian is offline
  15. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Dear Trollreign,
    Thanx for your help.
    I followed all the steps until 6.2, but when I start fluent again and i try to compile my UDF I get this message: "fatal error LNK1104: cannot open file 'LIBCMT.lib' ".
    Do you have any idea how to solve this issue?
    permalink
    Posted January 19, 2014 at 11:51 by giovanni.el giovanni.el is offline
  16. Old Comment

    Getting ANSYS 14 Fluent, Windows 8.1 and VS2013 to compile UDFs

    Dear trollreign,

    Thank you very much for detailed description!
    Could you please specify how to "Start Fluent with "C:\Program Files\ANSYS Inc\v140\ fluent\fluent14.0.0\launcher\win64"". "win64" is a folder, how could i start fluent with it?
    permalink
    Posted December 3, 2013 at 10:40 by MichaelVS MichaelVS is offline

All times are GMT -4. The time now is 00:46.