CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CD-adapco

Problem: graphics display in prostar main window

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 19, 2001, 11:32
Default Problem: graphics display in prostar main window
  #1
Jiaying Xu
Guest
 
Posts: n/a
Hi, there,

I am now using my PC to logon a remote UNIX machine (actually, an SGI IRIX machine) where the StarCD is installed, to run StarCD. I encounter some starnge problem regarding the graphics display in prostar main window, as decribed below.

If some dialogue box, or anything else changing the appearance of the screen, happens to appear in the prostar main window, it sweepes the shown contents of prostar main window which was covered. This is of course reasonable. But it is unreasonable that the cleaned contents never appear again and thus are lost. Okey, someone may suggest me to press replot button to refresh the shown graphics. This solves the problem partly though it is inconvenient. However, it won't work during some operations when the mouse and keyboard are not released to take another action untill the engaged task is finished. For an instance, to define a cell set by pressing button series "C->", "New", "Zone..." - here the mouse is engaged to define a zone and can't press replot button. Another horibble example, To capture the graphics such as velocity plot shown in the main window, I pull down menu "Utility" and go "Save Screen as", "GIF...", type a name in the popup dialogue, press "OK",...Guess what I will get finally? The obtained GIF picture even includes the dialogue box! It will clearly explain the problem if I can put a picture onto the disscussion board.

I logon the unix machine from my PC via three approachs: 1) use Exceed of Hummingbird Communication Ltd on MS Windows 98; 2) use X-Win32 of StarNet Communications Corp on win98; 3) use ssh on RedHat Linux 7.1. Only the first method works fine. But win98 always gives me the damned blue screen and terminates the computation on the remote host. I wish I can get a complete and cotrrect graphics showing on Linux like Windows with Exceed so that I can enjoy Linux's stability and native compatability with the host machine.

Anyone can help?

Thanks,

Jiaying
  Reply With Quote

Old   October 19, 2001, 13:44
Default Re: Problem: graphics display in prostar main wind
  #2
steve
Guest
 
Posts: n/a
You need to turn on backing store on the machine that you are using to display graphics (not the sgi). Each X installation has its own method for doing that so I cannot tell you how to do it for your specific setup. Search for backing store in your documentation.
  Reply With Quote

Old   October 19, 2001, 13:47
Default Re: Problem: graphics display in prostar main wind
  #3
Peter
Guest
 
Posts: n/a
hi jiaying,

your problem sounds familiar to me. i think you have a problem with the so called backing storage. after enabling backing storage your windows in the background should be refreshed automaticaly after the foreground window removes.

to enabling backing storage in exceed you have to go to Start/Programs/Exceed/Xconfig/Performance. for more details try http://www.hummingbird.com/exceeduse...1999/0133.html

i'm not sure what your problem under linux is - do you have the same (refresh) problem there or do you have troubles to redirect the graphics in general? in the first case you should ask your system administrator if backing store is activated - this should be done before starting the xserver (see the hummingbird support tread again - especially the users original question). if you have troubles to redirect the graphic display try the following: allow the sgi to send the display to your machine with 'xhost + name_of_sgi', then do the remote login on the sgi and enter 'export DISPLAY=name_of_linux:0.0' (the syntax may differ slightly depending on the kind of shell you're using - this should work on ksh or bash). normaly this works.

two additional points:

1. as a short time workaround try to work more with the command shell in prostar. after clicking a button take a look on the output window - you will find the command there. so for example enter 'cset news zone' or 'scdu gif number_of_gif' to do the operations mentioned above. at the beginning the command line seems to be not very comfortable but in the end it is faster than going through the panels - and it's easy to learn by observing the output window.

2.) there is a windows as well as a linux version of prostar available - maybe you can use this if your license allowes it.

hopes this help

regards

peter
  Reply With Quote

Old   October 19, 2001, 14:03
Default Re: Problem: graphics display in prostar main wind
  #4
Jiaying Xu
Guest
 
Posts: n/a
Thanks, Peter.

You got my point, but Exceed on Windows has been configured all right. What I need is to turn on the back storage on my linux. Besides, I have no problem to display graphics back to my PC screen while using ssh on linux to logon the remote SGI. That is, the X-session can be built up correctly with ssh.

So, how can I do this? It seems I need to do something with xinit on linux, as I read the URL (for Exceed) you gave me?

Need your further suggestion.

With thanks

Jiaying
  Reply With Quote

Old   October 19, 2001, 14:24
Default Re: Problem: graphics display in prostar main wind
  #5
Jiaying Xu
Guest
 
Posts: n/a
Which documentation, for X initialization on linux? Thanks, Jiaying.
  Reply With Quote

Old   October 19, 2001, 18:18
Default Re: Problem: graphics display in prostar main wind
  #6
peter
Guest
 
Posts: n/a
hello jiaying,

at the moment indeed i've only a suggestion what you can do and not the definite solution. i use suse-linux and not red-hat, so maybe the files are not in the same place, but i'm sure you will find them:

for enabling backing storage you have to add the option '+bs' to the call of the X server. try to enter 'X --' in the shell and check if the options name is the same (it should be, but ..). when starting the x-server suse linux reads a file named /etc/X11/XF86Config and writes some information to /var/log/XFree86.0.log.

in /etc/X11/XF86Config there is a section named 'ServerFlags' and i think there's the place for the '+bs' option. in /var/log/XFree86.0.log there is an entry ": Backing store disabled". which should change to enabled when everything works.

to be honest to you i tried this, but it didn't work the way i expected - this means that backing storage was enabled when i started the x server manualy from command line with the +bs option (but in this case several other things didn't work - no wonder if you take a look in the config-file) but the option was ignored when i included it in the config file. maybe this is only a syntax problem?

so, as i said before, it's only a suggestion, but i hope it helps anyway.

regards

peter

  Reply With Quote

Old   October 20, 2001, 13:45
Default Re: Problem: graphics display in prostar main wind
  #7
Jiaying Xu
Guest
 
Posts: n/a
Thanks, Peter,

Now I can turn on the backing store by issuing a command "xinit -- +bs" after a shell prompt, and prostar works fine!

But, it's because I change the default run level of linux from 5 (X11)to 3 (Text multiuser mode). I don't know how to invoke the backing store under run level 5. When I tried to issue command xinit or change file .xinitrc or something like that, it always gave me a warning message saying "fatal error, an X server already running" or something similiar.

Any idea to help me work this out under run level 5?

Thanks,

Jiaying
  Reply With Quote

Old   October 21, 2001, 14:36
Default Re: Problem: graphics display in prostar main wind
  #8
Jiaying Xu
Guest
 
Posts: n/a
Peter,

I've got answer from newsgroup: ucam.comp.linux. I should change a line in /etc/X11/gdm/gdm.conf from

0=/usr/bin/X11/X

to

0=/usr/bin/X11/X +bs

This works with my RedHat Linux 7.1. Thanks, anyway.

Jiaying
  Reply With Quote

Old   February 14, 2002, 09:08
Default Re: Problem: graphics display in prostar main wind
  #9
july
Guest
 
Posts: n/a
Hi... Try to use VNC Viewer connection... I'm using this and everything it's ok. you can download it from the net.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
graphics window locked? edi FLUENT 2 August 16, 2010 06:02
Change background color of graphics window laisquared FLUENT 3 February 25, 2009 10:28
About fluent graphics window EA FLUENT 0 March 8, 2006 23:55
Printing Graphics of Display Window in UNIX Jake FLUENT 1 June 11, 2003 09:48
How to change and fix the size of graphics window? Rob FLUENT 1 February 7, 2003 11:15


All times are GMT -4. The time now is 20:47.