CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CD-adapco

Setup on Redhat Linux 8.0 / OpenMotif Library

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 31, 2003, 18:25
Default Setup on Redhat Linux 8.0 / OpenMotif Library
  #1
Steve Lewis
Guest
 
Posts: n/a
I understand that Redhat Linux 8.0 uses a newer version of the OpenMotif libraries than what Prostar requires. What is the easiest way to setup a new machine with Redhat v8.0 for Prostar use? Can I just uninstall OpenMotif 2.2 and install OpenMotif 2.1? What other programs in Redhat will be affected by this? Can I get both versions to run concurrently? How?
  Reply With Quote

Old   April 1, 2003, 00:25
Default Re: Setup on Redhat Linux 8.0 / OpenMotif Library
  #2
cjtune
Guest
 
Posts: n/a
I just did a make, make install of the older OpenMotif 2.2.1 over 2.2.2 when I found out 2.2.2 wasn't compatible anymore.

To have both versions on your machine (installed from tarballs) I guess you'll need to know how to modify the makefiles to change the default installation directories and to those paths to ld.so.conf (run ldconfig afterwards).

I don't use Red Hat so I can't say for certain what will be affected by downgrading your OpenMotif libraries. Most likely nothing, as all Gnome and KDE programs only need their Gtk and Qt libraries respectively. Try running a GUI programs from the terminal and you can get to see error messages about missing or wrong widgets, if any.

  Reply With Quote

Old   April 2, 2003, 09:14
Default Re: Setup on Redhat Linux 8.0 / OpenMotif Library
  #3
steve
Guest
 
Posts: n/a
I know people who have installed both 2.1 and whatever the RH8.0 default is at the same time with no problems. If you ask the support people at adapco, I think they may be able to tell you how to download Motif 2.1. There should not be any conflicts between the two.
  Reply With Quote

Old   April 3, 2003, 10:20
Default Re: Setup on Redhat Linux 8.0 / OpenMotif Library
  #4
cjtune
Guest
 
Posts: n/a
Either OM 2.2.1 overwrites 2.2.2, or they coexist. Either way I have not noticed any problems on Mandrake Linux 9.0.

I've heard of people having success with LessTif (which should come with almost all Linux distros), but not me...

Last I checked, only OpenMotif 2.2.2 is available for download... but I had OpenMotif 2.2.1 stashed away somewhere for safekeeping.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluent-AMD-64bit-Linux-Redhat MCB FLUENT 4 January 19, 2007 15:39
Redhat Linux/CFX Meri CFX 1 June 1, 2005 06:43
CFX4-4 solver on Linux RedHat ver.8 YOSHIFUMI CFX 1 September 6, 2004 15:18
CFX5 on Redhat Linux 7.3 Ogbeni CFX 3 February 5, 2004 08:15
CFX5 with Linux RedHat 8.*. Jan Rusås CFX 6 November 4, 2002 03:06


All times are GMT -4. The time now is 15:48.