CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   CD-adapco (http://www.cfd-online.com/Forums/cd-adapco/)
-   -   hpc with absoft 7.5 (http://www.cfd-online.com/Forums/cd-adapco/53420-hpc-absoft-7-5-a.html)

Marcio August 4, 2003 11:13

hpc with absoft 7.5
 
Is it possible to compile a hpc run with absoft 7.5 instead of 7.0?


TomK August 4, 2003 13:17

Re: hpc with absoft 7.5
 
I don't know about 7.5, but we use 8.0.

cjtune August 4, 2003 20:53

Re: hpc with absoft 7.5
 
If you have problems with Absoft, try checking the website for patches to download. I had problems running 8.0 on Mandrake 9.1 recently but it's OK now.

allan August 5, 2003 13:32

Re: hpc with absoft 7.5
 
I sucessfully ran star hpc with v7.5 of the compiler and mandrake v 8.2

allan

allan August 5, 2003 13:35

Re: hpc with absoft 7.5
 
I sucessfully ran star hpc with v7.5 of the compiler and mandrake v 8.2

allan.


allan August 5, 2003 13:38

Re: hpc with absoft 7.5
 
what version of xmotif were you using? I've had problems with absoft v7.5 and mandrake 9.1

cheers

allan

Joern Beilke August 5, 2003 17:30

Re: hpc with absoft 7.5
 
You have to install the 2.1 version of the motif libs. It is no problem if both libs are installed at the same time.

For use with suse 8.2 I had to apply the latest patches to the 7.0 compiler and it works.

Marcio August 6, 2003 03:16

Re: hpc with absoft 7.5
 
Thank you for your replies,

I work with SuSe 8.0 Kernel 4-18-64 SMP and Fortran 7.5. and it is not possible to link an executable. I always receive a message about undefined references.

Joern,

could you please tell where I can find the patch for the compiler and the version 2.1 of the motif libs ??


cjtune August 6, 2003 04:10

Re: hpc with absoft 7.5
 
It's v2.2.1 of openMotif, as mentioned by Joern below. But without, it would only show as graphical glitches on your GUI (if it doesn't crash first) but not problems linking the executable. Check the Absoft website to see if you can patch it or upgrade for free to 8.0.

Joern Beilke August 6, 2003 04:16

Re: hpc with absoft 7.5
 
You can get the Absoft patches from

ftp://ftp.absoft.com/pub/linux/profortran7.0

or

ftp://ftp.absoft.com/pub/linux/profortran7.5

I put the openmotif on my homepage:

http://www.beilke-cfd.de/openmotif-2.1.30-8.i386.rpm

You have to run

rpm -i --force openmotif-2.1.30-8.i386.rpm

4xF August 7, 2003 13:10

Re: hpc with absoft 7.5
 
1) SuSE 8.0 comes already along with the openmotif libraries v2.1.30-MLI4. Check first if you have installed it (call YaST2 -> Install/Remove Software). Unless it is already installed, you do not need to install any supplementary rpm. If need to perform a prolinkl or a pmovlink, in which case you will need to install additional package call openmotif-devel (to install, check again in YaST2 -> Install/Remove Software)

2) Which kind of error message do you get? Which kind of object or libraries are missing?

Joern Beilke August 7, 2003 13:52

Re: hpc with absoft 7.5
 
suse 8.2 comes with openmotif 2.2 and prostar requires 2.1. Thats why one has to install the 2.1 in addition to the already installed 2.2.

4xF August 10, 2003 05:23

Re: hpc with absoft 7.5
 
I thought Marcio was working with SuSE 8.0, not with 8.2 (see Reply from Aug. 6). In the case you have SuSE 8.2, you need to install the "old" openmotif package with rpm -i --force --nodeps, as stated previously.


All times are GMT -4. The time now is 23:38.