CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > CD-adapco

hpc with absoft 7.5

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 4, 2003, 11:13
Default hpc with absoft 7.5
  #1
Marcio
Guest
 
Posts: n/a
Is it possible to compile a hpc run with absoft 7.5 instead of 7.0?

  Reply With Quote

Old   August 4, 2003, 13:17
Default Re: hpc with absoft 7.5
  #2
TomK
Guest
 
Posts: n/a
I don't know about 7.5, but we use 8.0.
  Reply With Quote

Old   August 4, 2003, 20:53
Default Re: hpc with absoft 7.5
  #3
cjtune
Guest
 
Posts: n/a
If you have problems with Absoft, try checking the website for patches to download. I had problems running 8.0 on Mandrake 9.1 recently but it's OK now.
  Reply With Quote

Old   August 5, 2003, 13:32
Default Re: hpc with absoft 7.5
  #4
allan
Guest
 
Posts: n/a
I sucessfully ran star hpc with v7.5 of the compiler and mandrake v 8.2

allan
  Reply With Quote

Old   August 5, 2003, 13:35
Default Re: hpc with absoft 7.5
  #5
allan
Guest
 
Posts: n/a
I sucessfully ran star hpc with v7.5 of the compiler and mandrake v 8.2

allan.

  Reply With Quote

Old   August 5, 2003, 13:38
Default Re: hpc with absoft 7.5
  #6
allan
Guest
 
Posts: n/a
what version of xmotif were you using? I've had problems with absoft v7.5 and mandrake 9.1

cheers

allan
  Reply With Quote

Old   August 5, 2003, 17:30
Default Re: hpc with absoft 7.5
  #7
Joern Beilke
Guest
 
Posts: n/a
You have to install the 2.1 version of the motif libs. It is no problem if both libs are installed at the same time.

For use with suse 8.2 I had to apply the latest patches to the 7.0 compiler and it works.
  Reply With Quote

Old   August 6, 2003, 03:16
Default Re: hpc with absoft 7.5
  #8
Marcio
Guest
 
Posts: n/a
Thank you for your replies,

I work with SuSe 8.0 Kernel 4-18-64 SMP and Fortran 7.5. and it is not possible to link an executable. I always receive a message about undefined references.

Joern,

could you please tell where I can find the patch for the compiler and the version 2.1 of the motif libs ??

  Reply With Quote

Old   August 6, 2003, 04:10
Default Re: hpc with absoft 7.5
  #9
cjtune
Guest
 
Posts: n/a
It's v2.2.1 of openMotif, as mentioned by Joern below. But without, it would only show as graphical glitches on your GUI (if it doesn't crash first) but not problems linking the executable. Check the Absoft website to see if you can patch it or upgrade for free to 8.0.
  Reply With Quote

Old   August 6, 2003, 04:16
Default Re: hpc with absoft 7.5
  #10
Joern Beilke
Guest
 
Posts: n/a
You can get the Absoft patches from

ftp://ftp.absoft.com/pub/linux/profortran7.0

or

ftp://ftp.absoft.com/pub/linux/profortran7.5

I put the openmotif on my homepage:

http://www.beilke-cfd.de/openmotif-2.1.30-8.i386.rpm

You have to run

rpm -i --force openmotif-2.1.30-8.i386.rpm
  Reply With Quote

Old   August 7, 2003, 13:10
Default Re: hpc with absoft 7.5
  #11
4xF
Guest
 
Posts: n/a
1) SuSE 8.0 comes already along with the openmotif libraries v2.1.30-MLI4. Check first if you have installed it (call YaST2 -> Install/Remove Software). Unless it is already installed, you do not need to install any supplementary rpm. If need to perform a prolinkl or a pmovlink, in which case you will need to install additional package call openmotif-devel (to install, check again in YaST2 -> Install/Remove Software)

2) Which kind of error message do you get? Which kind of object or libraries are missing?
  Reply With Quote

Old   August 7, 2003, 13:52
Default Re: hpc with absoft 7.5
  #12
Joern Beilke
Guest
 
Posts: n/a
suse 8.2 comes with openmotif 2.2 and prostar requires 2.1. Thats why one has to install the 2.1 in addition to the already installed 2.2.
  Reply With Quote

Old   August 10, 2003, 05:23
Default Re: hpc with absoft 7.5
  #13
4xF
Guest
 
Posts: n/a
I thought Marcio was working with SuSE 8.0, not with 8.2 (see Reply from Aug. 6). In the case you have SuSE 8.2, you need to install the "old" openmotif package with rpm -i --force --nodeps, as stated previously.
  Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
absoft fortran 9 linux murash-v CD-adapco 5 August 22, 2007 04:44
Absoft F90 compiler for Star-CD 3.26 marcus CD-adapco 0 April 24, 2006 11:39
Star-CD v.3.22 and Absoft compiler Alex CD-adapco 1 November 21, 2004 05:44
Absoft Pro Fortran 7.5 in Fluent 4.5 Thitikorn FLUENT 0 July 5, 2002 06:41
Absoft environmentals joel CD-adapco 2 June 21, 2002 11:12


All times are GMT -4. The time now is 10:12.